From b593ea30833ad5dcacb9076c988aec31b0cf26ec Mon Sep 17 00:00:00 2001
From: Martin Lucina
Date: Mon, 23 Jan 2012 08:53:57 +0100
Subject: Imported Upstream version 2.1.7
---
AUTHORS | 1 +
ChangeLog | 249 ++++++++++++++++++++++++++++++++++++++++++++++++
NEWS | 35 +++++++
configure | 20 ++--
doc/zmq.7 | 6 +-
doc/zmq_bind.3 | 10 +-
doc/zmq_bind.html | 8 +-
doc/zmq_bind.txt | 4 +-
doc/zmq_close.3 | 10 +-
doc/zmq_close.html | 8 +-
doc/zmq_close.txt | 4 +-
doc/zmq_connect.3 | 10 +-
doc/zmq_connect.html | 8 +-
doc/zmq_connect.txt | 4 +-
doc/zmq_cpp.7 | 6 +-
doc/zmq_device.3 | 6 +-
doc/zmq_epgm.7 | 6 +-
doc/zmq_errno.3 | 6 +-
doc/zmq_getsockopt.3 | 10 +-
doc/zmq_getsockopt.html | 8 +-
doc/zmq_getsockopt.txt | 4 +-
doc/zmq_init.3 | 6 +-
doc/zmq_inproc.7 | 6 +-
doc/zmq_ipc.7 | 6 +-
doc/zmq_msg_close.3 | 6 +-
doc/zmq_msg_copy.3 | 6 +-
doc/zmq_msg_data.3 | 6 +-
doc/zmq_msg_init.3 | 6 +-
doc/zmq_msg_init_data.3 | 6 +-
doc/zmq_msg_init_size.3 | 6 +-
doc/zmq_msg_move.3 | 6 +-
doc/zmq_msg_size.3 | 6 +-
doc/zmq_pgm.7 | 6 +-
doc/zmq_poll.3 | 8 +-
doc/zmq_poll.html | 6 +-
doc/zmq_poll.txt | 2 +-
doc/zmq_recv.3 | 10 +-
doc/zmq_recv.html | 8 +-
doc/zmq_recv.txt | 4 +-
doc/zmq_send.3 | 10 +-
doc/zmq_send.html | 8 +-
doc/zmq_send.txt | 4 +-
doc/zmq_setsockopt.3 | 10 +-
doc/zmq_setsockopt.html | 8 +-
doc/zmq_setsockopt.txt | 4 +-
doc/zmq_socket.3 | 6 +-
doc/zmq_socket.html | 4 +-
doc/zmq_strerror.3 | 6 +-
doc/zmq_tcp.7 | 6 +-
doc/zmq_term.3 | 8 +-
doc/zmq_term.html | 6 +-
doc/zmq_term.txt | 2 +-
doc/zmq_version.3 | 6 +-
include/zmq.h | 5 +-
src/ctx.cpp | 9 ++
src/ctx.hpp | 6 ++
src/decoder.cpp | 4 +-
src/dist.cpp | 72 +++++++-------
src/dist.hpp | 20 ++--
src/err.cpp | 112 +++++++++++-----------
src/err.hpp | 12 +++
src/rep.cpp | 21 ++--
src/socket_base.cpp | 9 ++
src/socket_base.hpp | 6 ++
src/tcp_connecter.cpp | 9 +-
src/xrep.cpp | 18 +++-
src/xrep.hpp | 1 +
src/zmq.cpp | 32 +++----
zeromq.spec | 2 +-
69 files changed, 659 insertions(+), 300 deletions(-)
diff --git a/AUTHORS b/AUTHORS
index 3ca57ce..43768e5 100644
--- a/AUTHORS
+++ b/AUTHORS
@@ -60,6 +60,7 @@ Tero Marttila
Terry Wilson
Thijs Terlouw
Toralf Wittner
+Tore Halvorsen
Vitaly Mayatskikh
Credits
diff --git a/ChangeLog b/ChangeLog
index 5a9a3e7..f15734e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,254 @@
# Generated by Makefile. Do not edit.
+commit c35f65a82f1dace3a0b9afc5185dc3efc35595b5
+Author: Pieter Hintjens
+Date: Thu May 12 12:07:51 2011 +0200
+
+ Updated NEWS for 2.1.7
+
+ NEWS | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit dae5a6cb9e589e2471558dc86c55202558e918c2
+Author: Martin Sustrik
+Date: Sun May 8 09:03:49 2011 +0200
+
+ Async connect doesn't fail on WSAENETDOWN
+
+ Signed-off-by: Martin Sustrik
+
+ NEWS | 9 +++-
+ src/err.cpp | 112 ++++++++++++++++++++++++++-----------------------
+ src/err.hpp | 12 +++++
+ src/tcp_connecter.cpp | 10 ++--
+ 4 files changed, 82 insertions(+), 61 deletions(-)
+
+commit 46738270c22c134b8bbd7546ba4c6864b42f4c75
+Author: Martin Sustrik
+Date: Sat Apr 9 09:46:59 2011 +0200
+
+ Missing ENOTSOCK added on Win32
+
+ Signed-off-by: Martin Sustrik
+
+ include/zmq.h | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 52318cf705f9b0a73e88b8296d10291f7ba22a86
+Merge: c42d156 141a001
+Author: Pieter Hintjens
+Date: Sat May 7 07:23:21 2011 +0200
+
+ Updated NEWS
+
+commit c42d156fb94b5131d385f08ff93659ffd2944e21
+Author: Pieter Hintjens
+Date: Sat May 7 07:20:10 2011 +0200
+
+ Updated NEWS
+
+ NEWS | 11 +++++++----
+ 1 files changed, 7 insertions(+), 4 deletions(-)
+
+commit 141a001b046a1206336642b7aa401cbd5e82b826
+Author: Pieter Hintjens
+Date: Fri May 6 17:09:36 2011 +0200
+
+ Updated news for issue 211
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 9a08c71d7d63544d55620391d12fab4269e3a4df
+Author: Pieter Hintjens
+Date: Fri May 6 17:03:18 2011 +0200
+
+ Fixed issue 211 - REP assert on missing envelope
+
+ src/rep.cpp | 21 ++++++++++++++-------
+ src/xrep.cpp | 12 +++++++++++-
+ src/xrep.hpp | 1 +
+ 3 files changed, 26 insertions(+), 8 deletions(-)
+
+commit ddffe5db3351fbaff6086157e6a351e935d37d2e
+Author: Martin Sustrik
+Date: Fri May 6 15:51:56 2011 +0200
+
+ Current pipe pointer in XREP out of range -- fixed.
+
+ Signed-off-by: Martin Sustrik
+
+ src/xrep.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 96861b9d405663d71926b21843220481ebd33062
+Author: Martin Sustrik
+Date: Sat Apr 9 09:35:34 2011 +0200
+
+ Run-time checking for context & socket validity added
+
+ Signed-off-by: Martin Sustrik
+
+ NEWS | 3 +++
+ doc/zmq_bind.txt | 4 ++--
+ doc/zmq_close.txt | 4 ++--
+ doc/zmq_connect.txt | 4 ++--
+ doc/zmq_getsockopt.txt | 4 ++--
+ doc/zmq_recv.txt | 4 ++--
+ doc/zmq_send.txt | 4 ++--
+ doc/zmq_setsockopt.txt | 4 ++--
+ doc/zmq_term.txt | 2 +-
+ src/ctx.cpp | 9 +++++++++
+ src/ctx.hpp | 6 ++++++
+ src/socket_base.cpp | 9 +++++++++
+ src/socket_base.hpp | 6 ++++++
+ src/zmq.cpp | 32 ++++++++++++++++----------------
+ 14 files changed, 64 insertions(+), 31 deletions(-)
+
+commit 24a669f96d44acd03e03212e8ad5c32ffa756f53
+Author: Martin Sustrik
+Date: Wed May 4 12:43:23 2011 +0200
+
+ Tore Halvorsen added to the AUTHORS file
+
+ Signed-off-by: Martin Sustrik
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 4536f014071dd85c5520057f902e288c65e3cd2b
+Author: Tore Halvorsen
+Date: Wed May 4 12:41:10 2011 +0200
+
+ Accessing an iterator after it is accessed is not valid.
+
+ Moving the erase after the access and check agains current_id.
+
+ src/xrep.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 8e740d555b5b4383995cb3d81ff44c1e7add2da4
+Author: Pieter Hintjens
+Date: Wed May 4 15:52:26 2011 +0200
+
+ Clarified zmq_poll man page that timeout resolution is 1msec
+
+ NEWS | 1 +
+ doc/zmq_poll.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+commit 71cb36d04bd74ca82aca3868e665831733995be7
+Author: Pieter Hintjens
+Date: Tue May 3 17:30:21 2011 +0200
+
+ Fixed issue 206
+
+ NEWS | 2 ++
+ src/decoder.cpp | 4 ++--
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+commit 0fc54c9d14c8ff137e2b8aff6e472dcefb3a0c02
+Author: Pieter Hintjens
+Date: Mon May 2 20:09:11 2011 +0200
+
+ Updated NEWS
+
+ NEWS | 7 +++++++
+ 1 files changed, 7 insertions(+), 0 deletions(-)
+
+commit 16b725ddc978633b6349eb9353263c076ad9b702
+Author: Martin Sustrik
+Date: Mon May 2 19:28:51 2011 +0200
+
+ Current inpipe remains unchaged in XREP when other pipe terminates
+
+ When an inpipe terminated within XREP, it was erased from the array
+ and thus current_in (which is an index) pointed to a different
+ element in the array. This caused problems when we were in the
+ middle of reading a multipart message.
+
+ Signed-off-by: Martin Sustrik
+
+ src/xrep.cpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit c688f7536ea1a2f4f8d82fcc40f962bea230dd9e
+Author: Pieter Hintjens
+Date: Sat Apr 30 09:13:28 2011 +0200
+
+ Another fix to PUB sockets with multipart messages
+
+ src/dist.cpp | 18 ++++++++----------
+ 1 files changed, 8 insertions(+), 10 deletions(-)
+
+commit 10f0e7c71ed31530d3a56f9ae99ef926bfcb1090
+Author: Pieter Hintjens
+Date: Sat Apr 30 07:37:17 2011 +0200
+
+ Updated NEWS for issue 191
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 24e56e19a82035950dd721bb9d970294f508737e
+Merge: 33018b3 b6befaa
+Author: Pieter Hintjens
+Date: Sat Apr 30 07:36:30 2011 +0200
+
+ Merge branch 'issue191'
+
+commit b6befaad5d9ac6c4ccb13b1668b14696d7016c01
+Author: Pieter Hintjens
+Date: Sat Apr 30 07:36:16 2011 +0200
+
+ Message atomicity in pub sockets fixed - issue 191
+
+ src/dist.cpp | 4 +++-
+ src/dist.hpp | 3 ---
+ 2 files changed, 3 insertions(+), 4 deletions(-)
+
+commit 33018b30287777bf19ac292e38861b0c4b7e2599
+Author: Pieter Hintjens
+Date: Fri Apr 29 09:24:16 2011 +0200
+
+ Updated NEWS
+
+ NEWS | 10 ++++++++++
+ 1 files changed, 10 insertions(+), 0 deletions(-)
+
+commit 7dc87c59ded306970763c928ff0c4c350e2a2453
+Author: Martin Sustrik
+Date: Fri Apr 29 07:23:30 2011 +0200
+
+ WSAENETUNREACH is a valid networking error
+
+ Till now, 0MQ asserted on Windows when connect () returned
+ WSAENETUNREACH.
+
+ Signed-off-by: Martin Sustrik
+
+ src/tcp_connecter.cpp | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+commit be403bf2ba1b61355cd0d2f8f6609408b71cde99
+Author: Pieter Hintjens
+Date: Fri Apr 29 09:22:29 2011 +0200
+
+ Downstreamed patch for issue 191
+
+ src/dist.cpp | 70 ++++++++++++++++++++++++++++++---------------------------
+ src/dist.hpp | 17 +++++++------
+ 2 files changed, 46 insertions(+), 41 deletions(-)
+
+commit 0ec42592f31faa5e98faa38961ee736d892e0783
+Author: Pieter Hintjens
+Date: Tue Apr 26 19:57:16 2011 +0200
+
+ Bumped version number for 2.1.7
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
commit ee185e241ec2a3091b9200cd5615cfa4f66e7a07
Author: Pieter Hintjens
Date: Tue Apr 26 19:45:25 2011 +0200
diff --git a/NEWS b/NEWS
index 3ad869d..8fc0892 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,37 @@
+0MQ version 2.1.7 (Stable), released on 2011/05/12
+==================================================
+
+Bug fixes
+---------
+
+* Fixed issue 191, message atomicity issue with PUB sockets (an old issue).
+
+* Fixed issue 199 (affected ROUTER/XREP sockets, an old issue).
+
+* Fixed issue 206, assertion failure in zmq.cpp:223, affected all sockets
+ (bug was introduced in 2.1.6 as part of message validity checking).
+
+* Fixed issue 211, REP socket asserted if sent malformed envelope (old issue
+ due to abuse of assertions for error checking).
+
+* Fixed issue 212, reconnect failing after resume from sleep on Windows
+ (due to not handling WSAENETDOWN).
+
+* Properly handle WSAENETUNREACH on Windows (e.g. if client connects
+ before server binds).
+
+Changes
+-------
+
+* Runtime checking of socket and context validity, to catch e.g. using a
+ socket after closing it, or passing an invalid pointer to context/socket
+ methods.
+
+* Test cases moved off port 5555, which conflicts with other services.
+
+* Clarified zmq_poll man page that the resolution of the timeout is 1msec.
+
+
0MQ version 2.1.6 (Stable), released on 2011/04/26
==================================================
@@ -30,6 +64,7 @@ Note that this version contained a malformed patch and is not usable.
It is not available for download, but is available in the git via the
2.1.5 tag.
+
0MQ version 2.1.4 (Stable), released on 2011/03/30
==================================================
diff --git a/configure b/configure
index 8453dc1..1344c83 100755
--- a/configure
+++ b/configure
@@ -1,6 +1,6 @@
#! /bin/sh
# Guess values for system-dependent variables and create Makefiles.
-# Generated by GNU Autoconf 2.67 for zeromq 2.1.6.
+# Generated by GNU Autoconf 2.67 for zeromq 2.1.7.
#
# Report bugs to .
#
@@ -701,8 +701,8 @@ MAKEFLAGS=
# Identity of this package.
PACKAGE_NAME='zeromq'
PACKAGE_TARNAME='zeromq'
-PACKAGE_VERSION='2.1.6'
-PACKAGE_STRING='zeromq 2.1.6'
+PACKAGE_VERSION='2.1.7'
+PACKAGE_STRING='zeromq 2.1.7'
PACKAGE_BUGREPORT='zeromq-dev@lists.zeromq.org'
PACKAGE_URL=''
@@ -1467,7 +1467,7 @@ if test "$ac_init_help" = "long"; then
# Omit some internal or obsolete options to make the list less imposing.
# This message is too long to be a string in the A/UX 3.1 sh.
cat <<_ACEOF
-\`configure' configures zeromq 2.1.6 to adapt to many kinds of systems.
+\`configure' configures zeromq 2.1.7 to adapt to many kinds of systems.
Usage: $0 [OPTION]... [VAR=VALUE]...
@@ -1537,7 +1537,7 @@ fi
if test -n "$ac_init_help"; then
case $ac_init_help in
- short | recursive ) echo "Configuration of zeromq 2.1.6:";;
+ short | recursive ) echo "Configuration of zeromq 2.1.7:";;
esac
cat <<\_ACEOF
@@ -1659,7 +1659,7 @@ fi
test -n "$ac_init_help" && exit $ac_status
if $ac_init_version; then
cat <<\_ACEOF
-zeromq configure 2.1.6
+zeromq configure 2.1.7
generated by GNU Autoconf 2.67
Copyright (C) 2010 Free Software Foundation, Inc.
@@ -2414,7 +2414,7 @@ cat >config.log <<_ACEOF
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.
-It was created by zeromq $as_me 2.1.6, which was
+It was created by zeromq $as_me 2.1.7, which was
generated by GNU Autoconf 2.67. Invocation command line was
$ $0 $@
@@ -3233,7 +3233,7 @@ fi
# Define the identity of the package.
PACKAGE='zeromq'
- VERSION='2.1.6'
+ VERSION='2.1.7'
cat >>confdefs.h <<_ACEOF
@@ -19405,7 +19405,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_write_fail=1
# report actual input values of CONFIG_FILES etc. instead of their
# values after options handling.
ac_log="
-This file was extended by zeromq $as_me 2.1.6, which was
+This file was extended by zeromq $as_me 2.1.7, which was
generated by GNU Autoconf 2.67. Invocation command line was
CONFIG_FILES = $CONFIG_FILES
@@ -19471,7 +19471,7 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
ac_cs_version="\\
-zeromq config.status 2.1.6
+zeromq config.status 2.1.7
configured by $0, generated by GNU Autoconf 2.67,
with options \\"\$ac_cs_config\\"
diff --git a/doc/zmq.7 b/doc/zmq.7
index b5f0d27..60394d0 100644
--- a/doc/zmq.7
+++ b/doc/zmq.7
@@ -2,12 +2,12 @@
.\" Title: zmq
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 04/20/2011
+.\" Date: 05/06/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.5
+.\" Source: 0MQ 2.1.6
.\" Language: English
.\"
-.TH "ZMQ" "7" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
+.TH "ZMQ" "7" "05/06/2011" "0MQ 2\&.1\&.6" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_bind.3 b/doc/zmq_bind.3
index 8412806..ce589e9 100644
--- a/doc/zmq_bind.3
+++ b/doc/zmq_bind.3
@@ -2,12 +2,12 @@
.\" Title: zmq_bind
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 04/20/2011
+.\" Date: 05/07/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.5
+.\" Source: 0MQ 2.1.6
.\" Language: English
.\"
-.TH "ZMQ_BIND" "3" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
+.TH "ZMQ_BIND" "3" "05/07/2011" "0MQ 2\&.1\&.6" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -114,11 +114,11 @@ associated with the specified
was terminated\&.
.RE
.PP
-\fBEFAULT\fR
+\fBENOTSOCK\fR
.RS 4
The provided
\fIsocket\fR
-was not valid (NULL)\&.
+was invalid\&.
.RE
.PP
\fBEMTHREAD\fR
diff --git a/doc/zmq_bind.html b/doc/zmq_bind.html
index 11b8762..034113d 100644
--- a/doc/zmq_bind.html
+++ b/doc/zmq_bind.html
@@ -690,11 +690,11 @@ The ØMQ context associated with the specified socket was term
-EFAULT
+ENOTSOCK
-The provided socket was not valid (NULL).
+The provided socket was invalid.
@@ -738,8 +738,8 @@ Martin Lucina <mato@kotelna.sk>.<