From cbaa7cfa93893876e4fd8794b6ea39f4d245b6b5 Mon Sep 17 00:00:00 2001
From: Martin Lucina
Date: Mon, 23 Jan 2012 08:53:45 +0100
Subject: Imported Upstream version 2.1.6
---
doc/Makefile.in | 9 +++++++--
doc/zmq.7 | 6 +++---
doc/zmq_bind.3 | 6 +++---
doc/zmq_close.3 | 6 +++---
doc/zmq_connect.3 | 6 +++---
doc/zmq_cpp.7 | 6 +++---
doc/zmq_device.3 | 6 +++---
doc/zmq_epgm.7 | 8 +++++---
doc/zmq_epgm.html | 8 ++++++--
doc/zmq_epgm.txt | 5 +++++
doc/zmq_errno.3 | 6 +++---
doc/zmq_getsockopt.3 | 6 +++---
doc/zmq_init.3 | 6 +++---
doc/zmq_inproc.7 | 6 +++---
doc/zmq_ipc.7 | 6 +++---
doc/zmq_msg_close.3 | 13 ++++++++-----
doc/zmq_msg_close.html | 15 ++++++++++++---
doc/zmq_msg_close.txt | 3 ++-
doc/zmq_msg_copy.3 | 13 ++++++++-----
doc/zmq_msg_copy.html | 15 ++++++++++++---
doc/zmq_msg_copy.txt | 3 ++-
doc/zmq_msg_data.3 | 6 +++---
doc/zmq_msg_init.3 | 6 +++---
doc/zmq_msg_init_data.3 | 22 +++++++++++++++++++---
doc/zmq_msg_init_data.html | 13 +++++++++++--
doc/zmq_msg_init_data.txt | 3 +++
doc/zmq_msg_init_size.3 | 6 +++---
doc/zmq_msg_move.3 | 13 ++++++++-----
doc/zmq_msg_move.html | 15 ++++++++++++---
doc/zmq_msg_move.txt | 3 ++-
doc/zmq_msg_size.3 | 6 +++---
doc/zmq_pgm.7 | 8 +++++---
doc/zmq_pgm.html | 8 ++++++--
doc/zmq_pgm.txt | 5 +++++
doc/zmq_poll.3 | 6 +++---
doc/zmq_recv.3 | 11 ++++++++---
doc/zmq_recv.html | 12 ++++++++++--
doc/zmq_recv.txt | 2 ++
doc/zmq_send.3 | 13 ++++++++++---
doc/zmq_send.html | 15 +++++++++++++--
doc/zmq_send.txt | 6 ++++++
doc/zmq_setsockopt.3 | 6 +++---
doc/zmq_socket.3 | 13 +++++++++----
doc/zmq_socket.html | 14 +++++++++++---
doc/zmq_socket.txt | 4 +++-
doc/zmq_strerror.3 | 6 +++---
doc/zmq_tcp.7 | 6 +++---
doc/zmq_term.3 | 6 +++---
doc/zmq_version.3 | 6 +++---
49 files changed, 273 insertions(+), 125 deletions(-)
(limited to 'doc')
diff --git a/doc/Makefile.in b/doc/Makefile.in
index 35bf698..2db8cb3 100644
--- a/doc/Makefile.in
+++ b/doc/Makefile.in
@@ -142,6 +142,8 @@ OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@
OTOOL = @OTOOL@
OTOOL64 = @OTOOL64@
+OpenPGM_CFLAGS = @OpenPGM_CFLAGS@
+OpenPGM_LIBS = @OpenPGM_LIBS@
PACKAGE = @PACKAGE@
PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
PACKAGE_NAME = @PACKAGE_NAME@
@@ -150,6 +152,9 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
+PKG_CONFIG = @PKG_CONFIG@
+PKG_CONFIG_LIBDIR = @PKG_CONFIG_LIBDIR@
+PKG_CONFIG_PATH = @PKG_CONFIG_PATH@
RANLIB = @RANLIB@
SED = @SED@
SET_MAKE = @SET_MAKE@
@@ -164,8 +169,6 @@ abs_top_srcdir = @abs_top_srcdir@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
-ac_zmq_have_asciidoc = @ac_zmq_have_asciidoc@
-ac_zmq_have_xmlto = @ac_zmq_have_xmlto@
am__include = @am__include@
am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
@@ -194,6 +197,8 @@ infodir = @infodir@
install_sh = @install_sh@
libdir = @libdir@
libexecdir = @libexecdir@
+libzmq_have_asciidoc = @libzmq_have_asciidoc@
+libzmq_have_xmlto = @libzmq_have_xmlto@
localedir = @localedir@
localstatedir = @localstatedir@
lt_ECHO = @lt_ECHO@
diff --git a/doc/zmq.7 b/doc/zmq.7
index d7fa3be..b5f0d27 100644
--- a/doc/zmq.7
+++ b/doc/zmq.7
@@ -2,12 +2,12 @@
.\" Title: zmq
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ" "7" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ" "7" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_bind.3 b/doc/zmq_bind.3
index 9ff1109..8412806 100644
--- a/doc/zmq_bind.3
+++ b/doc/zmq_bind.3
@@ -2,12 +2,12 @@
.\" Title: zmq_bind
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_BIND" "3" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_BIND" "3" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_close.3 b/doc/zmq_close.3
index 520f0ac..43f47b3 100644
--- a/doc/zmq_close.3
+++ b/doc/zmq_close.3
@@ -2,12 +2,12 @@
.\" Title: zmq_close
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_CLOSE" "3" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_CLOSE" "3" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_connect.3 b/doc/zmq_connect.3
index 06435e8..534abb4 100644
--- a/doc/zmq_connect.3
+++ b/doc/zmq_connect.3
@@ -2,12 +2,12 @@
.\" Title: zmq_connect
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_CONNECT" "3" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_CONNECT" "3" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_cpp.7 b/doc/zmq_cpp.7
index c61797e..b5fb80a 100644
--- a/doc/zmq_cpp.7
+++ b/doc/zmq_cpp.7
@@ -2,12 +2,12 @@
.\" Title: zmq_cpp
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_CPP" "7" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_CPP" "7" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_device.3 b/doc/zmq_device.3
index 329360d..67ab7bb 100644
--- a/doc/zmq_device.3
+++ b/doc/zmq_device.3
@@ -2,12 +2,12 @@
.\" Title: zmq_device
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_DEVICE" "3" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_DEVICE" "3" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
diff --git a/doc/zmq_epgm.7 b/doc/zmq_epgm.7
index 1559950..3c4c7d1 100644
--- a/doc/zmq_epgm.7
+++ b/doc/zmq_epgm.7
@@ -2,12 +2,12 @@
.\" Title: zmq_pgm
.\" Author: [see the "AUTHORS" section]
.\" Generator: DocBook XSL Stylesheets v1.75.2
-.\" Date: 03/30/2011
+.\" Date: 04/20/2011
.\" Manual: 0MQ Manual
-.\" Source: 0MQ 2.1.4
+.\" Source: 0MQ 2.1.5
.\" Language: English
.\"
-.TH "ZMQ_PGM" "7" "03/30/2011" "0MQ 2\&.1\&.4" "0MQ Manual"
+.TH "ZMQ_PGM" "7" "04/20/2011" "0MQ 2\&.1\&.5" "0MQ Manual"
.\" -----------------------------------------------------------------
.\" * Define some portability stuff
.\" -----------------------------------------------------------------
@@ -124,6 +124,8 @@ data = *OCTET
.sp
In order for late joining consumers to be able to identify message boundaries, each PGM datagram payload starts with a 16\-bit unsigned integer in network byte order specifying either the offset of the first message \fIframe\fR in the datagram or containing the value 0xFFFF if the datagram contains solely an intermediate part of a larger message\&.
.sp
+Note that offset specifies where the first message begins rather than the first message part\&. Thus, if there are trailing message parts at the beginning of the packet the offset ignores them and points to first initial message part in the packet\&.
+.sp
The following diagram illustrates the layout of a single PGM datagram payload:
.sp
.if n \{\
diff --git a/doc/zmq_epgm.html b/doc/zmq_epgm.html
index 5506fa1..9383d71 100644
--- a/doc/zmq_epgm.html
+++ b/doc/zmq_epgm.html
@@ -672,6 +672,10 @@ each PGM datagram payload starts with a 16-bit unsigned integer in network byte
order specifying either the offset of the first message frame in the datagram
or containing the value 0xFFFF if the datagram contains solely an
intermediate part of a larger message.
+Note that offset specifies where the first message begins rather than the first
+message part. Thus, if there are trailing message parts at the beginning of
+the packet the offset ignores them and points to first initial message part
+in the packet.
The following diagram illustrates the layout of a single PGM datagram payload: