summaryrefslogtreecommitdiff
path: root/bindings/ruby/Makefile.am
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2009-09-16 17:06:59 +0200
committermalosek <malosek@fastmq.com>2009-09-16 17:06:59 +0200
commit1a655045951c29edda0b616640b9dac507cda164 (patch)
tree6cd013eda2331cd5a19e3cd19d14f35b997f3a7d /bindings/ruby/Makefile.am
parentc63387ca3657848c0eaa8014a863148c1e6525ff (diff)
ruby directory moved into bindings dir
Diffstat (limited to 'bindings/ruby/Makefile.am')
-rw-r--r--bindings/ruby/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/bindings/ruby/Makefile.am b/bindings/ruby/Makefile.am
new file mode 100644
index 0000000..148daf0
--- /dev/null
+++ b/bindings/ruby/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)/include -I$(top_builddir)/include
+
+rblib_LTLIBRARIES = librbzmq.la
+rblibdir = @RUBYDIR@
+
+librbzmq_la_SOURCES = rbzmq.cpp
+
+librbzmq_la_LDFLAGS = -version-info @RBLTVER@
+librbzmq_la_CXXFLAGS = -Wall -pedantic -Werror -Wno-long-long
+librbzmq_la_LIBADD = $(top_builddir)/src/libzmq.la
+