summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMikko Koppanen <mkoppanen@php.net>2010-10-16 01:05:15 +0200
committerMartin Sustrik <sustrik@250bpm.com>2010-10-16 01:05:15 +0200
commitb95f11aa0a7887f5eb8eb8e2e0f09532bc3604ba (patch)
tree0f11b2afe7c2eaa453b8831aba41c31d2944ee9a /configure.in
parent48b0a901b8056957e36ba52ae4416d656971bb47 (diff)
Don't set pedantic to yes if using ICC
Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 33fdfb4..e52180d 100644
--- a/configure.in
+++ b/configure.in
@@ -53,8 +53,13 @@ LIBZMQ_EXTRA_CXXFLAGS=""
# Extra LDFLAGS are appended at the end of LDFLAGS for libzmq.
LIBZMQ_EXTRA_LDFLAGS=""
-# By default compiling with -pedantic except QNX and OSX.
-pedantic="yes"
+# Enable -pedantic if not using icc, this may be overridden later
+AC_CHECK_LANG_ICC
+if test "xyes" = "x$ac_cv_c_intel_compiler" -o "xyes" = "x$ac_cv_cpp_intel_compiler"; then
+ pedantic="no"
+else
+ pedantic="yes"
+fi
#By default compiling with -Werror except OSX.
werror="yes"
@@ -325,11 +330,11 @@ if test "x$gnu_compilers" = "xyes" -a "x$pgm_ext" = "xno"; then
CPPFLAGS="-Wall $CPPFLAGS"
if test "x$pedantic" = "xyes"; then
- CPPFLAGS="-pedantic $CPPFLAGS"
+ CPPFLAGS="-pedantic $CPPFLAGS"
fi
if test "x$werror" = "xyes"; then
- CPPFLAGS="-Werror $CPPFLAGS"
+ CPPFLAGS="-Werror $CPPFLAGS"
fi
fi