summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMikko Koppanen <mkoppanen@php.net>2011-09-04 10:28:15 +0200
committerMartin Sustrik <sustrik@250bpm.com>2011-09-04 10:28:15 +0200
commit9d0e122bfad431d7b84ad43c0c62c8ebc9540a36 (patch)
tree8c785db91e3727a4f1aff244380264317d68008a /configure.in
parent193fa1c079fd886623e55810556a9461561ca139 (diff)
Added option to choose internal polling system
Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a31177..4065252 100644
--- a/configure.in
+++ b/configure.in
@@ -229,6 +229,10 @@ esac
# Check whether to build docs / install man pages
LIBZMQ_CHECK_DOC_BUILD
+# Check polling system
+LIBZMQ_CHECK_POLLER([CPPFLAGS="${CPPFLAGS} -D${libzmq_cv_poller_flag}"],
+ [AC_MSG_ERROR([Unable to continue without polling system])])
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(errno.h arpa/inet.h netinet/tcp.h netinet/in.h stddef.h \