summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-04-10 17:04:33 +0200
committerMartin Lucina <mato@kotelna.sk>2010-04-10 17:04:33 +0200
commitb668387d917cd80c5d4b9631bc0008b6a014c083 (patch)
treedf072a0890ecb717d6ea8ba1bf8ade8a482cd6d9 /configure.in
parentf6fa41dd7b3677d0f7441db83cbd6c8a0283a499 (diff)
Remove -Wxxx gcc-isms from subdir Makefiles
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ae944b4..a196a35 100644
--- a/configure.in
+++ b/configure.in
@@ -365,14 +365,14 @@ fi
# -Wall, -Werror and -pedantic are GNU compiler specific.
# Also, these break OpenPGM so don't specify them if we are building with it.
if test "x$gnu_compilers" = "xyes" -a "x$pgm_ext" = "xno"; then
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Wall"
+ CPPFLAGS="-Wall $CPPFLAGS"
if test "x$pedantic" = "xyes"; then
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -pedantic"
+ CPPFLAGS="-pedantic $CPPFLAGS"
fi
if test "x$werror" = "xyes"; then
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Werror"
+ CPPFLAGS="-Werror $CPPFLAGS"
fi
fi