summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-02-26 20:03:58 +0100
committerMartin Lucina <mato@kotelna.sk>2010-02-26 20:03:58 +0100
commitefefa069b2ce407a7da4328ab024c47920a76960 (patch)
treea0e49b055888297ce438fa21e3e4bb8f4e5631e0 /configure.in
parentdeda7ca54a3c8f1ba735e8654ca87f8808606122 (diff)
Cygwin support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ac46000..8e45f89 100644
--- a/configure.in
+++ b/configure.in
@@ -211,7 +211,14 @@ case "${host_os}" in
install_man="no"
;;
*cygwin*)
+ # Define on Cygwin to enable all library features
+ CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
AC_DEFINE(ZMQ_HAVE_CYGWIN, 1, [Have Cygwin])
+ # Cygwin provides libuuid as part of the e2fsprogs package, and somewhat
+ # uselessly installs the library in /usr/lib/e2fsprogs
+ LDFLAGS="${LDFLAGS} -L/usr/lib/e2fsprogs"
+ AC_CHECK_LIB(uuid, uuid_generate, ,
+ [AC_MSG_ERROR([cannot link with -luuid, install the e2fsprogs package.])])
;;
*)
AC_MSG_ERROR([unsupported system: ${host_os}.])