summaryrefslogtreecommitdiff
path: root/devices/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@fastmq.commkdir>2009-12-13 14:45:23 +0100
committerMartin Sustrik <sustrik@fastmq.commkdir>2009-12-13 14:45:23 +0100
commitfa6bf24d8030b0e54fd25b167064482e4cf08a36 (patch)
tree9f8f833da9607c9ba3376b45aa5cfafa4305e59c /devices/Makefile.am
parentc43aded531014895973c283fdd82bb2e5e85c789 (diff)
XREP & XREQ socket types added; zmq_queue device added
Diffstat (limited to 'devices/Makefile.am')
-rw-r--r--devices/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/devices/Makefile.am b/devices/Makefile.am
index ab18976..4f20456 100644
--- a/devices/Makefile.am
+++ b/devices/Makefile.am
@@ -6,5 +6,9 @@ if BUILD_STREAMER
STREAMER_DIR = zmq_streamer
endif
-SUBDIRS = $(FORWARDER_DIR) $(STREAMER_DIR)
-DIST_SUBDIRS = zmq_forwarder zmq_streamer
+if BUILD_QUEUE
+QUEUE_DIR = zmq_queue
+endif
+
+SUBDIRS = $(FORWARDER_DIR) $(STREAMER_DIR) $(QUEUE_DIR)
+DIST_SUBDIRS = zmq_forwarder zmq_streamer zmq_queue