summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2009-09-08 14:54:04 +0200
committermalosek <malosek@fastmq.com>2009-09-08 14:54:04 +0200
commit2a4a10c8be92c5ce6314378fc4de163888075279 (patch)
tree683df480e109aeff751d93d3b89b28a1f7311a3a /perf/Makefile.am
parentec6822a477b89ac77afc90425bf36c4829dbef3d (diff)
build system tuning
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index dbebc93..a3c13ad 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -1,2 +1,23 @@
-SUBDIRS = c cpp python
-DIST_SUBDIRS = c cpp python
+if BUILD_C
+PERF_DIR_C = c
+endif
+
+if BUILD_CPP
+PERF_DIR_CPP = cpp
+endif
+
+if BUILD_PYTHON
+PERF_DIR_P = python
+endif
+
+if BUILD_JAVA
+PERF_DIR_J = java
+endif
+
+if BUILD_RUBY
+PERF_DIR_R = ruby
+endif
+
+SUBDIRS = $(PERF_DIR_C) $(PERF_DIR_CPP) $(PERF_DIR_P) \
+ $(PERF_DIR_J) $(PERF_DIR_R)
+DIST_SUBDIRS = c cpp python java ruby