summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2010-12-04 23:14:38 +0100
committerMartin Sustrik <sustrik@250bpm.com>2010-12-04 23:14:38 +0100
commitc80e7b80cc726ca7c29493c2553c8d19792bb6e5 (patch)
tree9c740ee660e900766a6f7d7e8a48bb09a6b72c4b /src/Makefile.am
parentabc8b5e40c55deb96e7674b15629f2affa4eb92a (diff)
XPUB and XSUB socket types added.
These are just placeholders. At the moment XPUB behaves th same as PUB and XSUB as SUB. Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a857ee7..eea7d35 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -126,8 +126,10 @@ libzmq_la_SOURCES = \
uuid.hpp \
windows.hpp \
wire.hpp \
+ xpub.hpp \
xrep.hpp \
xreq.hpp \
+ xsub.hpp \
ypipe.hpp \
yqueue.hpp \
zmq_connecter.hpp \
@@ -181,8 +183,10 @@ libzmq_la_SOURCES = \
transient_session.cpp \
trie.cpp \
uuid.cpp \
+ xpub.cpp \
xrep.cpp \
xreq.cpp \
+ xsub.cpp \
zmq.cpp \
zmq_connecter.cpp \
zmq_engine.cpp \