summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-11-25 17:12:31 +0100
committerMartin Sustrik <sustrik@250bpm.com>2010-11-25 17:12:31 +0100
commitc9584096e033850c77c4c3d4ee99e8073f7b26da (patch)
tree1c87497cffc99288743e21798b9ac452917f618d /src/Makefile.am
parent734624be760b3c7942eb26bea77fca918cb1540d (diff)
Control symbol exports using -fvisibility
On systems using GCC 4.0 or newer which support symbol visibility in shared libraries, use -fvisibility=hidden and only export explict API functions defined in zmq.cpp. We do not enable -fvisibility on MinGW since this uses a separate mechanism (__declspec). Signed-off-by: Martin Lucina <mato@kotelna.sk>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 761d8e8..a857ee7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -203,7 +203,6 @@ libpgm_diff_flags = \
-DCONFIG_HAVE_ISO_VARARGS \
-DCONFIG_HAVE_TSC \
-DCONFIG_HAVE_WSACMSGHDR \
- -DCONFIG_HAVE_DSO_VISIBILITY \
-DCONFIG_BIND_INADDR_ANY
else
@@ -225,7 +224,6 @@ libpgm_diff_flags = \
-DCONFIG_HAVE_IP_MREQN \
-DCONFIG_HAVE_SPRINTF_GROUPING \
-DCONFIG_HAVE_VASPRINTF \
- -DCONFIG_HAVE_DSO_VISIBILITY \
-DCONFIG_BIND_INADDR_ANY \
-DCONFIG_HAVE_GETOPT
endif
@@ -237,6 +235,7 @@ libpgm_la_CFLAGS = -I$(top_srcdir)/foreign/openpgm/@pgm_basename@/openpgm/pgm/in
-DCONFIG_16BIT_CHECKSUM \
-DCONFIG_GALOIS_MUL_LUT \
-DGETTEXT_PACKAGE='"pgm"' \
+ -DPGM_GNUC_INTERNAL= \
${libpgm_diff_flags}
libzmq_la_CXXFLAGS = -I$(top_srcdir)/foreign/openpgm/@pgm_basename@/openpgm/pgm/include/ \