summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2011-07-17 23:31:29 +0200
committerMartin Sustrik <sustrik@250bpm.com>2011-07-17 23:31:29 +0200
commitbf78e230ad4736da9fce6e0b4d1655affb8f466b (patch)
tree8119826b6e569e4cbb93fa1afc869b8fab43690d /src/Makefile.am
parentc8e8f2a24cd339c548e06f75a3cef96454671a85 (diff)
GENERIC socket type and COMMAND flag added
GENERIC allows to use 0MQ as a dumb networking framework. It provides user with connect/disconnect notifications. Also, each inbound message is labeled by ID of the connection it originated from. Outbound messages should be labeled by the ID of the connection to send them to. To distinguish connect/disconnect notifications from common messages, COMMAND flag was introduced. Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5049ad8..971ebeb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,6 +23,7 @@ libzmq_la_SOURCES = \
err.hpp \
fd.hpp \
fq.hpp \
+ generic.hpp \
io_object.hpp \
io_thread.hpp \
ip.hpp \
@@ -88,6 +89,7 @@ libzmq_la_SOURCES = \
epoll.cpp \
err.cpp \
fq.cpp \
+ generic.cpp \
io_object.cpp \
io_thread.cpp \
ip.cpp \