summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2012-04-05 07:32:58 +0200
committerMartin Sustrik <sustrik@250bpm.com>2012-04-05 07:32:58 +0200
commitd82cbb3a81f116cd22e9895ecac36ac3d7b38929 (patch)
tree03c923311b937f550bec325d131476513a02bebf /src/Makefile.am
parent52b8a917deb2990e7197b82e81e0258ebe30f424 (diff)
XS_PLUGIN and XS_FILTER implementation
This patch introduces following features: - XS_PLUGIN context option to add plugins to libxs - XS_FILTER option to switch between different filter types - Automatic loading of plug-ins is *not* implemented. From the implementation point of view: - standard prefix filter is implemented as a pluggable filter - trie_t and mtrie_t are joined into a single class - the code for 0MQ/3.1 compatibility is left in in the form of comments - new test for testing re-subscriptions is added Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index fdfa8d1..3c260be 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,6 +23,7 @@ libxs_la_SOURCES = \
clock.hpp \
command.hpp \
config.hpp \
+ core.hpp \
ctx.hpp \
decoder.hpp \
devpoll.hpp \
@@ -44,7 +45,6 @@ libxs_la_SOURCES = \
likely.hpp \
mailbox.hpp \
msg.hpp \
- mtrie.hpp \
mutex.hpp \
object.hpp \
options.hpp \
@@ -56,6 +56,7 @@ libxs_la_SOURCES = \
platform.hpp \
poll.hpp \
pair.hpp \
+ prefix_filter.hpp \
pub.hpp \
pull.hpp \
push.hpp \
@@ -74,7 +75,6 @@ libxs_la_SOURCES = \
tcp_connecter.hpp \
tcp_listener.hpp \
thread.hpp \
- trie.hpp \
upoll.hpp \
windows.hpp \
wire.hpp \
@@ -85,6 +85,7 @@ libxs_la_SOURCES = \
ypipe.hpp \
yqueue.hpp \
clock.cpp \
+ core.cpp \
ctx.cpp \
decoder.cpp \
devpoll.cpp \
@@ -103,7 +104,6 @@ libxs_la_SOURCES = \
lb.cpp \
mailbox.cpp \
msg.cpp \
- mtrie.cpp \
object.cpp \
options.cpp \
own.cpp \
@@ -113,6 +113,7 @@ libxs_la_SOURCES = \
pgm_socket.cpp \
pipe.cpp \
poll.cpp \
+ prefix_filter.cpp \
pull.cpp \
push.cpp \
reaper.cpp \
@@ -130,7 +131,6 @@ libxs_la_SOURCES = \
tcp_connecter.cpp \
tcp_listener.cpp \
thread.cpp \
- trie.cpp \
upoll.cpp \
xpub.cpp \
xrep.cpp \