summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-08-27 18:35:59 +0200
committerMartin Lucina <mato@kotelna.sk>2010-08-27 18:35:59 +0200
commit35cb1fade62a92fdccc9fa0d75a3b69115c56c35 (patch)
tree342015f38acd56552b0e3c3ca94594723164182b /tests/Makefile.am
parent56faac7f19bf2a6d2c7b6e0c2e35fcb667a72a48 (diff)
Add a basic framework for a test suite
The test suite uses the standard automake support. Tests are always built, but run only when you do a "make check".
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..50ba0f3
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,8 @@
+INCLUDES = -I$(top_builddir)/include
+LDADD = $(top_builddir)/src/libzmq.la
+
+noinst_PROGRAMS = simple
+
+simple_SOURCES = simple.cpp
+
+TESTS = $(noinst_PROGRAMS)