summaryrefslogtreecommitdiff
path: root/bindings/ruby/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/ruby/Makefile.am')
-rw-r--r--bindings/ruby/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/bindings/ruby/Makefile.am b/bindings/ruby/Makefile.am
new file mode 100644
index 0000000..148daf0
--- /dev/null
+++ b/bindings/ruby/Makefile.am
@@ -0,0 +1,11 @@
+INCLUDES = -I$(top_builddir) -I$(top_srcdir)/include -I$(top_builddir)/include
+
+rblib_LTLIBRARIES = librbzmq.la
+rblibdir = @RUBYDIR@
+
+librbzmq_la_SOURCES = rbzmq.cpp
+
+librbzmq_la_LDFLAGS = -version-info @RBLTVER@
+librbzmq_la_CXXFLAGS = -Wall -pedantic -Werror -Wno-long-long
+librbzmq_la_LIBADD = $(top_builddir)/src/libzmq.la
+