summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in196
1 files changed, 104 insertions, 92 deletions
diff --git a/configure.in b/configure.in
index 4932995..b7d524a 100644
--- a/configure.in
+++ b/configure.in
@@ -6,9 +6,7 @@ AC_PREREQ(2.61)
# the version.sh script. Hence, it should be updated there.
# The version in git should reflect the *next* version planned.
#
-AC_INIT([zeromq],
- m4_esyscmd([./version.sh | tr -d '\n']),
- [zeromq-dev@lists.zeromq.org])
+AC_INIT([zeromq],[m4_esyscmd(./version.sh | tr -d '\n')],[zeromq-dev@lists.zeromq.org])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
@@ -30,60 +28,68 @@ AC_SUBST(LTVER)
# Checks for programs.
AC_PROG_CC
+AC_PROG_CC_C99
AC_PROG_CXX
AM_PROG_CC_C_O
-AC_LIBTOOL_WIN32_DLL
-AC_PROG_LIBTOOL
AC_PROG_SED
AC_PROG_AWK
-# Set a helper variable to indicate GNU C and C++ are in use
-if test "x$GCC" = "xyes" -a "x$GXX" = "xyes"; then
- gnu_compilers="yes"
-else
- gnu_compilers="no"
-fi
+# Host specific checks
+AC_CANONICAL_HOST
+
+# Libtool configuration for different targets. See acinclude.m4
+AC_CONFIG_LIBTOOL
+AC_LIBTOOL_WIN32_DLL
+AC_PROG_LIBTOOL
+
+# For that the compiler works and try to come up with the type
+AC_LANG(C)
+AC_CHECK_LANG_COMPILER
+
+AC_CHECK_LANG_ICC
+AC_CHECK_LANG_SUN_STUDIO
+
+AC_LANG(C++)
+AC_CHECK_LANG_COMPILER
+
+AC_CHECK_LANG_ICC
+AC_CHECK_LANG_SUN_STUDIO
# Checks for libraries.
AC_CHECK_LIB([pthread], [pthread_create])
+# Extra CFLAGS are appended at the end of CFLAGS for pgm.
+LIBZMQ_EXTRA_CFLAGS=""
+
# Extra CXXFLAGS are appended at the end of CXXFLAGS for libzmq.
LIBZMQ_EXTRA_CXXFLAGS=""
# Extra LDFLAGS are appended at the end of LDFLAGS for libzmq.
LIBZMQ_EXTRA_LDFLAGS=""
-# By default compiling with -pedantic except QNX and OSX.
-pedantic="yes"
+# Set a helper variable to indicate GNU C and C++ are in use
+if test "x$GCC" = "xyes" -a "x$GXX" = "xyes"; then
+ gnu_compilers="yes"
+
+ # ICC is detected as GNU compiler, make sure that it's not being used as one
+ if test "xyes" = "x$ac_cv_c_intel_compiler" -o "xyes" = "x$ac_cv_cpp_intel_compiler"; then
+ gnu_compilers="no"
+ fi
+else
+ gnu_compilers="no"
+fi
+
+# Set pedantic when using GNU compilers
+if test "x$gnu_compilers" = "xyes"; then
+ pedantic="yes"
+fi
-#By default compiling with -Werror except OSX.
+# By default compiling with -Werror except OSX.
werror="yes"
-#Whether we are on mingw or not.
+# Whether we are on mingw or not.
on_mingw32="no"
-# Host speciffic checks
-AC_CANONICAL_HOST
-
-# Determine whether or not documentation should be built and installed.
-build_doc="yes"
-install_man="yes"
-# Check for asciidoc and xmlto and don't build the docs if these are not installed.
-AC_CHECK_PROG(have_asciidoc, asciidoc, yes, no)
-AC_CHECK_PROG(have_xmlto, xmlto, yes, no)
-if test "x$have_asciidoc" = "xno" -o "x$have_xmlto" = "xno"; then
- build_doc="no"
- # Tarballs built with 'make dist' ship with prebuilt documentation.
- if ! test -f doc/zmq.7; then
- install_man="no"
- AC_MSG_WARN([You are building an unreleased version of 0MQ and asciidoc or xmlto are not installed. Documentation will not be built and manual pages will not be installed.])
- fi
-fi
-AC_MSG_CHECKING([whether to build documentation])
-AC_MSG_RESULT([$build_doc])
-AC_MSG_CHECKING([whether to install manpages])
-AC_MSG_RESULT([$install_man])
-
# Set some default features required by 0MQ code.
CPPFLAGS="-D_REENTRANT -D_THREAD_SAFE $CPPFLAGS"
@@ -95,17 +101,18 @@ case "${host_os}" in
CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
fi
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
- AC_CHECK_LIB(uuid, main, ,
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install uuid-dev.])])
;;
*solaris*)
# Define on Solaris to enable all library features
CPPFLAGS="-D_PTHREADS $CPPFLAGS"
AC_DEFINE(ZMQ_HAVE_SOLARIS, 1, [Have Solaris OS])
- AC_CHECK_LIB(socket, main)
- AC_CHECK_LIB(nsl, main)
- AC_CHECK_LIB(rt, main)
- AC_CHECK_LIB(uuid, main, ,
+ AC_CHECK_LIB(socket, socket)
+ AC_CHECK_LIB(nsl, gethostbyname)
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install uuid-dev.])])
AC_MSG_CHECKING([whether atomic operations can be used])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
@@ -165,8 +172,8 @@ case "${host_os}" in
*nto-qnx*)
pedantic="no"
AC_DEFINE(ZMQ_HAVE_QNXNTO, 1, [Have QNX Neutrino OS])
- AC_CHECK_LIB(socket,main)
- AC_CHECK_LIB(crypto,RAND_bytes)
+ AC_CHECK_LIB(socket, socket)
+ AC_CHECK_LIB(crypto, RAND_bytes)
;;
*aix*)
AC_DEFINE(ZMQ_HAVE_AIX, 1, [Have AIX OS])
@@ -176,7 +183,8 @@ case "${host_os}" in
# Define on HP-UX to enable all library features
CPPFLAGS="-D_POSIX_C_SOURCE=200112L"
AC_DEFINE(ZMQ_HAVE_HPUX, 1, [Have HPUX OS])
- AC_CHECK_LIB(rt, main)
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(crypto, RAND_bytes)
;;
*mingw32*)
AC_DEFINE(ZMQ_HAVE_WINDOWS, 1, [Have Windows OS])
@@ -188,9 +196,13 @@ case "${host_os}" in
[AC_MSG_ERROR([cannot link with rpcrt4.dll.])])
AC_CHECK_LIB(iphlpapi, main, ,
[AC_MSG_ERROR([cannot link with iphlpapi.dll.])])
- CFLAGS="${CFLAGS} -std=c99"
+ # mingw32 defines __int64_t as long long
+ CPPFLAGS="-Wno-long-long ${CPPFLAGS} "
on_mingw32="yes"
- install_man="no"
+
+ if test "x$enable_static" = "xyes"; then
+ AC_MSG_ERROR([Building static libraries is not supported under MinGW32])
+ fi
;;
*cygwin*)
# Define on Cygwin to enable all library features
@@ -201,12 +213,28 @@ case "${host_os}" in
LDFLAGS="${LDFLAGS} -L/usr/lib/e2fsprogs"
AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install the e2fsprogs package.])])
+
+ if test "x$enable_static" = "xyes"; then
+ AC_MSG_ERROR([Building static libraries is not supported under Cygwin])
+ fi
;;
*)
AC_MSG_ERROR([unsupported system: ${host_os}.])
;;
esac
+# Check if the compiler supports -fvisibility=hidden. If so, use it, but not
+# on MinGW32 where we use a separate mechanism (__declspec).
+_LT_COMPILER_OPTION([if $compiler supports -fvisibility=hidden],
+ ac_cv_prog_compiler_visibility,
+ [-fvisibility=hidden],
+ [],
+ [have_dso_visibility=yes])
+if test "x$have_dso_visibility" = "xyes" -a "x$on_mingw32" = "xno"; then
+ LIBZMQ_EXTRA_CFLAGS="-fvisibility=hidden $LIBZMQ_EXTRA_CFLAGS"
+ LIBZMQ_EXTRA_CXXFLAGS="-fvisibility=hidden $LIBZMQ_EXTRA_CXXFLAGS"
+fi
+
# CPU-specific optimizations
case "${host_cpu}" in
*sparc*)
@@ -218,6 +246,9 @@ case "${host_cpu}" in
;;
esac
+# Check whether to build docs / install man pages
+AC_CHECK_DOC_BUILD
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(errno.h arpa/inet.h netinet/tcp.h netinet/in.h stddef.h \
@@ -229,10 +260,9 @@ AC_CHECK_HEADERS(ifaddrs.h, [AC_DEFINE(ZMQ_HAVE_IFADDRS, 1, [Have ifaddrs.h head
# Use c++ in subsequent tests
AC_LANG(C++)
-# pkg-config is used if found, and is required for builds with OpenPGM.
-# However, we need to provide a way to disable it entirely when the user
-# knows what she's doing and it's use is undesirable, such as when
-# cross-compiling.
+# pkg-config is used if found, however, we need to provide a way to disable it
+# entirely when the user knows what she's doing and it's use is undesirable,
+# such as when cross-compiling.
AC_ARG_WITH([pkg-config], [AS_HELP_STRING([--without-pkg-config],
[do not use pkg-config [default=no]])])
if test "x$with_pkg_config" != "xno"; then
@@ -249,21 +279,10 @@ AC_HEADER_TIME
AC_TYPE_UINT32_T
AC_C_VOLATILE
-# Substs
-stdint="0"
-if test "x$HAVE_STDINT_H" = "xyes"; then
- stdint="1"
-fi
-
-inttypes="0"
-if test "x$HAVE_INTTYPES_H" = "xyes"; then
- inttypes="1"
-fi
-
# PGM extension
pgm_ext="no"
-pgm_basename="libpgm-2-1-28~dfsg"
+pgm_basename="libpgm-5.0.91~dfsg"
AC_SUBST(pgm_basename)
@@ -273,10 +292,14 @@ AC_ARG_WITH([pgm], [AS_HELP_STRING([--with-pgm],
if test "x$with_pgm_ext" != "xno"; then
+ if test "x$ac_cv_prog_cc_c99" = "xno"; then
+ AC_MSG_WARN([The C compiler is not set to C99 mode. The build will most likely fail])
+ fi
+
AC_MSG_CHECKING([if the PGM extension is supported on this platform])
- # OpenPGM is only supported by the vendor on x86 and AMD64 platforms...
+ # OpenPGM is only supported by the vendor on x86, AMD64, and SPARC platforms...
case "${host_cpu}" in
- i*86|x86_64)
+ i*86|x86_64|amd64|*sparc*)
# Supported
;;
*)
@@ -284,10 +307,16 @@ if test "x$with_pgm_ext" != "xno"; then
;;
esac
- # ... and on Linux/Windows/Solaris systems.
+ # ... and on Linux/Windows/Solaris/FreeBSD/OSX systems.
case "${host_os}" in
- *linux*|*mingw32*|*solaris*)
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Wno-variadic-macros -Wno-long-long "
+ *linux*|*mingw32*|*solaris*|*freebsd*|*darwin*)
+ if test "x$gnu_compilers" = "xyes"; then
+ LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Wno-variadic-macros -Wno-long-long "
+ elif test "x$ac_cv_c_intel_compiler" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-strict-ansi -Dasm=__asm__ "
+ elif test "x$ac_cv_c_sun_studio_compiler" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-Xc -Dasm=__asm__ "
+ fi
;;
*)
AC_MSG_ERROR([the PGM extension is not supported on system ${host_os}.])
@@ -295,18 +324,6 @@ if test "x$with_pgm_ext" != "xno"; then
esac
AC_MSG_RESULT([yes])
- # Test if we have pkg-config
- if test "x$with_pkg_config" != "xno"; then
- if test "x$have_pkg_config" != "xyes"; then
- AC_MSG_ERROR([the --with-pgm option requires that pkg-config be installed.]);
- fi
-
- # Check for OpenPGM dependencies
- PKG_CHECK_MODULES([GLIB], [glib-2.0 gthread-2.0])
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} ${GLIB_CFLAGS} "
- LIBZMQ_EXTRA_LDFLAGS="${LIBZMQ_EXTRA_LDFLAGS} ${GLIB_LIBS} "
- fi
-
# Gzip, Perl and Python are required duing PGM build
AC_CHECK_PROG(have_gzip, gzip, yes, no)
if test "x$have_gzip" != "xyes"; then
@@ -338,35 +355,30 @@ if test "x$gnu_compilers" = "xyes" -a "x$pgm_ext" = "xno"; then
CPPFLAGS="-Wall $CPPFLAGS"
if test "x$pedantic" = "xyes"; then
- CPPFLAGS="-pedantic $CPPFLAGS"
+ CPPFLAGS="-pedantic $CPPFLAGS"
fi
if test "x$werror" = "xyes"; then
- CPPFLAGS="-Werror $CPPFLAGS"
+ CPPFLAGS="-Werror $CPPFLAGS"
fi
fi
AM_CONDITIONAL(BUILD_PGM, test "x$pgm_ext" = "xyes")
-AM_CONDITIONAL(BUILD_NO_PGM, test "x$pgm_ext" = "xno")
AM_CONDITIONAL(ON_MINGW, test "x$on_mingw32" = "xyes")
-AM_CONDITIONAL(INSTALL_MAN, test "x$install_man" = "xyes")
-AM_CONDITIONAL(BUILD_DOC, test "x$build_doc" = "xyes")
-
-AC_SUBST(stdint)
-AC_SUBST(inttypes)
-# Subst LIBZMQ_EXTRA_CXXFLAGS & LDFLAGS
+# Subst LIBZMQ_EXTRA_CFLAGS & CXXFLAGS & LDFLAGS
+AC_SUBST(LIBZMQ_EXTRA_CFLAGS)
AC_SUBST(LIBZMQ_EXTRA_CXXFLAGS)
AC_SUBST(LIBZMQ_EXTRA_LDFLAGS)
-
# Checks for library functions.
AC_TYPE_SIGNAL
AC_CHECK_FUNCS(perror gettimeofday memset socket getifaddrs freeifaddrs)
-AC_OUTPUT(Makefile src/Makefile doc/Makefile
+AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile
perf/Makefile src/libzmq.pc \
devices/Makefile devices/zmq_forwarder/Makefile \
devices/zmq_streamer/Makefile devices/zmq_queue/Makefile \
- builds/msvc/Makefile)
+ builds/msvc/Makefile tests/Makefile])
+AC_OUTPUT