summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 11 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 25a4eed..88286ba 100644
--- a/configure.in
+++ b/configure.in
@@ -6,7 +6,7 @@ AC_PREREQ(2.61)
# The version in git should reflect the *next* version planned.
# Version must be MAJOR.MINOR.PATCH otherwise things will break.
#
-AC_INIT([zeromq],[2.0.10],[zeromq-dev@lists.zeromq.org])
+AC_INIT([zeromq],[2.1.0],[zeromq-dev@lists.zeromq.org])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
@@ -89,6 +89,7 @@ case "${host_os}" in
# Define on Linux to enable all library features
CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
+ AC_CHECK_LIB(rt, main)
AC_CHECK_LIB(uuid, main, ,
[AC_MSG_ERROR([cannot link with -luuid, install uuid-dev.])])
;;
@@ -222,10 +223,9 @@ AC_CHECK_HEADERS(ifaddrs.h, [AC_DEFINE(ZMQ_HAVE_IFADDRS, 1, [Have ifaddrs.h head
# Use c++ in subsequent tests
AC_LANG(C++)
-# pkg-config is used if found, and is required for builds with OpenPGM.
-# However, we need to provide a way to disable it entirely when the user
-# knows what she's doing and it's use is undesirable, such as when
-# cross-compiling.
+# pkg-config is used if found, however, we need to provide a way to disable it
+# entirely when the user knows what she's doing and it's use is undesirable,
+# such as when cross-compiling.
AC_ARG_WITH([pkg-config], [AS_HELP_STRING([--without-pkg-config],
[do not use pkg-config [default=no]])])
if test "x$with_pkg_config" != "xno"; then
@@ -256,7 +256,7 @@ fi
# PGM extension
pgm_ext="no"
-pgm_basename="libpgm-2.1.26"
+pgm_basename="libpgm-5.0.78"
AC_SUBST(pgm_basename)
@@ -267,9 +267,9 @@ AC_ARG_WITH([pgm], [AS_HELP_STRING([--with-pgm],
if test "x$with_pgm_ext" != "xno"; then
AC_MSG_CHECKING([if the PGM extension is supported on this platform])
- # OpenPGM is only supported by the vendor on x86 and AMD64 platforms...
+ # OpenPGM is only supported by the vendor on x86, AMD64, and SPARC platforms...
case "${host_cpu}" in
- i*86|x86_64)
+ i*86|x86_64|amd64|*sparc*)
# Supported
;;
*)
@@ -277,9 +277,9 @@ if test "x$with_pgm_ext" != "xno"; then
;;
esac
- # ... and on Linux/Windows/Solaris systems.
+ # ... and on Linux/Windows/Solaris/FreeBSD/OSX systems.
case "${host_os}" in
- *linux*|*mingw32*|*solaris*)
+ *linux*|*mingw32*|*solaris*|*freebsd*|*darwin*)
LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Wno-variadic-macros -Wno-long-long "
;;
*)
@@ -288,18 +288,6 @@ if test "x$with_pgm_ext" != "xno"; then
esac
AC_MSG_RESULT([yes])
- # Test if we have pkg-config
- if test "x$with_pkg_config" != "xno"; then
- if test "x$have_pkg_config" != "xyes"; then
- AC_MSG_ERROR([the --with-pgm option requires that pkg-config be installed.]);
- fi
-
- # Check for OpenPGM dependencies
- PKG_CHECK_MODULES([GLIB], [glib-2.0 gthread-2.0])
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} ${GLIB_CFLAGS} "
- LIBZMQ_EXTRA_LDFLAGS="${LIBZMQ_EXTRA_LDFLAGS} ${GLIB_LIBS} "
- fi
-
# Gzip, Perl and Python are required duing PGM build
AC_CHECK_PROG(have_gzip, gzip, yes, no)
if test "x$have_gzip" != "xyes"; then
@@ -361,7 +349,7 @@ AC_OUTPUT(Makefile src/Makefile doc/Makefile
perf/Makefile src/libzmq.pc \
devices/Makefile devices/zmq_forwarder/Makefile \
devices/zmq_streamer/Makefile devices/zmq_queue/Makefile \
- builds/msvc/Makefile)
+ builds/msvc/Makefile tests/Makefile)
# On Linux patch libtool to delete hardcoded paths (rpath).
case "${host_os}" in