summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8a31177..4065252 100644
--- a/configure.in
+++ b/configure.in
@@ -229,6 +229,10 @@ esac
# Check whether to build docs / install man pages
LIBZMQ_CHECK_DOC_BUILD
+# Check polling system
+LIBZMQ_CHECK_POLLER([CPPFLAGS="${CPPFLAGS} -D${libzmq_cv_poller_flag}"],
+ [AC_MSG_ERROR([Unable to continue without polling system])])
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(errno.h arpa/inet.h netinet/tcp.h netinet/in.h stddef.h \