summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4051536..eba8188 100644
--- a/configure.in
+++ b/configure.in
@@ -391,6 +391,21 @@ else
JAR=true
fi
+# Common Lisp
+cldir=""
+AC_ARG_WITH([cl], [AS_HELP_STRING([--with-cl],
+ [build Common Lisp language binding and install it into specified ASDF central registry [default=no]])],
+ [cldir="$withval";clzmq="yes"], [clzmq="no"])
+
+if test "x$clzmq" = "xyes"; then
+ if test "x$cldir" = "xyes"; then
+ AC_MSG_ERROR([Please, specify ASDF central registry path])
+ fi
+
+ CLDIR=${cldir}
+ AC_SUBST([CLDIR])
+fi
+
# PGM extension
pgm1_ext="no"
pgm2_ext="no"
@@ -631,6 +646,7 @@ AM_CONDITIONAL(BUILD_JAVA, test "x$jzmq" = "xyes")
AM_CONDITIONAL(BUILD_PYTHON, test "x$pyzmq" = "xyes")
AM_CONDITIONAL(BUILD_RUBY, test "x$rbzmq" = "xyes")
AM_CONDITIONAL(BUILD_C, test "x$czmq" = "xyes")
+AM_CONDITIONAL(BUILD_CL, test "x$clzmq" = "xyes")
AM_CONDITIONAL(BUILD_CPP, test "x$cppzmq" = "xyes")
AM_CONDITIONAL(BUILD_PGM1, test "x$pgm1_ext" = "xyes")
AM_CONDITIONAL(BUILD_PGM2, test "x$pgm2_ext" = "xyes")
@@ -657,6 +673,7 @@ AC_CHECK_FUNCS(perror gettimeofday memset socket getifaddrs freeifaddrs)
AC_OUTPUT(Makefile src/Makefile man/Makefile bindings/python/Makefile \
bindings/python/setup.py bindings/ruby/Makefile \
+ bindings/cl/Makefile perf/cl/Makefile \
bindings/java/Makefile perf/Makefile perf/c/Makefile perf/cpp/Makefile \
perf/python/Makefile perf/ruby/Makefile perf/java/Makefile src/libzmq.pc \
devices/Makefile devices/zmq_forwarder/Makefile \
@@ -676,6 +693,10 @@ AC_MSG_RESULT([ 0MQ install dir: $prefix])
AC_MSG_RESULT([ Language bindings:])
AC_MSG_RESULT([ C: $czmq])
AC_MSG_RESULT([ C++: $cppzmq])
+AC_MSG_RESULT([ Common Lisp: $clzmq])
+if test "x$clzmq" = "xyes"; then
+AC_MSG_RESULT([ ASDF central registry: $cldir])
+fi
AC_MSG_RESULT([ Java: $jzmq])
AC_MSG_RESULT([ Python: $pyzmq])
AC_MSG_RESULT([ Ruby: $rbzmq])