summaryrefslogtreecommitdiff
path: root/perf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perf/Makefile.am')
-rw-r--r--perf/Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
index dbebc93..a3c13ad 100644
--- a/perf/Makefile.am
+++ b/perf/Makefile.am
@@ -1,2 +1,23 @@
-SUBDIRS = c cpp python
-DIST_SUBDIRS = c cpp python
+if BUILD_C
+PERF_DIR_C = c
+endif
+
+if BUILD_CPP
+PERF_DIR_CPP = cpp
+endif
+
+if BUILD_PYTHON
+PERF_DIR_P = python
+endif
+
+if BUILD_JAVA
+PERF_DIR_J = java
+endif
+
+if BUILD_RUBY
+PERF_DIR_R = ruby
+endif
+
+SUBDIRS = $(PERF_DIR_C) $(PERF_DIR_CPP) $(PERF_DIR_P) \
+ $(PERF_DIR_J) $(PERF_DIR_R)
+DIST_SUBDIRS = c cpp python java ruby