summaryrefslogtreecommitdiff
path: root/builds
diff options
context:
space:
mode:
authorMartin Lucina <martin@lucina.net>2012-01-23 08:53:35 +0100
committerMartin Lucina <martin@lucina.net>2012-01-23 08:53:35 +0100
commite645fc2693acc796304498909786b7b47005b429 (patch)
tree4118cd4c7b9eba3ba1d6892800c79669ea94c4e9 /builds
parent2c416a793ea781273a5da6742211f5f01af13a2b (diff)
Imported Upstream version 2.1.3upstream/2.1.3
Diffstat (limited to 'builds')
-rw-r--r--builds/msvc/Makefile.am6
-rw-r--r--builds/msvc/Makefile.in34
-rw-r--r--builds/msvc/libzmq/libzmq.vcproj237
-rw-r--r--builds/msvc/msvc.sln32
-rw-r--r--builds/msvc/platform.hpp11
-rw-r--r--builds/msvc/zmq_forwarder/zmq_forwarder.vcproj176
-rw-r--r--builds/msvc/zmq_queue/zmq_queue.vcproj176
-rw-r--r--builds/msvc/zmq_streamer/zmq_streamer.vcproj176
8 files changed, 226 insertions, 622 deletions
diff --git a/builds/msvc/Makefile.am b/builds/msvc/Makefile.am
index 6f20cee..9ce00aa 100644
--- a/builds/msvc/Makefile.am
+++ b/builds/msvc/Makefile.am
@@ -1,12 +1,8 @@
LIBZMQ_DIST = libzmq/libzmq.vcproj platform.hpp msvc.sln
-DEVICES_DIST = zmq_queue/zmq_queue.vcproj \
- zmq_streamer/zmq_streamer.vcproj \
- zmq_forwarder/zmq_forwarder.vcproj
-
PERF_DIST = c_local_thr/c_local_thr.vcproj \
c_remote_thr/c_remote_thr.vcproj \
c_local_lat/c_local_lat.vcproj \
c_remote_lat/c_remote_lat.vcproj
-EXTRA_DIST = $(LIBZMQ_DIST) $(DEVICES_DIST) $(PERF_DIST)
+EXTRA_DIST = $(LIBZMQ_DIST) $(PERF_DIST)
diff --git a/builds/msvc/Makefile.in b/builds/msvc/Makefile.in
index bc7333f..c3ba84f 100644
--- a/builds/msvc/Makefile.in
+++ b/builds/msvc/Makefile.in
@@ -40,20 +40,29 @@ am__aclocal_m4_deps = $(top_srcdir)/config/libtool.m4 \
$(top_srcdir)/config/ltoptions.m4 \
$(top_srcdir)/config/ltsugar.m4 \
$(top_srcdir)/config/ltversion.m4 \
- $(top_srcdir)/config/lt~obsolete.m4 $(top_srcdir)/configure.in
+ $(top_srcdir)/config/lt~obsolete.m4 $(top_srcdir)/acinclude.m4 \
+ $(top_srcdir)/configure.in
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = $(top_builddir)/src/platform.hpp
CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
+AM_V_GEN = $(am__v_GEN_$(V))
+am__v_GEN_ = $(am__v_GEN_$(AM_DEFAULT_VERBOSITY))
+am__v_GEN_0 = @echo " GEN " $@;
+AM_V_at = $(am__v_at_$(V))
+am__v_at_ = $(am__v_at_$(AM_DEFAULT_VERBOSITY))
+am__v_at_0 = @
SOURCES =
DIST_SOURCES =
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
ACLOCAL = @ACLOCAL@
AMTAR = @AMTAR@
+AM_DEFAULT_VERBOSITY = @AM_DEFAULT_VERBOSITY@
AR = @AR@
AS = @AS@
+ASCIIDOC = @ASCIIDOC@
AUTOCONF = @AUTOCONF@
AUTOHEADER = @AUTOHEADER@
AUTOMAKE = @AUTOMAKE@
@@ -79,8 +88,6 @@ ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
FGREP = @FGREP@
-GLIB_CFLAGS = @GLIB_CFLAGS@
-GLIB_LIBS = @GLIB_LIBS@
GREP = @GREP@
INSTALL = @INSTALL@
INSTALL_DATA = @INSTALL_DATA@
@@ -92,6 +99,7 @@ LDFLAGS = @LDFLAGS@
LIBOBJS = @LIBOBJS@
LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
+LIBZMQ_EXTRA_CFLAGS = @LIBZMQ_EXTRA_CFLAGS@
LIBZMQ_EXTRA_CXXFLAGS = @LIBZMQ_EXTRA_CXXFLAGS@
LIBZMQ_EXTRA_LDFLAGS = @LIBZMQ_EXTRA_LDFLAGS@
LIPO = @LIPO@
@@ -114,13 +122,13 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
-PKG_CONFIG = @PKG_CONFIG@
RANLIB = @RANLIB@
SED = @SED@
SET_MAKE = @SET_MAKE@
SHELL = @SHELL@
STRIP = @STRIP@
VERSION = @VERSION@
+XMLTO = @XMLTO@
abs_builddir = @abs_builddir@
abs_srcdir = @abs_srcdir@
abs_top_builddir = @abs_top_builddir@
@@ -128,6 +136,8 @@ abs_top_srcdir = @abs_top_srcdir@
ac_ct_CC = @ac_ct_CC@
ac_ct_CXX = @ac_ct_CXX@
ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
+ac_zmq_have_asciidoc = @ac_zmq_have_asciidoc@
+ac_zmq_have_xmlto = @ac_zmq_have_xmlto@
am__include = @am__include@
am__leading_dot = @am__leading_dot@
am__quote = @am__quote@
@@ -145,12 +155,6 @@ datarootdir = @datarootdir@
docdir = @docdir@
dvidir = @dvidir@
exec_prefix = @exec_prefix@
-have_asciidoc = @have_asciidoc@
-have_gzip = @have_gzip@
-have_perl = @have_perl@
-have_pkg_config = @have_pkg_config@
-have_python = @have_python@
-have_xmlto = @have_xmlto@
host = @host@
host_alias = @host_alias@
host_cpu = @host_cpu@
@@ -160,7 +164,6 @@ htmldir = @htmldir@
includedir = @includedir@
infodir = @infodir@
install_sh = @install_sh@
-inttypes = @inttypes@
libdir = @libdir@
libexecdir = @libexecdir@
localedir = @localedir@
@@ -171,29 +174,26 @@ mkdir_p = @mkdir_p@
oldincludedir = @oldincludedir@
pdfdir = @pdfdir@
pgm_basename = @pgm_basename@
+pgm_srcdir = @pgm_srcdir@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
srcdir = @srcdir@
-stdint = @stdint@
+subdirs = @subdirs@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
LIBZMQ_DIST = libzmq/libzmq.vcproj platform.hpp msvc.sln
-DEVICES_DIST = zmq_queue/zmq_queue.vcproj \
- zmq_streamer/zmq_streamer.vcproj \
- zmq_forwarder/zmq_forwarder.vcproj
-
PERF_DIST = c_local_thr/c_local_thr.vcproj \
c_remote_thr/c_remote_thr.vcproj \
c_local_lat/c_local_lat.vcproj \
c_remote_lat/c_remote_lat.vcproj
-EXTRA_DIST = $(LIBZMQ_DIST) $(DEVICES_DIST) $(PERF_DIST)
+EXTRA_DIST = $(LIBZMQ_DIST) $(PERF_DIST)
all: all-am
.SUFFIXES:
diff --git a/builds/msvc/libzmq/libzmq.vcproj b/builds/msvc/libzmq/libzmq.vcproj
index 95db1df..c774ac2 100644
--- a/builds/msvc/libzmq/libzmq.vcproj
+++ b/builds/msvc/libzmq/libzmq.vcproj
@@ -40,7 +40,7 @@
/>
<Tool
Name="VCCLCompilerTool"
- AdditionalOptions="-DDLL_EXPORT"
+ AdditionalOptions="-DDLL_EXPORT -DFD_SETSIZE=1024"
Optimization="0"
MinimalRebuild="true"
BasicRuntimeChecks="3"
@@ -112,7 +112,7 @@
/>
<Tool
Name="VCCLCompilerTool"
- AdditionalOptions="-DDLL_EXPORT"
+ AdditionalOptions="-DDLL_EXPORT -DFD_SETSIZE=1024"
Optimization="2"
EnableIntrinsicFunctions="true"
RuntimeLibrary="2"
@@ -160,6 +160,83 @@
Name="VCPostBuildEventTool"
/>
</Configuration>
+ <Configuration
+ Name="WithOpenPGM|Win32"
+ OutputDirectory="$(SolutionDir)$(ConfigurationName)"
+ IntermediateDirectory="$(ConfigurationName)"
+ ConfigurationType="2"
+ CharacterSet="2"
+ WholeProgramOptimization="1"
+ >
+ <Tool
+ Name="VCPreBuildEventTool"
+ CommandLine="copy ..\platform.hpp ..\..\..\src"
+ />
+ <Tool
+ Name="VCCustomBuildTool"
+ />
+ <Tool
+ Name="VCXMLDataGeneratorTool"
+ />
+ <Tool
+ Name="VCWebServiceProxyGeneratorTool"
+ />
+ <Tool
+ Name="VCMIDLTool"
+ />
+ <Tool
+ Name="VCCLCompilerTool"
+ AdditionalOptions="-DDLL_EXPORT -DFD_SETSIZE=1024"
+ Optimization="2"
+ EnableIntrinsicFunctions="true"
+ AdditionalIncludeDirectories="../../../../OpenPGM/include"
+ PreprocessorDefinitions="ZMQ_HAVE_OPENPGM"
+ RuntimeLibrary="2"
+ EnableFunctionLevelLinking="true"
+ WarningLevel="3"
+ DebugInformationFormat="3"
+ />
+ <Tool
+ Name="VCManagedResourceCompilerTool"
+ />
+ <Tool
+ Name="VCResourceCompilerTool"
+ />
+ <Tool
+ Name="VCPreLinkEventTool"
+ />
+ <Tool
+ Name="VCLinkerTool"
+ AdditionalDependencies="Ws2_32.lib Rpcrt4.lib libpgm.lib"
+ OutputFile="../../../lib/libzmq.dll"
+ AdditionalLibraryDirectories="../../../../OpenPGM/lib"
+ GenerateDebugInformation="true"
+ OptimizeReferences="2"
+ EnableCOMDATFolding="2"
+ TargetMachine="1"
+ />
+ <Tool
+ Name="VCALinkTool"
+ />
+ <Tool
+ Name="VCManifestTool"
+ />
+ <Tool
+ Name="VCXDCMakeTool"
+ />
+ <Tool
+ Name="VCBscMakeTool"
+ />
+ <Tool
+ Name="VCFxCopTool"
+ />
+ <Tool
+ Name="VCAppVerifierTool"
+ />
+ <Tool
+ Name="VCPostBuildEventTool"
+ />
+ </Configuration>
</Configurations>
<References>
</References>
@@ -170,7 +247,7 @@
UniqueIdentifier="{4FC737F1-C7A5-4376-A066-2A32D752A2FF}"
>
<File
- RelativePath="..\..\..\src\app_thread.cpp"
+ RelativePath="..\..\..\src\clock.cpp"
>
</File>
<File
@@ -178,27 +255,39 @@
>
</File>
<File
+ RelativePath="..\..\..\src\connect_session.cpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\ctx.cpp"
>
</File>
<File
+ RelativePath="..\..\..\src\decoder.cpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\device.cpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\devpoll.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\push.cpp"
+ RelativePath="..\..\..\src\dist.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\epoll.cpp"
+ RelativePath="..\..\..\src\encoder.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\err.cpp"
+ RelativePath="..\..\..\src\epoll.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\forwarder.cpp"
+ RelativePath="..\..\..\src\err.cpp"
>
</File>
<File
@@ -226,7 +315,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\msg_store.cpp"
+ RelativePath="..\..\..\src\mailbox.cpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\named_session.cpp"
>
</File>
<File
@@ -238,7 +331,7 @@
>
</File>
<File
- RelativePath="..\..\..\src\owned.cpp"
+ RelativePath="..\..\..\src\own.cpp"
>
</File>
<File
@@ -266,7 +359,7 @@
>
</File>
<File
- RelativePath="..\..\..\src\prefix_tree.cpp"
+ RelativePath="..\..\..\src\poller_base.cpp"
>
</File>
<File
@@ -274,7 +367,15 @@
>
</File>
<File
- RelativePath="..\..\..\src\queue.cpp"
+ RelativePath="..\..\..\src\pull.cpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\push.cpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\reaper.cpp"
>
</File>
<File
@@ -294,19 +395,15 @@
>
</File>
<File
- RelativePath="..\..\..\src\signaler.cpp"
- >
- </File>
- <File
RelativePath="..\..\..\src\socket_base.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\streamer.cpp"
+ RelativePath="..\..\..\src\sub.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\sub.cpp"
+ RelativePath="..\..\..\src\swap.cpp"
>
</File>
<File
@@ -326,7 +423,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\pull.cpp"
+ RelativePath="..\..\..\src\transient_session.cpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\trie.cpp"
>
</File>
<File
@@ -334,27 +435,27 @@
>
</File>
<File
- RelativePath="..\..\..\src\xrep.cpp"
+ RelativePath="..\..\..\src\xpub.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\xreq.cpp"
+ RelativePath="..\..\..\src\xrep.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq.cpp"
+ RelativePath="..\..\..\src\xreq.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_connecter.cpp"
+ RelativePath="..\..\..\src\xsub.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_decoder.cpp"
+ RelativePath="..\..\..\src\zmq.cpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_encoder.cpp"
+ RelativePath="..\..\..\src\zmq_connecter.cpp"
>
</File>
<File
@@ -376,7 +477,7 @@
UniqueIdentifier="{93995380-89BD-4b04-88EB-625FBE52EBFB}"
>
<File
- RelativePath="..\..\..\src\app_thread.hpp"
+ RelativePath="..\..\..\src\array.hpp"
>
</File>
<File
@@ -388,6 +489,14 @@
>
</File>
<File
+ RelativePath="..\..\..\src\blob.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\clock.hpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\command.hpp"
>
</File>
@@ -396,6 +505,10 @@
>
</File>
<File
+ RelativePath="..\..\..\src\connect_session.hpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\ctx.hpp"
>
</File>
@@ -404,11 +517,15 @@
>
</File>
<File
+ RelativePath="..\..\..\src\device.hpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\devpoll.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\push.hpp"
+ RelativePath="..\..\..\src\dist.hpp"
>
</File>
<File
@@ -428,18 +545,10 @@
>
</File>
<File
- RelativePath="..\..\..\src\forwarder.hpp"
- >
- </File>
- <File
RelativePath="..\..\..\src\fq.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\i_endpoint.hpp"
- >
- </File>
- <File
RelativePath="..\..\..\src\i_engine.hpp"
>
</File>
@@ -472,11 +581,15 @@
>
</File>
<File
- RelativePath="..\..\..\src\msg_content.hpp"
+ RelativePath="..\..\..\src\likely.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\msg_store.hpp"
+ RelativePath="..\..\..\src\mailbox.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\msg_content.hpp"
>
</File>
<File
@@ -484,6 +597,10 @@
>
</File>
<File
+ RelativePath="..\..\..\src\named_session.hpp"
+ >
+ </File>
+ <File
RelativePath="..\..\..\src\object.hpp"
>
</File>
@@ -492,7 +609,7 @@
>
</File>
<File
- RelativePath="..\..\..\src\owned.hpp"
+ RelativePath="..\..\..\src\own.hpp"
>
</File>
<File
@@ -516,7 +633,7 @@
>
</File>
<File
- RelativePath="..\platform.hpp"
+ RelativePath="..\..\..\src\platform.hpp"
>
</File>
<File
@@ -524,7 +641,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\prefix_tree.hpp"
+ RelativePath="..\..\..\src\poller.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\poller_base.hpp"
>
</File>
<File
@@ -532,7 +653,15 @@
>
</File>
<File
- RelativePath="..\..\..\src\queue.hpp"
+ RelativePath="..\..\..\src\pull.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\push.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\reaper.hpp"
>
</File>
<File
@@ -548,11 +677,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\session.hpp"
+ RelativePath="..\..\..\src\semaphore.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\signaler.hpp"
+ RelativePath="..\..\..\src\session.hpp"
>
</File>
<File
@@ -564,11 +693,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\streamer.hpp"
+ RelativePath="..\..\..\src\sub.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\sub.hpp"
+ RelativePath="..\..\..\src\swap.hpp"
>
</File>
<File
@@ -588,7 +717,11 @@
>
</File>
<File
- RelativePath="..\..\..\src\pull.hpp"
+ RelativePath="..\..\..\src\transient_session.hpp"
+ >
+ </File>
+ <File
+ RelativePath="..\..\..\src\trie.hpp"
>
</File>
<File
@@ -604,31 +737,31 @@
>
</File>
<File
- RelativePath="..\..\..\src\xrep.hpp"
+ RelativePath="..\..\..\src\xpub.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\xreq.hpp"
+ RelativePath="..\..\..\src\xrep.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\ypipe.hpp"
+ RelativePath="..\..\..\src\xreq.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\yqueue.hpp"
+ RelativePath="..\..\..\src\xsub.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_connecter.hpp"
+ RelativePath="..\..\..\src\ypipe.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_decoder.hpp"
+ RelativePath="..\..\..\src\yqueue.hpp"
>
</File>
<File
- RelativePath="..\..\..\src\zmq_encoder.hpp"
+ RelativePath="..\..\..\src\zmq_connecter.hpp"
>
</File>
<File
diff --git a/builds/msvc/msvc.sln b/builds/msvc/msvc.sln
index 42a5e36..c47f3ac 100644
--- a/builds/msvc/msvc.sln
+++ b/builds/msvc/msvc.sln
@@ -23,59 +23,61 @@ Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "remote_thr", "c_remote_thr\
{641C5F36-32EE-4323-B740-992B651CF9D6} = {641C5F36-32EE-4323-B740-992B651CF9D6}
EndProjectSection
EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "zmq_forwarder", "zmq_forwarder\zmq_forwarder.vcproj", "{EFE471DE-6747-4B2E-B084-F7E45A16CD03}"
- ProjectSection(ProjectDependencies) = postProject
- {641C5F36-32EE-4323-B740-992B651CF9D6} = {641C5F36-32EE-4323-B740-992B651CF9D6}
- EndProjectSection
-EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "zmq_streamer", "zmq_streamer\zmq_streamer.vcproj", "{DF2CED64-4156-48EA-8AA3-38CF86060D59}"
- ProjectSection(ProjectDependencies) = postProject
- {641C5F36-32EE-4323-B740-992B651CF9D6} = {641C5F36-32EE-4323-B740-992B651CF9D6}
- EndProjectSection
-EndProject
-Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "zmq_queue", "zmq_queue\zmq_queue.vcproj", "{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}"
- ProjectSection(ProjectDependencies) = postProject
- {641C5F36-32EE-4323-B740-992B651CF9D6} = {641C5F36-32EE-4323-B740-992B651CF9D6}
- EndProjectSection
-EndProject
Global
GlobalSection(SolutionConfigurationPlatforms) = preSolution
Debug|Win32 = Debug|Win32
Release|Win32 = Release|Win32
+ WithOpenPGM|Win32 = WithOpenPGM|Win32
EndGlobalSection
GlobalSection(ProjectConfigurationPlatforms) = postSolution
{641C5F36-32EE-4323-B740-992B651CF9D6}.Debug|Win32.ActiveCfg = Debug|Win32
{641C5F36-32EE-4323-B740-992B651CF9D6}.Debug|Win32.Build.0 = Debug|Win32
{641C5F36-32EE-4323-B740-992B651CF9D6}.Release|Win32.ActiveCfg = Release|Win32
{641C5F36-32EE-4323-B740-992B651CF9D6}.Release|Win32.Build.0 = Release|Win32
+ {641C5F36-32EE-4323-B740-992B651CF9D6}.WithOpenPGM|Win32.ActiveCfg = WithOpenPGM|Win32
+ {641C5F36-32EE-4323-B740-992B651CF9D6}.WithOpenPGM|Win32.Build.0 = WithOpenPGM|Win32
{4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.Debug|Win32.ActiveCfg = Debug|Win32
{4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.Debug|Win32.Build.0 = Debug|Win32
{4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.Release|Win32.ActiveCfg = Release|Win32
{4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.Release|Win32.Build.0 = Release|Win32
+ {4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {4FDB8C73-9D4A-4D87-A4A9-A7FC06DFEA57}.WithOpenPGM|Win32.Build.0 = Release|Win32
{9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.Debug|Win32.ActiveCfg = Debug|Win32
{9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.Debug|Win32.Build.0 = Debug|Win32
{9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.Release|Win32.ActiveCfg = Release|Win32
{9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.Release|Win32.Build.0 = Release|Win32
+ {9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {9C20A37C-5D9F-4C4C-A2D9-E6EE91A077D1}.WithOpenPGM|Win32.Build.0 = Release|Win32
{8EF2DF6B-6646-460F-8032-913B70FE0E94}.Debug|Win32.ActiveCfg = Debug|Win32
{8EF2DF6B-6646-460F-8032-913B70FE0E94}.Debug|Win32.Build.0 = Debug|Win32
{8EF2DF6B-6646-460F-8032-913B70FE0E94}.Release|Win32.ActiveCfg = Release|Win32
{8EF2DF6B-6646-460F-8032-913B70FE0E94}.Release|Win32.Build.0 = Release|Win32
+ {8EF2DF6B-6646-460F-8032-913B70FE0E94}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {8EF2DF6B-6646-460F-8032-913B70FE0E94}.WithOpenPGM|Win32.Build.0 = Release|Win32
{B15E059C-0CBB-4A82-8C42-6567FB650802}.Debug|Win32.ActiveCfg = Debug|Win32
{B15E059C-0CBB-4A82-8C42-6567FB650802}.Debug|Win32.Build.0 = Debug|Win32
{B15E059C-0CBB-4A82-8C42-6567FB650802}.Release|Win32.ActiveCfg = Release|Win32
{B15E059C-0CBB-4A82-8C42-6567FB650802}.Release|Win32.Build.0 = Release|Win32
+ {B15E059C-0CBB-4A82-8C42-6567FB650802}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {B15E059C-0CBB-4A82-8C42-6567FB650802}.WithOpenPGM|Win32.Build.0 = Release|Win32
{EFE471DE-6747-4B2E-B084-F7E45A16CD03}.Debug|Win32.ActiveCfg = Debug|Win32
{EFE471DE-6747-4B2E-B084-F7E45A16CD03}.Debug|Win32.Build.0 = Debug|Win32
{EFE471DE-6747-4B2E-B084-F7E45A16CD03}.Release|Win32.ActiveCfg = Release|Win32
{EFE471DE-6747-4B2E-B084-F7E45A16CD03}.Release|Win32.Build.0 = Release|Win32
+ {EFE471DE-6747-4B2E-B084-F7E45A16CD03}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {EFE471DE-6747-4B2E-B084-F7E45A16CD03}.WithOpenPGM|Win32.Build.0 = Release|Win32
{DF2CED64-4156-48EA-8AA3-38CF86060D59}.Debug|Win32.ActiveCfg = Debug|Win32
{DF2CED64-4156-48EA-8AA3-38CF86060D59}.Debug|Win32.Build.0 = Debug|Win32
{DF2CED64-4156-48EA-8AA3-38CF86060D59}.Release|Win32.ActiveCfg = Release|Win32
{DF2CED64-4156-48EA-8AA3-38CF86060D59}.Release|Win32.Build.0 = Release|Win32
+ {DF2CED64-4156-48EA-8AA3-38CF86060D59}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {DF2CED64-4156-48EA-8AA3-38CF86060D59}.WithOpenPGM|Win32.Build.0 = Release|Win32
{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.Debug|Win32.ActiveCfg = Debug|Win32
{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.Debug|Win32.Build.0 = Debug|Win32
{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.Release|Win32.ActiveCfg = Release|Win32
{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.Release|Win32.Build.0 = Release|Win32
+ {076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.WithOpenPGM|Win32.ActiveCfg = Release|Win32
+ {076F7B8B-5175-4CA9-BC2B-438E37F7F43E}.WithOpenPGM|Win32.Build.0 = Release|Win32
EndGlobalSection
GlobalSection(SolutionProperties) = preSolution
HideSolutionNode = FALSE
diff --git a/builds/msvc/platform.hpp b/builds/msvc/platform.hpp
index 9c0c8ae..4af872c 100644
--- a/builds/msvc/platform.hpp
+++ b/builds/msvc/platform.hpp
@@ -1,26 +1,27 @@
/*
- Copyright (c) 2007-2010 iMatix Corporation
+ Copyright (c) 2007-2011 iMatix Corporation
+ Copyright (c) 2007-2011 Other contributors as noted in the AUTHORS file
This file is part of 0MQ.
0MQ is free software; you can redistribute it and/or modify it under
- the terms of the Lesser GNU General Public License as published by
+ the terms of the GNU Lesser General Public License as published by
the Free Software Foundation; either version 3 of the License, or
(at your option) any later version.
0MQ is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- Lesser GNU General Public License for more details.
+ GNU Lesser General Public License for more details.
- You should have received a copy of the Lesser GNU General Public License
+ You should have received a copy of the GNU Lesser General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
#ifndef __ZMQ_PLATFORM_HPP_INCLUDED__
#define __ZMQ_PLATFORM_HPP_INCLUDED__
-// This is the platform definition for the Windows platform.
+// This is the platform definition for the MSVC platform.
// As a first step of the build process it is copied to
// zmq directory to take place of platform.hpp generated from
// platform.hpp.in on platforms supported by GNU autotools.
diff --git a/builds/msvc/zmq_forwarder/zmq_forwarder.vcproj b/builds/msvc/zmq_forwarder/zmq_forwarder.vcproj
deleted file mode 100644
index c8f587d..0000000
--- a/builds/msvc/zmq_forwarder/zmq_forwarder.vcproj
+++ /dev/null
@@ -1,176 +0,0 @@
-<?xml version="1.0" encoding="windows-1250"?>
-<VisualStudioProject
- ProjectType="Visual C++"
- Version="9.00"
- Name="zmq_forwarder"
- ProjectGUID="{EFE471DE-6747-4B2E-B084-F7E45A16CD03}"
- RootNamespace="zmq_forwarder"
- TargetFrameworkVersion="196613"
- >
- <Platforms>
- <Platform
- Name="Win32"
- />
- </Platforms>
- <ToolFiles>
- </ToolFiles>
- <Configurations>
- <Configuration
- Name="Debug|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="0"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- MinimalRebuild="true"
- BasicRuntimeChecks="3"
- RuntimeLibrary="3"
- WarningLevel="3"
- DebugInformationFormat="4"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_forwarder.exe"
- GenerateDebugInformation="true"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- <Configuration
- Name="Release|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- WholeProgramOptimization="1"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="2"
- EnableIntrinsicFunctions="true"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- RuntimeLibrary="2"
- EnableFunctionLevelLinking="true"
- WarningLevel="3"
- DebugInformationFormat="3"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_forwarder.exe"
- GenerateDebugInformation="true"
- OptimizeReferences="2"
- EnableCOMDATFolding="2"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- </Configurations>
- <References>
- </References>
- <Files>
- <Filter
- Name="Source Files"
- Filter="cpp;c;cc;cxx;def;odl;idl;hpj;bat;asm;asmx"
- UniqueIdentifier="{4FC737F1-C7A5-4376-A066-2A32D752A2FF}"
- >
- <File
- RelativePath="..\..\..\devices\zmq_forwarder\zmq_forwarder.cpp"
- >
- </File>
- </Filter>
- </Files>
- <Globals>
- </Globals>
-</VisualStudioProject>
diff --git a/builds/msvc/zmq_queue/zmq_queue.vcproj b/builds/msvc/zmq_queue/zmq_queue.vcproj
deleted file mode 100644
index 499ed36..0000000
--- a/builds/msvc/zmq_queue/zmq_queue.vcproj
+++ /dev/null
@@ -1,176 +0,0 @@
-<?xml version="1.0" encoding="Windows-1252"?>
-<VisualStudioProject
- ProjectType="Visual C++"
- Version="9.00"
- Name="zmq_queue"
- ProjectGUID="{076F7B8B-5175-4CA9-BC2B-438E37F7F43E}"
- RootNamespace="zmq_queue"
- TargetFrameworkVersion="196613"
- >
- <Platforms>
- <Platform
- Name="Win32"
- />
- </Platforms>
- <ToolFiles>
- </ToolFiles>
- <Configurations>
- <Configuration
- Name="Debug|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="0"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- MinimalRebuild="true"
- BasicRuntimeChecks="3"
- RuntimeLibrary="3"
- WarningLevel="3"
- DebugInformationFormat="4"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_queue.exe"
- GenerateDebugInformation="true"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- <Configuration
- Name="Release|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- WholeProgramOptimization="1"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="2"
- EnableIntrinsicFunctions="true"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- RuntimeLibrary="2"
- EnableFunctionLevelLinking="true"
- WarningLevel="3"
- DebugInformationFormat="3"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_queue.exe"
- GenerateDebugInformation="true"
- OptimizeReferences="2"
- EnableCOMDATFolding="2"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- </Configurations>
- <References>
- </References>
- <Files>
- <Filter
- Name="Source Files"
- Filter="cpp;c;cc;cxx;def;odl;idl;hpj;bat;asm;asmx"
- UniqueIdentifier="{4FC737F1-C7A5-4376-A066-2A32D752A2FF}"
- >
- <File
- RelativePath="..\..\..\devices\zmq_queue\zmq_queue.cpp"
- >
- </File>
- </Filter>
- </Files>
- <Globals>
- </Globals>
-</VisualStudioProject>
diff --git a/builds/msvc/zmq_streamer/zmq_streamer.vcproj b/builds/msvc/zmq_streamer/zmq_streamer.vcproj
deleted file mode 100644
index e2f5fa6..0000000
--- a/builds/msvc/zmq_streamer/zmq_streamer.vcproj
+++ /dev/null
@@ -1,176 +0,0 @@
-<?xml version="1.0" encoding="Windows-1252"?>
-<VisualStudioProject
- ProjectType="Visual C++"
- Version="9.00"
- Name="zmq_streamer"
- ProjectGUID="{DF2CED64-4156-48EA-8AA3-38CF86060D59}"
- RootNamespace="zmq_streamer"
- TargetFrameworkVersion="196613"
- >
- <Platforms>
- <Platform
- Name="Win32"
- />
- </Platforms>
- <ToolFiles>
- </ToolFiles>
- <Configurations>
- <Configuration
- Name="Debug|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="0"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- MinimalRebuild="true"
- BasicRuntimeChecks="3"
- RuntimeLibrary="3"
- WarningLevel="3"
- DebugInformationFormat="4"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_streamer.exe"
- GenerateDebugInformation="true"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- <Configuration
- Name="Release|Win32"
- OutputDirectory="$(SolutionDir)$(ConfigurationName)"
- IntermediateDirectory="$(ConfigurationName)"
- ConfigurationType="1"
- CharacterSet="2"
- WholeProgramOptimization="1"
- >
- <Tool
- Name="VCPreBuildEventTool"
- />
- <Tool
- Name="VCCustomBuildTool"
- />
- <Tool
- Name="VCXMLDataGeneratorTool"
- />
- <Tool
- Name="VCWebServiceProxyGeneratorTool"
- />
- <Tool
- Name="VCMIDLTool"
- />
- <Tool
- Name="VCCLCompilerTool"
- Optimization="2"
- EnableIntrinsicFunctions="true"
- AdditionalIncludeDirectories="../../../bindings/c;../../../bindings/cpp"
- RuntimeLibrary="2"
- EnableFunctionLevelLinking="true"
- WarningLevel="3"
- DebugInformationFormat="3"
- />
- <Tool
- Name="VCManagedResourceCompilerTool"
- />
- <Tool
- Name="VCResourceCompilerTool"
- />
- <Tool
- Name="VCPreLinkEventTool"
- />
- <Tool
- Name="VCLinkerTool"
- OutputFile="../../../bin/zmq_streamer.exe"
- GenerateDebugInformation="true"
- OptimizeReferences="2"
- EnableCOMDATFolding="2"
- TargetMachine="1"
- />
- <Tool
- Name="VCALinkTool"
- />
- <Tool
- Name="VCManifestTool"
- />
- <Tool
- Name="VCXDCMakeTool"
- />
- <Tool
- Name="VCBscMakeTool"
- />
- <Tool
- Name="VCFxCopTool"
- />
- <Tool
- Name="VCAppVerifierTool"
- />
- <Tool
- Name="VCPostBuildEventTool"
- />
- </Configuration>
- </Configurations>
- <References>
- </References>
- <Files>
- <Filter
- Name="Source Files"
- Filter="cpp;c;cc;cxx;def;odl;idl;hpj;bat;asm;asmx"
- UniqueIdentifier="{4FC737F1-C7A5-4376-A066-2A32D752A2FF}"
- >
- <File
- RelativePath="..\..\..\devices\zmq_streamer\zmq_streamer.cpp"
- >
- </File>
- </Filter>
- </Files>
- <Globals>
- </Globals>
-</VisualStudioProject>