summaryrefslogtreecommitdiff
path: root/perf
diff options
context:
space:
mode:
authorMartin Lucina <martin@lucina.net>2012-01-23 08:53:19 +0100
committerMartin Lucina <martin@lucina.net>2012-01-23 08:53:19 +0100
commita15854bd92db69fcd0b4444fe1b8fe3610a7acf6 (patch)
tree1214b945d0f0033ff318de367c70525ea141ef56 /perf
Imported Upstream version 2.0.7.dfsgupstream/2.0.7.dfsg
Diffstat (limited to 'perf')
-rw-r--r--perf/Makefile.am16
-rw-r--r--perf/Makefile.in492
-rw-r--r--perf/helpers.cpp86
-rw-r--r--perf/helpers.h40
-rw-r--r--perf/local_lat.cpp107
-rw-r--r--perf/local_thr.cpp137
-rw-r--r--perf/remote_lat.cpp120
-rw-r--r--perf/remote_thr.cpp99
8 files changed, 1097 insertions, 0 deletions
diff --git a/perf/Makefile.am b/perf/Makefile.am
new file mode 100644
index 0000000..323c91a
--- /dev/null
+++ b/perf/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = -I$(top_builddir)/include
+
+noinst_PROGRAMS = local_lat remote_lat local_thr remote_thr
+EXTRA_DIST = helpers.h
+
+local_lat_LDADD = $(top_builddir)/src/libzmq.la
+local_lat_SOURCES = local_lat.cpp helpers.cpp
+
+remote_lat_LDADD = $(top_builddir)/src/libzmq.la
+remote_lat_SOURCES = remote_lat.cpp helpers.cpp
+
+local_thr_LDADD = $(top_builddir)/src/libzmq.la
+local_thr_SOURCES = local_thr.cpp helpers.cpp
+
+remote_thr_LDADD = $(top_builddir)/src/libzmq.la
+remote_thr_SOURCES = remote_thr.cpp helpers.cpp
diff --git a/perf/Makefile.in b/perf/Makefile.in
new file mode 100644
index 0000000..ed9e5d7
--- /dev/null
+++ b/perf/Makefile.in
@@ -0,0 +1,492 @@
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
+# @configure_input@
+
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
+# This Makefile.in is free software; the Free Software Foundation
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
+
+@SET_MAKE@
+
+VPATH = @srcdir@
+pkgdatadir = $(datadir)/@PACKAGE@
+pkglibdir = $(libdir)/@PACKAGE@
+pkgincludedir = $(includedir)/@PACKAGE@
+am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
+install_sh_DATA = $(install_sh) -c -m 644
+install_sh_PROGRAM = $(install_sh) -c
+install_sh_SCRIPT = $(install_sh) -c
+INSTALL_HEADER = $(INSTALL_DATA)
+transform = $(program_transform_name)
+NORMAL_INSTALL = :
+PRE_INSTALL = :
+POST_INSTALL = :
+NORMAL_UNINSTALL = :
+PRE_UNINSTALL = :
+POST_UNINSTALL = :
+build_triplet = @build@
+host_triplet = @host@
+noinst_PROGRAMS = local_lat$(EXEEXT) remote_lat$(EXEEXT) \
+ local_thr$(EXEEXT) remote_thr$(EXEEXT)
+subdir = perf
+DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
+ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+am__aclocal_m4_deps = $(top_srcdir)/config/libtool.m4 \
+ $(top_srcdir)/config/ltoptions.m4 \
+ $(top_srcdir)/config/ltsugar.m4 \
+ $(top_srcdir)/config/ltversion.m4 \
+ $(top_srcdir)/config/lt~obsolete.m4 $(top_srcdir)/configure.in
+am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+mkinstalldirs = $(install_sh) -d
+CONFIG_HEADER = $(top_builddir)/src/platform.hpp
+CONFIG_CLEAN_FILES =
+PROGRAMS = $(noinst_PROGRAMS)
+am_local_lat_OBJECTS = local_lat.$(OBJEXT) helpers.$(OBJEXT)
+local_lat_OBJECTS = $(am_local_lat_OBJECTS)
+local_lat_DEPENDENCIES = $(top_builddir)/src/libzmq.la
+am_local_thr_OBJECTS = local_thr.$(OBJEXT) helpers.$(OBJEXT)
+local_thr_OBJECTS = $(am_local_thr_OBJECTS)
+local_thr_DEPENDENCIES = $(top_builddir)/src/libzmq.la
+am_remote_lat_OBJECTS = remote_lat.$(OBJEXT) helpers.$(OBJEXT)
+remote_lat_OBJECTS = $(am_remote_lat_OBJECTS)
+remote_lat_DEPENDENCIES = $(top_builddir)/src/libzmq.la
+am_remote_thr_OBJECTS = remote_thr.$(OBJEXT) helpers.$(OBJEXT)
+remote_thr_OBJECTS = $(am_remote_thr_OBJECTS)
+remote_thr_DEPENDENCIES = $(top_builddir)/src/libzmq.la
+DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/src
+depcomp = $(SHELL) $(top_srcdir)/config/depcomp
+am__depfiles_maybe = depfiles
+CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+LTCXXCOMPILE = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=compile $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+CXXLD = $(CXX)
+CXXLINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXXLD) $(AM_CXXFLAGS) $(CXXFLAGS) $(AM_LDFLAGS) \
+ $(LDFLAGS) -o $@
+SOURCES = $(local_lat_SOURCES) $(local_thr_SOURCES) \
+ $(remote_lat_SOURCES) $(remote_thr_SOURCES)
+DIST_SOURCES = $(local_lat_SOURCES) $(local_thr_SOURCES) \
+ $(remote_lat_SOURCES) $(remote_thr_SOURCES)
+ETAGS = etags
+CTAGS = ctags
+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+ACLOCAL = @ACLOCAL@
+AMTAR = @AMTAR@
+AR = @AR@
+AS = @AS@
+AUTOCONF = @AUTOCONF@
+AUTOHEADER = @AUTOHEADER@
+AUTOMAKE = @AUTOMAKE@
+AWK = @AWK@
+CC = @CC@
+CCDEPMODE = @CCDEPMODE@
+CFLAGS = @CFLAGS@
+CPP = @CPP@
+CPPFLAGS = @CPPFLAGS@
+CXX = @CXX@
+CXXCPP = @CXXCPP@
+CXXDEPMODE = @CXXDEPMODE@
+CXXFLAGS = @CXXFLAGS@
+CYGPATH_W = @CYGPATH_W@
+DEFS = @DEFS@
+DEPDIR = @DEPDIR@
+DLLTOOL = @DLLTOOL@
+DSYMUTIL = @DSYMUTIL@
+DUMPBIN = @DUMPBIN@
+ECHO_C = @ECHO_C@
+ECHO_N = @ECHO_N@
+ECHO_T = @ECHO_T@
+EGREP = @EGREP@
+EXEEXT = @EXEEXT@
+FGREP = @FGREP@
+GLIB_CFLAGS = @GLIB_CFLAGS@
+GLIB_LIBS = @GLIB_LIBS@
+GREP = @GREP@
+INSTALL = @INSTALL@
+INSTALL_DATA = @INSTALL_DATA@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+LD = @LD@
+LDFLAGS = @LDFLAGS@
+LIBOBJS = @LIBOBJS@
+LIBS = @LIBS@
+LIBTOOL = @LIBTOOL@
+LIBZMQ_EXTRA_CXXFLAGS = @LIBZMQ_EXTRA_CXXFLAGS@
+LIBZMQ_EXTRA_LDFLAGS = @LIBZMQ_EXTRA_LDFLAGS@
+LIPO = @LIPO@
+LN_S = @LN_S@
+LTLIBOBJS = @LTLIBOBJS@
+LTVER = @LTVER@
+MAKEINFO = @MAKEINFO@
+MKDIR_P = @MKDIR_P@
+NM = @NM@
+NMEDIT = @NMEDIT@
+OBJDUMP = @OBJDUMP@
+OBJEXT = @OBJEXT@
+OTOOL = @OTOOL@
+OTOOL64 = @OTOOL64@
+PACKAGE = @PACKAGE@
+PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+PACKAGE_NAME = @PACKAGE_NAME@
+PACKAGE_STRING = @PACKAGE_STRING@
+PACKAGE_TARNAME = @PACKAGE_TARNAME@
+PACKAGE_VERSION = @PACKAGE_VERSION@
+PATH_SEPARATOR = @PATH_SEPARATOR@
+PKG_CONFIG = @PKG_CONFIG@
+RANLIB = @RANLIB@
+SED = @SED@
+SET_MAKE = @SET_MAKE@
+SHELL = @SHELL@
+STRIP = @STRIP@
+VERSION = @VERSION@
+abs_builddir = @abs_builddir@
+abs_srcdir = @abs_srcdir@
+abs_top_builddir = @abs_top_builddir@
+abs_top_srcdir = @abs_top_srcdir@
+ac_ct_CC = @ac_ct_CC@
+ac_ct_CXX = @ac_ct_CXX@
+ac_ct_DUMPBIN = @ac_ct_DUMPBIN@
+am__include = @am__include@
+am__leading_dot = @am__leading_dot@
+am__quote = @am__quote@
+am__tar = @am__tar@
+am__untar = @am__untar@
+bindir = @bindir@
+build = @build@
+build_alias = @build_alias@
+build_cpu = @build_cpu@
+build_os = @build_os@
+build_vendor = @build_vendor@
+builddir = @builddir@
+datadir = @datadir@
+datarootdir = @datarootdir@
+docdir = @docdir@
+dvidir = @dvidir@
+exec_prefix = @exec_prefix@
+have_asciidoc = @have_asciidoc@
+have_gzip = @have_gzip@
+have_perl = @have_perl@
+have_pkg_config = @have_pkg_config@
+have_python = @have_python@
+have_xmlto = @have_xmlto@
+host = @host@
+host_alias = @host_alias@
+host_cpu = @host_cpu@
+host_os = @host_os@
+host_vendor = @host_vendor@
+htmldir = @htmldir@
+includedir = @includedir@
+infodir = @infodir@
+install_sh = @install_sh@
+inttypes = @inttypes@
+libdir = @libdir@
+libexecdir = @libexecdir@
+localedir = @localedir@
+localstatedir = @localstatedir@
+lt_ECHO = @lt_ECHO@
+mandir = @mandir@
+mkdir_p = @mkdir_p@
+oldincludedir = @oldincludedir@
+pdfdir = @pdfdir@
+pgm_basename = @pgm_basename@
+prefix = @prefix@
+program_transform_name = @program_transform_name@
+psdir = @psdir@
+sbindir = @sbindir@
+sharedstatedir = @sharedstatedir@
+srcdir = @srcdir@
+stdint = @stdint@
+sysconfdir = @sysconfdir@
+target_alias = @target_alias@
+top_builddir = @top_builddir@
+top_srcdir = @top_srcdir@
+INCLUDES = -I$(top_builddir)/include
+EXTRA_DIST = helpers.h
+local_lat_LDADD = $(top_builddir)/src/libzmq.la
+local_lat_SOURCES = local_lat.cpp helpers.cpp
+remote_lat_LDADD = $(top_builddir)/src/libzmq.la
+remote_lat_SOURCES = remote_lat.cpp helpers.cpp
+local_thr_LDADD = $(top_builddir)/src/libzmq.la
+local_thr_SOURCES = local_thr.cpp helpers.cpp
+remote_thr_LDADD = $(top_builddir)/src/libzmq.la
+remote_thr_SOURCES = remote_thr.cpp helpers.cpp
+all: all-am
+
+.SUFFIXES:
+.SUFFIXES: .cpp .lo .o .obj
+$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
+ @for dep in $?; do \
+ case '$(am__configure_deps)' in \
+ *$$dep*) \
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh \
+ && exit 0; \
+ exit 1;; \
+ esac; \
+ done; \
+ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu perf/Makefile'; \
+ cd $(top_srcdir) && \
+ $(AUTOMAKE) --gnu perf/Makefile
+.PRECIOUS: Makefile
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ @case '$?' in \
+ *config.status*) \
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh;; \
+ *) \
+ echo ' cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe)'; \
+ cd $(top_builddir) && $(SHELL) ./config.status $(subdir)/$@ $(am__depfiles_maybe);; \
+ esac;
+
+$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+
+$(top_srcdir)/configure: $(am__configure_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+ cd $(top_builddir) && $(MAKE) $(AM_MAKEFLAGS) am--refresh
+
+clean-noinstPROGRAMS:
+ @list='$(noinst_PROGRAMS)'; for p in $$list; do \
+ f=`echo $$p|sed 's/$(EXEEXT)$$//'`; \
+ echo " rm -f $$p $$f"; \
+ rm -f $$p $$f ; \
+ done
+local_lat$(EXEEXT): $(local_lat_OBJECTS) $(local_lat_DEPENDENCIES)
+ @rm -f local_lat$(EXEEXT)
+ $(CXXLINK) $(local_lat_OBJECTS) $(local_lat_LDADD) $(LIBS)
+local_thr$(EXEEXT): $(local_thr_OBJECTS) $(local_thr_DEPENDENCIES)
+ @rm -f local_thr$(EXEEXT)
+ $(CXXLINK) $(local_thr_OBJECTS) $(local_thr_LDADD) $(LIBS)
+remote_lat$(EXEEXT): $(remote_lat_OBJECTS) $(remote_lat_DEPENDENCIES)
+ @rm -f remote_lat$(EXEEXT)
+ $(CXXLINK) $(remote_lat_OBJECTS) $(remote_lat_LDADD) $(LIBS)
+remote_thr$(EXEEXT): $(remote_thr_OBJECTS) $(remote_thr_DEPENDENCIES)
+ @rm -f remote_thr$(EXEEXT)
+ $(CXXLINK) $(remote_thr_OBJECTS) $(remote_thr_LDADD) $(LIBS)
+
+mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
+
+distclean-compile:
+ -rm -f *.tab.c
+
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/helpers.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/local_lat.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/local_thr.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/remote_lat.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/remote_thr.Po@am__quote@
+
+.cpp.o:
+@am__fastdepCXX_TRUE@ $(CXXCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCXX_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(CXXCOMPILE) -c -o $@ $<
+
+.cpp.obj:
+@am__fastdepCXX_TRUE@ $(CXXCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ `$(CYGPATH_W) '$<'`
+@am__fastdepCXX_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(CXXCOMPILE) -c -o $@ `$(CYGPATH_W) '$<'`
+
+.cpp.lo:
+@am__fastdepCXX_TRUE@ $(LTCXXCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
+@am__fastdepCXX_TRUE@ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Plo
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='$<' object='$@' libtool=yes @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCXX_FALSE@ $(LTCXXCOMPILE) -c -o $@ $<
+
+mostlyclean-libtool:
+ -rm -f *.lo
+
+clean-libtool:
+ -rm -rf .libs _libs
+
+ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
+ unique=`for i in $$list; do \
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
+ done | \
+ $(AWK) '{ files[$$0] = 1; nonemtpy = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
+ mkid -fID $$unique
+tags: TAGS
+
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
+ $(TAGS_FILES) $(LISP)
+ tags=; \
+ here=`pwd`; \
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
+ unique=`for i in $$list; do \
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
+ done | \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
+ if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
+ test -n "$$unique" || unique=$$empty_fix; \
+ $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
+ $$tags $$unique; \
+ fi
+ctags: CTAGS
+CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
+ $(TAGS_FILES) $(LISP)
+ tags=; \
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
+ unique=`for i in $$list; do \
+ if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
+ done | \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
+ test -z "$(CTAGS_ARGS)$$tags$$unique" \
+ || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
+ $$tags $$unique
+
+GTAGS:
+ here=`$(am__cd) $(top_builddir) && pwd` \
+ && cd $(top_srcdir) \
+ && gtags -i $(GTAGS_ARGS) $$here
+
+distclean-tags:
+ -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
+
+distdir: $(DISTFILES)
+ @srcdirstrip=`echo "$(srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
+ topsrcdirstrip=`echo "$(top_srcdir)" | sed 's/[].[^$$\\*]/\\\\&/g'`; \
+ list='$(DISTFILES)'; \
+ dist_files=`for file in $$list; do echo $$file; done | \
+ sed -e "s|^$$srcdirstrip/||;t" \
+ -e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t"`; \
+ case $$dist_files in \
+ */*) $(MKDIR_P) `echo "$$dist_files" | \
+ sed '/\//!d;s|^|$(distdir)/|;s,/[^/]*$$,,' | \
+ sort -u` ;; \
+ esac; \
+ for file in $$dist_files; do \
+ if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
+ if test -d $$d/$$file; then \
+ dir=`echo "/$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
+ cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
+ fi; \
+ cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
+ else \
+ test -f $(distdir)/$$file \
+ || cp -p $$d/$$file $(distdir)/$$file \
+ || exit 1; \
+ fi; \
+ done
+check-am: all-am
+check: check-am
+all-am: Makefile $(PROGRAMS)
+installdirs:
+install: install-am
+install-exec: install-exec-am
+install-data: install-data-am
+uninstall: uninstall-am
+
+install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+
+installcheck: installcheck-am
+install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
+ `test -z '$(STRIP)' || \
+ echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+mostlyclean-generic:
+
+clean-generic:
+
+distclean-generic:
+ -test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
+
+maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+ @echo "it deletes files that may require special tools to rebuild."
+clean: clean-am
+
+clean-am: clean-generic clean-libtool clean-noinstPROGRAMS \
+ mostlyclean-am
+
+distclean: distclean-am
+ -rm -rf ./$(DEPDIR)
+ -rm -f Makefile
+distclean-am: clean-am distclean-compile distclean-generic \
+ distclean-tags
+
+dvi: dvi-am
+
+dvi-am:
+
+html: html-am
+
+info: info-am
+
+info-am:
+
+install-data-am:
+
+install-dvi: install-dvi-am
+
+install-exec-am:
+
+install-html: install-html-am
+
+install-info: install-info-am
+
+install-man:
+
+install-pdf: install-pdf-am
+
+install-ps: install-ps-am
+
+installcheck-am:
+
+maintainer-clean: maintainer-clean-am
+ -rm -rf ./$(DEPDIR)
+ -rm -f Makefile
+maintainer-clean-am: distclean-am maintainer-clean-generic
+
+mostlyclean: mostlyclean-am
+
+mostlyclean-am: mostlyclean-compile mostlyclean-generic \
+ mostlyclean-libtool
+
+pdf: pdf-am
+
+pdf-am:
+
+ps: ps-am
+
+ps-am:
+
+uninstall-am:
+
+.MAKE: install-am install-strip
+
+.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
+ clean-libtool clean-noinstPROGRAMS ctags distclean \
+ distclean-compile distclean-generic distclean-libtool \
+ distclean-tags distdir dvi dvi-am html html-am info info-am \
+ install install-am install-data install-data-am install-dvi \
+ install-dvi-am install-exec install-exec-am install-html \
+ install-html-am install-info install-info-am install-man \
+ install-pdf install-pdf-am install-ps install-ps-am \
+ install-strip installcheck installcheck-am installdirs \
+ maintainer-clean maintainer-clean-generic mostlyclean \
+ mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
+ pdf pdf-am ps ps-am tags uninstall uninstall-am
+
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT:
diff --git a/perf/helpers.cpp b/perf/helpers.cpp
new file mode 100644
index 0000000..94b653f
--- /dev/null
+++ b/perf/helpers.cpp
@@ -0,0 +1,86 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include <assert.h>
+#include <stdlib.h>
+#ifdef _WIN32
+# include "../src/windows.hpp"
+#else
+# include <sys/time.h>
+# include <unistd.h>
+#endif
+#include "../src/stdint.hpp"
+
+#ifdef _WIN32
+
+static uint64_t now ()
+{
+ // Get the high resolution counter's accuracy.
+ LARGE_INTEGER ticksPerSecond;
+ QueryPerformanceFrequency (&ticksPerSecond);
+
+ // What time is it?
+ LARGE_INTEGER tick;
+ QueryPerformanceCounter (&tick);
+
+ // Convert the tick number into the number of seconds
+ // since the system was started.
+ double ticks_div = (double) (ticksPerSecond.QuadPart / 1000000);
+ return (uint64_t) (tick.QuadPart / ticks_div);
+}
+
+void perf_sleep (int seconds_)
+{
+ Sleep (seconds_ * 1000);
+}
+
+#else /* not _WIN32 */
+
+static uint64_t now ()
+{
+ struct timeval tv;
+ int rc;
+
+ rc = gettimeofday (&tv, NULL);
+ assert (rc == 0);
+ return (tv.tv_sec * (uint64_t) 1000000 + tv.tv_usec);
+}
+
+void perf_sleep (int seconds_)
+{
+ sleep (seconds_);
+}
+
+#endif /* _WIN32 */
+
+void *stopwatch_start ()
+{
+ uint64_t *watch = (uint64_t*) malloc (sizeof (uint64_t));
+ assert (watch);
+ *watch = now ();
+ return (void*) watch;
+}
+
+unsigned long stopwatch_stop (void *watch_)
+{
+ uint64_t end = now ();
+ uint64_t start = *(uint64_t*) watch_;
+ free (watch_);
+ return (unsigned long) (end - start);
+}
diff --git a/perf/helpers.h b/perf/helpers.h
new file mode 100644
index 0000000..b790f59
--- /dev/null
+++ b/perf/helpers.h
@@ -0,0 +1,40 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#ifndef __HELPERS_H_INCLUDED__
+#define __HELPERS_H_INCLUDED__
+
+/******************************************************************************/
+/* Helper functions. */
+/******************************************************************************/
+
+/* Helper functions are used by perf tests so that they don't have to care */
+/* about minutiae of time-related functions on different OS platforms. */
+
+/* Starts the stopwatch. Returns the handle to the watch. */
+void *stopwatch_start ();
+
+/* Stops the stopwatch. Returns the number of microseconds elapsed since */
+/* the stopwatch was started. */
+unsigned long stopwatch_stop (void *watch_);
+
+/* Sleeps for specified number of seconds. */
+void perf_sleep (int seconds_);
+
+#endif
diff --git a/perf/local_lat.cpp b/perf/local_lat.cpp
new file mode 100644
index 0000000..0628a97
--- /dev/null
+++ b/perf/local_lat.cpp
@@ -0,0 +1,107 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "../include/zmq.h"
+#include <stdio.h>
+#include <stdlib.h>
+#include "helpers.h"
+
+int main (int argc, char *argv [])
+{
+ const char *bind_to;
+ int roundtrip_count;
+ size_t message_size;
+ void *ctx;
+ void *s;
+ int rc;
+ int i;
+ zmq_msg_t msg;
+
+ if (argc != 4) {
+ printf ("usage: local_lat <bind-to> <message-size> "
+ "<roundtrip-count>\n");
+ return 1;
+ }
+ bind_to = argv [1];
+ message_size = atoi (argv [2]);
+ roundtrip_count = atoi (argv [3]);
+
+ ctx = zmq_init (1);
+ if (!ctx) {
+ printf ("error in zmq_init: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ s = zmq_socket (ctx, ZMQ_REP);
+ if (!s) {
+ printf ("error in zmq_socket: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_bind (s, bind_to);
+ if (rc != 0) {
+ printf ("error in zmq_bind: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_msg_init (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_init: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ for (i = 0; i != roundtrip_count; i++) {
+ rc = zmq_recv (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_recv: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ if (zmq_msg_size (&msg) != message_size) {
+ printf ("message of incorrect size received\n");
+ return -1;
+ }
+ rc = zmq_send (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_send: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ }
+
+ rc = zmq_msg_close (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ perf_sleep (1);
+
+ rc = zmq_close (s);
+ if (rc != 0) {
+ printf ("error in zmq_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_term (ctx);
+ if (rc != 0) {
+ printf ("error in zmq_term: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ return 0;
+}
diff --git a/perf/local_thr.cpp b/perf/local_thr.cpp
new file mode 100644
index 0000000..8480ebd
--- /dev/null
+++ b/perf/local_thr.cpp
@@ -0,0 +1,137 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "../include/zmq.h"
+#include <stdio.h>
+#include <stdlib.h>
+#include "helpers.h"
+
+int main (int argc, char *argv [])
+{
+ const char *bind_to;
+ int message_count;
+ size_t message_size;
+ void *ctx;
+ void *s;
+ int rc;
+ int i;
+ zmq_msg_t msg;
+ void *watch;
+ unsigned long elapsed;
+ unsigned long throughput;
+ double megabits;
+
+ if (argc != 4) {
+ printf ("usage: local_thr <bind-to> <message-size> <message-count>\n");
+ return 1;
+ }
+ bind_to = argv [1];
+ message_size = atoi (argv [2]);
+ message_count = atoi (argv [3]);
+
+ ctx = zmq_init (1);
+ if (!ctx) {
+ printf ("error in zmq_send: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ s = zmq_socket (ctx, ZMQ_SUB);
+ if (!s) {
+ printf ("error in zmq_socket: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_setsockopt (s, ZMQ_SUBSCRIBE , "", 0);
+ if (rc != 0) {
+ printf ("error in zmq_setsockopt: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ // Add your socket options here.
+ // For example ZMQ_RATE, ZMQ_RECOVERY_IVL and ZMQ_MCAST_LOOP for PGM.
+
+ rc = zmq_bind (s, bind_to);
+ if (rc != 0) {
+ printf ("error in zmq_bind: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_msg_init (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_init: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_recv (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_recv: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ if (zmq_msg_size (&msg) != message_size) {
+ printf ("message of incorrect size received\n");
+ return -1;
+ }
+
+ watch = stopwatch_start ();
+
+ for (i = 0; i != message_count - 1; i++) {
+ rc = zmq_recv (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_recv: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ if (zmq_msg_size (&msg) != message_size) {
+ printf ("message of incorrect size received\n");
+ return -1;
+ }
+ }
+
+ elapsed = stopwatch_stop (watch);
+ if (elapsed == 0)
+ elapsed = 1;
+
+ rc = zmq_msg_close (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ throughput = (unsigned long)
+ ((double) message_count / (double) elapsed * 1000000);
+ megabits = (double) (throughput * message_size * 8) / 1000000;
+
+ printf ("message size: %d [B]\n", (int) message_size);
+ printf ("message count: %d\n", (int) message_count);
+ printf ("mean throughput: %d [msg/s]\n", (int) throughput);
+ printf ("mean throughput: %.3f [Mb/s]\n", (double) megabits);
+
+ rc = zmq_close (s);
+ if (rc != 0) {
+ printf ("error in zmq_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_term (ctx);
+ if (rc != 0) {
+ printf ("error in zmq_term: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ return 0;
+}
diff --git a/perf/remote_lat.cpp b/perf/remote_lat.cpp
new file mode 100644
index 0000000..cd465f7
--- /dev/null
+++ b/perf/remote_lat.cpp
@@ -0,0 +1,120 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "../include/zmq.h"
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include "helpers.h"
+
+int main (int argc, char *argv [])
+{
+ const char *connect_to;
+ int roundtrip_count;
+ size_t message_size;
+ void *ctx;
+ void *s;
+ int rc;
+ int i;
+ zmq_msg_t msg;
+ void *watch;
+ unsigned long elapsed;
+ double latency;
+
+ if (argc != 4) {
+ printf ("usage: remote_lat <connect-to> <message-size> "
+ "<roundtrip-count>\n");
+ return 1;
+ }
+ connect_to = argv [1];
+ message_size = atoi (argv [2]);
+ roundtrip_count = atoi (argv [3]);
+
+ ctx = zmq_init (1);
+ if (!ctx) {
+ printf ("error in zmq_init: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ s = zmq_socket (ctx, ZMQ_REQ);
+ if (!s) {
+ printf ("error in zmq_socket: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_connect (s, connect_to);
+ if (rc != 0) {
+ printf ("error in zmq_connect: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_msg_init_size (&msg, message_size);
+ if (rc != 0) {
+ printf ("error in zmq_msg_init_size: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ memset (zmq_msg_data (&msg), 0, message_size);
+
+ watch = stopwatch_start ();
+
+ for (i = 0; i != roundtrip_count; i++) {
+ rc = zmq_send (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_send: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ rc = zmq_recv (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_recv: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ if (zmq_msg_size (&msg) != message_size) {
+ printf ("message of incorrect size received\n");
+ return -1;
+ }
+ }
+
+ elapsed = stopwatch_stop (watch);
+
+ rc = zmq_msg_close (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ latency = (double) elapsed / (roundtrip_count * 2);
+
+ printf ("message size: %d [B]\n", (int) message_size);
+ printf ("roundtrip count: %d\n", (int) roundtrip_count);
+ printf ("average latency: %.3f [us]\n", (double) latency);
+
+ rc = zmq_close (s);
+ if (rc != 0) {
+ printf ("error in zmq_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_term (ctx);
+ if (rc != 0) {
+ printf ("error in zmq_term: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ return 0;
+}
diff --git a/perf/remote_thr.cpp b/perf/remote_thr.cpp
new file mode 100644
index 0000000..002aaf2
--- /dev/null
+++ b/perf/remote_thr.cpp
@@ -0,0 +1,99 @@
+/*
+ Copyright (c) 2007-2010 iMatix Corporation
+
+ This file is part of 0MQ.
+
+ 0MQ is free software; you can redistribute it and/or modify it under
+ the terms of the Lesser GNU General Public License as published by
+ the Free Software Foundation; either version 3 of the License, or
+ (at your option) any later version.
+
+ 0MQ is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ Lesser GNU General Public License for more details.
+
+ You should have received a copy of the Lesser GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "../include/zmq.h"
+#include <stdio.h>
+#include <stdlib.h>
+#include "helpers.h"
+
+int main (int argc, char *argv [])
+{
+ const char *connect_to;
+ int message_count;
+ int message_size;
+ void *ctx;
+ void *s;
+ int rc;
+ int i;
+ zmq_msg_t msg;
+
+ if (argc != 4) {
+ printf ("usage: remote_thr <connect-to> <message-size> "
+ "<message-count>\n");
+ return 1;
+ }
+ connect_to = argv [1];
+ message_size = atoi (argv [2]);
+ message_count = atoi (argv [3]);
+
+ ctx = zmq_init (1);
+ if (!ctx) {
+ printf ("error in zmq_recv: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ s = zmq_socket (ctx, ZMQ_PUB);
+ if (!s) {
+ printf ("error in zmq_socket: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ // Add your socket options here.
+ // For example ZMQ_RATE, ZMQ_RECOVERY_IVL and ZMQ_MCAST_LOOP for PGM.
+
+ rc = zmq_connect (s, connect_to);
+ if (rc != 0) {
+ printf ("error in zmq_connect: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ for (i = 0; i != message_count; i++) {
+ rc = zmq_msg_init_size (&msg, message_size);
+ if (rc != 0) {
+ printf ("error in zmq_msg_init_size: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ rc = zmq_send (s, &msg, 0);
+ if (rc != 0) {
+ printf ("error in zmq_send: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ rc = zmq_msg_close (&msg);
+ if (rc != 0) {
+ printf ("error in zmq_msg_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+ }
+
+ perf_sleep (10);
+
+ rc = zmq_close (s);
+ if (rc != 0) {
+ printf ("error in zmq_close: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ rc = zmq_term (ctx);
+ if (rc != 0) {
+ printf ("error in zmq_term: %s\n", zmq_strerror (errno));
+ return -1;
+ }
+
+ return 0;
+}