summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorMartin Lucina <martin@lucina.net>2012-01-23 08:53:35 +0100
committerMartin Lucina <martin@lucina.net>2012-01-23 08:53:35 +0100
commite645fc2693acc796304498909786b7b47005b429 (patch)
tree4118cd4c7b9eba3ba1d6892800c79669ea94c4e9 /tests/Makefile.am
parent2c416a793ea781273a5da6742211f5f01af13a2b (diff)
Imported Upstream version 2.1.3upstream/2.1.3
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..ebbc46c
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,30 @@
+INCLUDES = -I$(top_builddir)/include
+LDADD = $(top_builddir)/src/libzmq.la
+
+noinst_PROGRAMS = test_pair_inproc \
+ test_pair_tcp \
+ test_reqrep_inproc \
+ test_reqrep_tcp \
+ test_hwm
+
+if !ON_MINGW
+noinst_PROGRAMS += test_shutdown_stress \
+ test_pair_ipc \
+ test_reqrep_ipc
+endif
+
+test_pair_inproc_SOURCES = test_pair_inproc.cpp testutil.hpp
+test_pair_tcp_SOURCES = test_pair_tcp.cpp testutil.hpp
+
+test_reqrep_inproc_SOURCES = test_reqrep_inproc.cpp testutil.hpp
+test_reqrep_tcp_SOURCES = test_reqrep_tcp.cpp testutil.hpp
+
+test_hwm_SOURCES = test_hwm.cpp
+
+if !ON_MINGW
+test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
+test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
+test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
+endif
+
+TESTS = $(noinst_PROGRAMS)