summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog432
1 files changed, 432 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 9161480..98c598f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,437 @@
# Generated by Makefile. Do not edit.
+commit 8daada4bdc41bfe9da9e3c93c8b0f6c04a6cb0ec
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 10 20:30:31 2012 +0200
+
+ gcc_421_char_traits.hpp was missing from tarballs
+
+ src/Makefile.am | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit fb64b8801cd02776e1524aedc41083f9bf876e4d
+Merge: 2bdb487 f2a8fa1
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 04:36:54 2012 -0700
+
+ Merge pull request #47 from pieterh/master
+
+ Bumped version for next release (2.2.1)
+
+commit f2a8fa1de6d92c5264ff19e3ed05af115069edc0
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 12:26:45 2012 +0100
+
+ Bumped version number to 2.2.1 for next release
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 2bdb487abbe69984ec264ddcb785e032e1b0419f
+Merge: bfd04c5 0b2f5cb
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 04:11:29 2012 -0700
+
+ Merge pull request #46 from pieterh/master
+
+ Preparing for release 2.2.0
+
+commit 0b2f5cbac93b674e6282cc85222b64cf6a17950a
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 12:06:28 2012 +0100
+
+ Fixed man pages for release 2.2.0
+
+ * Fixed new entries for getsockopt/setsockopt SNDTIMEO and RCVTIMEO
+ * Removed individual authorship from man page footers
+
+ doc/zmq.txt | 3 +-
+ doc/zmq_bind.txt | 3 +-
+ doc/zmq_close.txt | 3 +-
+ doc/zmq_connect.txt | 3 +-
+ doc/zmq_cpp.txt | 3 +-
+ doc/zmq_device.txt | 16 +----------
+ doc/zmq_errno.txt | 3 +-
+ doc/zmq_getsockopt.txt | 67 ++++++++++++++++++++++-----------------------
+ doc/zmq_init.txt | 3 +-
+ doc/zmq_inproc.txt | 3 +-
+ doc/zmq_ipc.txt | 3 +-
+ doc/zmq_msg_close.txt | 3 +-
+ doc/zmq_msg_copy.txt | 3 +-
+ doc/zmq_msg_data.txt | 3 +-
+ doc/zmq_msg_init.txt | 3 +-
+ doc/zmq_msg_init_data.txt | 3 +-
+ doc/zmq_msg_init_size.txt | 3 +-
+ doc/zmq_msg_move.txt | 3 +-
+ doc/zmq_msg_size.txt | 3 +-
+ doc/zmq_pgm.txt | 4 +-
+ doc/zmq_poll.txt | 3 +-
+ doc/zmq_recv.txt | 3 +-
+ doc/zmq_send.txt | 3 +-
+ doc/zmq_setsockopt.txt | 67 ++++++++++++++++++++++-----------------------
+ doc/zmq_socket.txt | 3 +-
+ doc/zmq_strerror.txt | 3 +-
+ doc/zmq_tcp.txt | 3 +-
+ doc/zmq_term.txt | 3 +-
+ doc/zmq_version.txt | 4 +-
+ 29 files changed, 95 insertions(+), 135 deletions(-)
+
+commit 87cce25bd9b31a192297bc4213f45107f5a1b796
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 11:53:58 2012 +0100
+
+ Updated product version to 2.2.0
+
+ include/zmq.h | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 33af4869733de3f646daf2bafc242f813fb927f4
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 11:53:02 2012 +0100
+
+ Updated ABI version to 1.1.0
+
+ configure.in | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+commit b0d95774000b930125f24450f9e080b9e8b63a0c
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 4 11:50:50 2012 +0100
+
+ Updated NEWS for version 2.2.0
+
+ NEWS | 11 +++++++----
+ 1 files changed, 7 insertions(+), 4 deletions(-)
+
+commit bfd04c5b867890b4d6a563f2a7d95b5d183e84ba
+Merge: 6ab8ef0 1e5c6fa
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 3 05:27:13 2012 -0700
+
+ Merge pull request #45 from jhawk28/master
+
+ Fix issue 349
+
+commit 1e5c6fa0077dcd5767bc557fbccaf383dee98339
+Author: Joshua Foster <jhawk28@gmail.com>
+Date: Sun Apr 1 20:44:26 2012 -0400
+
+ Fix issue 349
+
+ https://zeromq.jira.com/browse/LIBZMQ-349
+ Add the send/recv socket options from 3.1.0.
+
+ .gitignore | 1 +
+ NEWS | 2 +
+ doc/zmq_getsockopt.txt | 32 ++++++++++++
+ doc/zmq_setsockopt.txt | 32 ++++++++++++
+ include/zmq.h | 4 +-
+ src/options.cpp | 39 +++++++++++++++-
+ src/options.hpp | 4 ++
+ src/socket_base.cpp | 8 ++--
+ tests/Makefile.am | 4 +-
+ tests/test_timeo.cpp | 125 ++++++++++++++++++++++++++++++++++++++++++++++++
+ 10 files changed, 244 insertions(+), 7 deletions(-)
+
+commit 6ab8ef084242299a9b8ada00b500126e465f6618
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Mar 20 14:48:45 2012 -0500
+
+ Updated NEWS for issue 342
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 6f3967176b1d3b6f0f586cc92848f9f6e80ee912
+Merge: 24f1175 4b8ace2
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Mar 20 12:47:19 2012 -0700
+
+ Merge pull request #42 from yisding/master
+
+ missing algorithm include
+
+commit 24f1175d942323697bff6ed1690ffbdcf2f33631
+Merge: 25c7cd0 48f70a8
+Author: Chuck Remes <cremes@mac.com>
+Date: Tue Mar 20 09:40:20 2012 -0700
+
+ Merge pull request #44 from pieterh/master
+
+ Fixed issue LIBZMQ-293 - libzmq doesn't follow ZMTP/1.0 spec
+
+commit 48f70a88a31245667fccd5227d60cac34a06855f
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Mar 20 11:28:36 2012 -0500
+
+ Fixed issue #293 - libzmq doesn't follow ZMTP/1.0 spec
+
+ NEWS | 4 +++-
+ src/encoder.cpp | 4 ++--
+ 2 files changed, 5 insertions(+), 3 deletions(-)
+
+commit 25c7cd0691b77770a4b85a13964e22d2274da4b7
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Mar 20 11:05:26 2012 -0500
+
+ Updated for issue 332
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 033907f2b810f8476c300c169e0fa6b912a56e22
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 12:14:56 2012 -0600
+
+ Updated NEWS for PR #36
+
+ NEWS | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+commit e4d7ad2643ac4e5391ae3939d3e19b6b0a05830f
+Merge: ec3e95a ba61dde
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Mar 20 09:02:55 2012 -0700
+
+ Merge pull request #43 from jlopex/master
+
+ Fixes issue LIBZMQ-332
+
+commit ba61dde6730aa79f05450a8b56b22dbf528eb57c
+Author: Javier Lopez <jlopex@cozybit.com>
+Date: Mon Mar 19 19:13:56 2012 -0700
+
+ Fixes zeromq 2.1 not compiling on Android
+
+ According to the libc documentation S_IWRITE is only for BSD
+ compatibility:
+
+ http://www.gnu.org/s/hello/manual/libc/Permission-Bits.html
+
+ This patch adds a check to determine the target platform and
+ use correct file access definition in each case:
+
+ - For Linux and Android S_IWUSR is used.
+ - For other platforms S_IWRITE is used.
+
+ Signed-off-by: Javier Lopez <jlopex@cozybit.com>
+
+ src/options.cpp | 10 +++++++---
+ 1 files changed, 7 insertions(+), 3 deletions(-)
+
+commit 4b8ace2e68b2a50caad1b6204335aa00720c1c8e
+Author: Yi Ding <yi.s.ding@gmail.com>
+Date: Sun Feb 19 15:13:27 2012 -0600
+
+ Add algorithm include for std::swap
+
+ include/zmq.hpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit ec3e95a67e9fba9542e45aeadd5bd9fc22ea6dfa
+Merge: 71dc626 dbf1db2
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 10:16:29 2012 -0800
+
+ Merge pull request #40 from gitfoxi/master
+
+ Backport some build fixes for old-ass Linux from libzmq development.
+
+commit 71dc626e82100e9be7a61d92f1f9e51aa50fa40c
+Merge: 80b2764 ec070c5
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 10:15:37 2012 -0800
+
+ Merge pull request #38 from jtzl/master
+
+ updated INSTALL documentation as per pull request #37
+
+commit 80b27649bc1d00fde72b98d79d9f407dfee0c30a
+Merge: e23eb9d 5361000
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 10:13:26 2012 -0800
+
+ Merge pull request #36 from gimaker/trie-pruning
+
+ Backport fix to prune the trie from zmq3 (LIBZMQ-305)
+
+commit e23eb9dd2a66104f54ed8517aee56161d0382061
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 12:10:34 2012 -0600
+
+ Updated NEWS for PR #39
+
+ NEWS | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit de1c5fd75d28af7fc9b849f5c79c89c2ccc9fbb3
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Dec 18 19:23:54 2011 -0600
+
+ Prepared for 2.1.12
+
+ NEWS | 7 +++++++
+ include/zmq.h | 2 +-
+ 2 files changed, 8 insertions(+), 1 deletions(-)
+
+commit 8123b18284b1dadf4a72b7d6e644471539239282
+Merge: 9bea035 2b148ac
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Feb 16 10:09:10 2012 -0800
+
+ Merge pull request #39 from vortechs2000/issue-301
+
+ Fix builds on HP-UX 11iv3 when using either gcc or aCC
+
+commit 9bea035b96d90fbfeefe248453697c9aaf68594e
+Merge: 73f167e 1bff796
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Feb 14 09:10:39 2012 -0800
+
+ Merge pull request #41 from thesamet/master
+
+ Prevent unused variable warning in presence of assertions.
+
+commit 1bff796edb408aafcc9096849fd41209afa20d66
+Author: Nadav Samet <thesamet@gmail.com>
+Date: Mon Feb 13 22:09:13 2012 -0800
+
+ Prevent unused variable warning in presence of assertions.
+
+ include/zmq.hpp | 12 ++++++++++--
+ 1 files changed, 10 insertions(+), 2 deletions(-)
+
+commit dbf1db2253cac6cf06488e2739068be135983682
+Author: m <415fox@gmail.com>
+Date: Sat Jan 28 13:30:52 2012 -0800
+
+ Backport ./configure --with-poller from libzmq development.
+
+ If you've been configuring the poller using:
+ CPPFLAGS=-DZMQ_FORCE_POLL ./configure
+
+ Now you're going to want to say:
+ ./configure --with-poller=poll
+
+ acinclude.m4 | 190 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ configure.in | 5 +-
+ 2 files changed, 194 insertions(+), 1 deletions(-)
+
+commit 34da56118ee70ce594662960cdac90ca55f87ed0
+Author: 415fox@gmail.com <415fox@gmail.com>
+Date: Sat Jan 28 12:37:56 2012 -0800
+
+ Fix: Whitespace and comment.
+
+ src/clock.cpp | 20 ++++++++++----------
+ 1 files changed, 10 insertions(+), 10 deletions(-)
+
+commit 4a90c1027731ccad41cf44294c92f1ad1c8eb7ba
+Author: 415fox@gmail.com <415fox@gmail.com>
+Date: Fri Jan 27 12:40:56 2012 -0800
+
+ Fix: runtime patch for when system has clock_gettime but does not support CLOCK_MONOTONIC.
+
+ src/clock.cpp | 11 ++++++++++-
+ 1 files changed, 10 insertions(+), 1 deletions(-)
+
+commit 9631d910082fa302c3f3d45fbac189139747b933
+Author: 415fox@gmail.com <415fox@gmail.com>
+Date: Sat Jan 28 12:24:14 2012 -0800
+
+ Source char_traits<unsigned char> from GCC C++ Library directly to clarify license.
+
+ http://gcc.gnu.org/onlinedocs/libstdc++/
+ Previously borrowed code from id3lib was considered shady.
+ Placed in its own file for style reasons.
+
+ src/blob.hpp | 96 +---------------------------------
+ src/gcc_421_char_traits.hpp | 119 +++++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 122 insertions(+), 93 deletions(-)
+
+commit 1050ffe01a159dd4fdf0880932b55439c8dad36f
+Author: 415fox@gmail.com <415fox@gmail.com>
+Date: Fri Jan 27 12:24:14 2012 -0800
+
+ Fix basic_string<unsigned char> not implemented in stdc++ 3
+
+ src/blob.hpp | 94 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 files changed, 94 insertions(+), 0 deletions(-)
+
+commit 7a55220be42c7e0ead23a29e26caddac76110577
+Author: 415fox@gmail.com <415fox@gmail.com>
+Date: Fri Jan 27 12:23:32 2012 -0800
+
+ Fix bad combination of gcc3, -Werror and private destructor.
+
+ src/ctx.hpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 536100053cd3bb28d9d8be33b2e48a60d3d225ee
+Author: Staffan Gimåker <staffan@spotify.com>
+Date: Thu Jan 26 14:18:03 2012 +0100
+
+ Fix segfault bug when pruning the trie.
+
+ Signed-off-by: Staffan Gimåker <staffan@spotify.com>
+
+ src/trie.cpp | 9 +++++++--
+ 1 files changed, 7 insertions(+), 2 deletions(-)
+
+commit 2b148acd46db833b8c2b880622d0f77bb5e1d89c
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Tue Jan 17 11:20:32 2012 -0600
+
+ Patch from Mikko Koppanen for #LIBZMQ-301
+
+ Add the '-Ae' flag when using aCC
+
+ Check if CLOCK_MONOTONIC defined before using it - if not, use gethrtime()
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ configure.in | 2 ++
+ src/clock.cpp | 8 ++++++--
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+commit ec070c59343d2991f1bbeb3613c4ae88a55c580f
+Author: Jtzl Forshizl <jtg@intarcorp.com>
+Date: Tue Jan 17 14:07:51 2012 -0500
+
+ clarifying installation documentation for users building from repo
+
+ INSTALL | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+commit e954cb49732facaa627dff617d214a5b5cab90e5
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Tue Jan 17 10:33:55 2012 -0600
+
+ Change peer_identity_size (in all cases) in the command_t structure to be a size_t instead of an unsigned char.
+
+ The peer_identity_size field in the attach and bind substructure is
+ used to generate a C++ base_string object from an unsigned char *, and
+ that object expects a size_t, not an unsigned char. If an unsigned
+ char is used, the HPUX aCC compiler gets confused and can't figure out
+ which constructor to use.
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ src/command.hpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 75bc614d55a36f76cfdadbf44b094cbd132b11dd
+Author: Staffan Gimåker <staffan@spotify.com>
+Date: Wed Jan 4 11:31:32 2012 +0100
+
+ Backport fix to prune the trie from zmq3.
+
+ Signed-off-by: Staffan Gimåker <staffan@spotify.com>
+
+ src/trie.cpp | 24 ++++++++++++++++++++++--
+ src/trie.hpp | 3 +++
+ 2 files changed, 25 insertions(+), 2 deletions(-)
+
commit 73f167eeb5ce9d26678399a574918f9813976024
Author: Pieter Hintjens <ph@imatix.com>
Date: Sun Dec 18 19:11:17 2011 -0600