summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog553
1 files changed, 553 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index ee15982..9161480 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,558 @@
# Generated by Makefile. Do not edit.
+commit 73f167eeb5ce9d26678399a574918f9813976024
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Dec 18 19:11:17 2011 -0600
+
+ Updated NEWS for 2.1.11
+
+ NEWS | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 1e49dda4da68c92b410c93065a9dac908bef4cf6
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Dec 6 14:21:17 2011 +0100
+
+ Updated NEWS for issue 290
+
+ NEWS | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 354faeb8360c434600b6c5e34dc1c249991bc014
+Merge: 04b2ef2 1f1b454
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Dec 5 08:18:28 2011 -0800
+
+ Merge pull request #35 from mika-fischer/libzmq-290
+
+ Use monotonic clock for clock_t
+
+commit 1f1b4543750d9ec882cc83c3e0f49b568c57bbf5
+Author: Mika Fischer <mika.fischer@zoopnet.de>
+Date: Fri Dec 2 09:43:44 2011 +0100
+
+ Use monotonic clock for clock_t
+
+ This makes clock_t insensitive to the system clock being reset by NTP or
+ the sysadmin, which could previously cause long hangs for instance in
+ zmq_poll.
+
+ configure.in | 4 ++--
+ src/clock.cpp | 12 ++++++++++++
+ 2 files changed, 14 insertions(+), 2 deletions(-)
+
+commit 04b2ef208d9fc9bea382fcfb2d0eb3efa36d5f9f
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Nov 30 17:14:18 2011 -0600
+
+ Reverted commit 1fb107, which was causing memory violations
+
+ NEWS | 2 +-
+ src/xrep.cpp | 9 +++++----
+ 2 files changed, 6 insertions(+), 5 deletions(-)
+
+commit 0919e99c394c426685e74154fea06ed04b50d5ba
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Nov 30 14:01:43 2011 -0600
+
+ Wasn't compiling... what happened to xrep.cpp?
+
+ src/xrep.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit d6cd256584f65764795d82aac0f7850a9cd920de
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Nov 30 14:01:22 2011 -0600
+
+ Fixed issue 254
+
+ NEWS | 2 ++
+ src/tcp_socket.cpp | 16 +++++++++++-----
+ 2 files changed, 13 insertions(+), 5 deletions(-)
+
+commit 4212c4b6dd11971c3dc9f6b2426f787939cc0c04
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Nov 27 09:11:15 2011 -0600
+
+ Revert "Fixes duplicated variable error"
+
+ This reverts commit 26da87062080a9247401efd1a85f747c59365db1.
+
+ src/xrep.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 35df57cda6861cac31710ad2a10fae4c97c0e63c
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Nov 21 08:11:33 2011 +0100
+
+ Phillip Kovacs added to the AUTHORS file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 1fb107166f67091c4e1e20a0e511e78e4bf13c7b
+Merge: d3a1ba6 26da870
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Nov 19 15:52:02 2011 -0800
+
+ Merge pull request #28 from gsandoval/master
+
+ Fixes memory leak in XREP xsend
+
+commit d3a1ba6ae4a0e3939fb9e48935ac341504cd513d
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Nov 19 17:50:59 2011 -0600
+
+ Added Botond Ballo to authors
+
+ AUTHORS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 9861b49161aba728151e06bcd50c0ec7bb11121c
+Merge: ad47cc5 0ceb637
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Nov 19 15:48:53 2011 -0800
+
+ Merge pull request #33 from botond-ballo/master
+
+ C++11 move constructor and move assignment operator for zmq::socket_t and zmq::context_t
+
+commit 0ceb637b379c65b49d0a5b572e2b0715fcfb3531
+Author: Botond Ballo <botond.ballo@gmail.com>
+Date: Sat Nov 19 18:00:25 2011 -0500
+
+ Fixed indentation of preprocessor directives
+
+ Fixed indentation of preprocessor directives to it's consistent with
+ other headers.
+ Signed-off-by: Botond Ballo <botond.ballo@gmail.com>
+
+ include/zmq.hpp | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+commit 573614acf14936772fbc4edee5b2c791a8ab4283
+Author: Botond Ballo <botond.ballo@gmail.com>
+Date: Sat Nov 19 17:57:00 2011 -0500
+
+ Fixed indentation of preprocessor directives.
+
+ Fixed indentation of preprocessor directives to make it consistent with
+ other headers.
+
+ Signed-off-by: Botond Ballo <botond.ballo@gmail.com>
+
+ include/zmq.hpp | 10 +++++-----
+ 1 files changed, 5 insertions(+), 5 deletions(-)
+
+commit 315e563eddc856cdeb062b07c780a476aca954e5
+Author: Botond Ballo <botond.ballo@gmail.com>
+Date: Sat Nov 19 17:44:17 2011 -0500
+
+ C++11 move constructor/assignment operator for socket_t and context_t
+
+ Added a C++11 move constructor and move assignment operator to zmq::socket_t
+ and zmq::context_t. These functions are only enabled if the compiler supports
+ C++11 rvalue references. Currently the code can detect rvalue reference
+ support for the following compilers: GCC, MSVC, clang.
+
+ Signed-off-by: Botond Ballo <botond.ballo@gmail.com>
+
+ include/zmq.hpp | 39 +++++++++++++++++++++++++++++++++++++++
+ 1 files changed, 39 insertions(+), 0 deletions(-)
+
+commit ad47cc55cf39660ce533e7921fe259d32d4c4a49
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sat Nov 19 10:06:06 2011 +0100
+
+ Stuart Webster added to the AUTHORS file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit bed61c78946e5719bfbd1477ded6c577fe811163
+Author: Stuart Webster <sw_webster@hotmail.com>
+Date: Sat Nov 19 10:02:23 2011 +0100
+
+ Line-ending conversion rules for hg-git users and enabled use of .gitignore by hg-git users
+
+ Mercurial does not have built-in support for converting line-endings. This is a
+ settings file for hg eol (http://mercurial.selenic.com/wiki/EolExtension), an
+ extension that replicates the behaviour of git with core.autocrlf=true.
+
+ Mercurial uses Python regex syntax by default in its .hgignore files. Adding
+ this line to .gitignore overrides that setting, so hg-git users can just create
+ a hardlink to it (e.g "mklink /H .hgignore .gitignore" on Windows) to use it.
+
+ Signed-off-by: Stuart Webster <sw_webster@hotmail.com>
+
+ .gitignore | 1 +
+ .hgeol | 2 ++
+ 2 files changed, 3 insertions(+), 0 deletions(-)
+
+commit a247c7d422c86cd78ef6f5b8dad8fbfd9a00aeea
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Nov 17 11:20:21 2011 -0600
+
+ Updated NEWS for issue 281
+
+ NEWS | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 561a9d2d8022d76166e1de981543337a783f6076
+Merge: 69bc977 c4dabba
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Nov 17 09:16:43 2011 -0800
+
+ Merge pull request #32 from mika-fischer/libzmq-281
+
+ Work around for LIBZMQ-281
+
+commit c4dabba55f71d2648d9196cd5ef3b2c7238ab254
+Author: Mika Fischer <mika.fischer@zoopnet.de>
+Date: Thu Nov 17 13:33:55 2011 +0100
+
+ Work around for LIBZMQ-281
+
+ The problem is that other threads might still be in mailbox::send() when
+ it is destroyed. So as a workaround, we just acquire the mutex in the
+ destructor. Therefore the running send will finish before the mailbox is
+ destroyed.
+
+ Signed-off-by: Mika Fischer <mika.fischer@zoopnet.de>
+
+ src/mailbox.cpp | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+commit 69bc97726e0ec0ffb509eaf4f50e86616544677f
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Nov 16 11:42:08 2011 -0600
+
+ Fixed erroneous ifdef -- backport 83975c1
+
+ src/ip.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 5819d702ff48af12d02276cb79eef0c2068d0dc3
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Nov 5 20:34:28 2011 +0100
+
+ Added AJ Lewis to AUTHORS
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 4c7e6d6156d1225f00701ba460c062524e5a474d
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Nov 4 21:09:47 2011 +0100
+
+ Updated NEWS
+
+ NEWS | 6 +++++-
+ 1 files changed, 5 insertions(+), 1 deletions(-)
+
+commit 533a94ba0741e54de832140bdffff53d944441c9
+Merge: 6e5a3e9 1afd7a0
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Nov 4 12:59:40 2011 -0700
+
+ Merge pull request #30 from vortechs2000/master
+
+ Get zeromq compiling on AIX 6.1
+
+commit 1afd7a088400b39fd3309ff996ffbf9e567463ff
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Thu Nov 3 12:10:35 2011 -0500
+
+ Combine the existing freebsd/netbsd section with the new HP-UX DCE section
+
+ Using a couple #ifdefs, we can combine the freebsd/netbsd uuid section with
+ the HP-UX DEC section in uuid.cpp.
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ src/uuid.cpp | 39 +++++++++++----------------------------
+ 1 files changed, 11 insertions(+), 28 deletions(-)
+
+commit 357a6e9f05110e241a1682f841b886b88e442263
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Thu Nov 3 11:57:52 2011 -0500
+
+ Implement DCE uuid calls properly
+
+ Create HPUX & LIBDCEKT specific sections similar to BSD section. It's
+ possible that these could be merged, but I'm not sure if it would be
+ as readable because there are some type differences that might make
+ things difficult.
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ src/uuid.cpp | 37 +++++++++++++++++++++++++------------
+ src/uuid.hpp | 5 +++++
+ 2 files changed, 30 insertions(+), 12 deletions(-)
+
+commit 857c7f91d1e3c5c82408b9d932e117145678b814
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Thu Nov 3 11:37:41 2011 -0500
+
+ Use DCE library on HP-UX to handle UUID generation
+
+ This is the initial dumb implementation - it just replaces RAND_bytes
+ in the final uuid case rather than handling uuid_create() as done in
+ the BSD case.
+
+ It passes the self tests, but it's probably not the correct way to do
+ it.
+
+ You can also use the openssl method my using the '--without-dce' flag
+ to configure.
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ configure.in | 9 ++++++++-
+ src/uuid.cpp | 12 ++++++++++++
+ 2 files changed, 20 insertions(+), 1 deletions(-)
+
+commit e5742c20cb076a1867ca7d42668ac1a53aab6b58
+Merge: f32cf6d 6e5a3e9
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Thu Nov 3 11:35:22 2011 -0500
+
+ Merge remote-tracking branch 'upstream/master'
+
+commit 6e5a3e9358373d28123d3b19e91f5a6ff7486073
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Oct 28 05:43:35 2011 +0900
+
+ Updated NEWS
+
+ NEWS | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 4cf638a2502a6d344c9e25ef5252b2d45613f7de
+Author: Bernd Prager <bernd@prager.ws>
+Date: Thu Oct 27 17:11:28 2011 +0200
+
+ Missing bracket added
+
+ Signed-off: Martin Sustrik <sustrik@250bpm.com>
+
+ src/zmq.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 8c502692dad0a29e0b98e895b3b04f3d783b5b42
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Oct 28 05:38:05 2011 +0900
+
+ Updated NEWS
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit b75c06c34f991d96a3b21d48b74efc029df7c800
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Thu Oct 27 11:51:23 2011 +0200
+
+ Paul Betts added to the AUTHORS file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ Conflicts:
+
+ AUTHORS
+
+ AUTHORS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 19c865d3d7d6a4157205b4036e95e45955459a0b
+Author: Paul Betts <paul@paulbetts.org>
+Date: Thu Oct 27 11:48:58 2011 +0200
+
+ Enable exceptions raising on assert on Win32
+
+ This patch changes the Win32 version to call RaiseException instead of abort
+ (which eventually calls TerminateProcess). This allows crash dumps to be sent
+ correctly instead of the process disappearing.
+
+ Signed-off-by: Paul Betts <paul@paulbetts.org>
+
+ src/err.cpp | 13 +++++++++++++
+ src/err.hpp | 26 ++++++++++++++------------
+ 2 files changed, 27 insertions(+), 12 deletions(-)
+
+commit b40d7c18ad1a3210a49da088b65060f784d17009
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Oct 28 05:33:13 2011 +0900
+
+ Updated NEWS for issue 261
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 99e7b6a44ee81d1807a5c8a577eea366e4d7275f
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Thu Oct 27 09:41:48 2011 +0200
+
+ Bug in kqueue poller fixed (issue 261)
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/kqueue.cpp | 25 +++++++++++++++++--------
+ 1 files changed, 17 insertions(+), 8 deletions(-)
+
+commit b2974da2ba800d2c2b5eb76e1123e95ec63fedf4
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Oct 28 05:32:02 2011 +0900
+
+ Revert "Applied workaround for issue 261"
+
+ This reverts commit ddc75f9e54f1fc95a057e935c51c0c22e53df6e7.
+
+ NEWS | 7 +++----
+ src/kqueue.cpp | 4 +---
+ 2 files changed, 4 insertions(+), 7 deletions(-)
+
+commit 686f9f53641899d2e4863526aa52fe47c6fb6bc0
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Thu Oct 27 20:37:06 2011 +0100
+
+ Fix issue LIBZMQ-273
+
+ NEWS | 3 +++
+ acinclude.m4 | 22 ++++++++++++++++++++++
+ configure.in | 5 +++++
+ src/ip.cpp | 4 ++--
+ 4 files changed, 32 insertions(+), 2 deletions(-)
+
+commit f32cf6d4991bf7a334fa8350157d51fb5469ed50
+Author: AJ Lewis <aj.lewis@quantum.com>
+Date: Thu Oct 27 08:42:11 2011 -0500
+
+ Get zeromq compiling on AIX 6.1
+
+ Includes platform.hpp in device.cpp and then adds the same check for
+ platforms found in zmq.cpp to include poll.h. Without this, device.cpp
+ fails to compile with:
+ device.cpp: In function 'int zmq::device(zmq::socket_base_t*, zmq::socket_base_t*)':
+ device.cpp:46: error: 'struct zmq_pollitem_t' has no member named 'reqevents'
+ device.cpp:47: error: 'struct zmq_pollitem_t' has no member named 'rtnevents'
+ device.cpp:50: error: 'struct zmq_pollitem_t' has no member named 'reqevents'
+ device.cpp:51: error: 'struct zmq_pollitem_t' has no member named 'rtnevents'
+ device.cpp:67: error: 'struct zmq_pollitem_t' has no member named 'rtnevents'
+ device.cpp:92: error: 'struct zmq_pollitem_t' has no member named 'rtnevents'
+ gmake[1]: *** [libzmq_la-device.lo] Error 1
+
+ Signed-off-by: AJ Lewis <aj.lewis@quantum.com>
+
+ src/device.cpp | 14 ++++++++++++++
+ 1 files changed, 14 insertions(+), 0 deletions(-)
+
+commit 26da87062080a9247401efd1a85f747c59365db1
+Author: Guillermo Sandoval <gsandoval@darchitect.org>
+Date: Mon Oct 24 16:14:43 2011 -0500
+
+ Fixes duplicated variable error
+
+ src/xrep.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 826d61244360d703f38cfc59ee643a177fb8b65e
+Author: Guillermo Sandoval <gsandoval@darchitect.org>
+Date: Mon Oct 24 16:10:12 2011 -0500
+
+ Calls zmq_msg_close regardless of the message is send or not. So it fixes memory leak in XREP
+
+ src/xrep.cpp | 3 ---
+ 1 files changed, 0 insertions(+), 3 deletions(-)
+
+commit daac034503589ed7dabe77fdecb5f1a360ced638
+Merge: db69361 c3af879
+Author: Guillermo Sandoval <gsandoval@darchitect.org>
+Date: Mon Oct 24 16:08:33 2011 -0500
+
+ Merge branch 'master' of github.com:gsandoval/zeromq2-1
+
+commit db69361650acb476269623e01b6f548a549365fa
+Author: Guillermo Sandoval <gsandoval@darchitect.org>
+Date: Mon Oct 24 15:14:08 2011 -0500
+
+ Fixes memory leak in XREP sockets, occurring when the message was successfully sent.
+
+ src/xrep.cpp | 6 ++----
+ 1 files changed, 2 insertions(+), 4 deletions(-)
+
+commit c3af87950559ce87c5f5798ec4c950a6ea5e7e55
+Author: Guillermo Sandoval <gsandoval@darchitect.org>
+Date: Mon Oct 24 15:14:08 2011 -0500
+
+ Fixes memory leak in XREP sockets, occurring when the message was successfully sent.
+
+ src/xrep.cpp | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 808c3b9ff6756566d7da3a8f2ae5f626d9fd1b13
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Oct 12 06:52:31 2011 -0500
+
+ Updated NEWS for issue 269
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 5f248ef1a63f36e0932db122b73e7f4ce4cf7cd0
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Oct 12 05:51:39 2011 -0500
+
+ Revert "Added diagnostics for issue 254"
+
+ This reverts commit 80b0041ea1685ed49c222d237b4c9c49bd495b64.
+
+ src/tcp_socket.cpp | 10 ++--------
+ 1 files changed, 2 insertions(+), 8 deletions(-)
+
+commit 3014e0f87129695c5230ffbc5b68cdf007878de2
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Oct 5 15:50:35 2011 +0200
+
+ Clarified doc to say 'round-robined' instead of 'load-balanced'
+
+ doc/zmq_socket.txt | 14 +++++++-------
+ 1 files changed, 7 insertions(+), 7 deletions(-)
+
+commit b71462bf750cf00210669921e32fdd2f85d40eb8
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Oct 5 14:34:35 2011 +0200
+
+ Updated NEWS for OpenPGM updated
+
+ NEWS | 12 ++++++++++++
+ 1 files changed, 12 insertions(+), 0 deletions(-)
+
+commit 77c8c7f11865b1e1b8c4e11cb5ef6297bc6b774e
+Author: Steven McCoy <steven.mccoy@miru.hk>
+Date: Tue Oct 4 09:39:55 2011 +0200
+
+ New upstream OpenPGM maintenance release 5.1.118.
+
+ Signed-off-by: Steven McCoy <steven.mccoy@miru.hk>
+
+ configure.in | 2 +-
+ foreign/openpgm/libpgm-5.1.115~dfsg.tar.gz | Bin 1054630 -> 0 bytes
+ foreign/openpgm/libpgm-5.1.118~dfsg.tar.gz | Bin 0 -> 1046589 bytes
+ 3 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 0bbc1755387b743aaa086bdc268bcb65fab90af3
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Oct 3 07:42:08 2011 -0500
+
+ Updated version to 2.1.11
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
commit ab64a395a01293453da606f08e0983ae8bbeb210
Author: Pieter Hintjens <ph@imatix.com>
Date: Mon Oct 3 07:24:15 2011 -0500