summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog663
1 files changed, 663 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index f15734e..2349d55 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,649 @@
# Generated by Makefile. Do not edit.
+commit 392c3771c22d0dfe793cc9c4ee5c27d18d38d428
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Aug 29 20:25:11 2011 +0200
+
+ Updated NEWS for 2.1.9
+
+ NEWS | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit bb7f41144b513ebf07698ade91c6d6c4e20bec77
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Aug 29 12:24:45 2011 +0200
+
+ Fixed NEWS to reflect RC status of 2.1.8
+
+ NEWS | 7 +++++--
+ 1 files changed, 5 insertions(+), 2 deletions(-)
+
+commit 4df43be69c3f25a4a5f96d379a59d6c6d6f214fa
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Wed Aug 17 18:41:02 2011 +0200
+
+ Fix the PGM support on win64
+
+ On win64 the size of file descriptor is not the same as size of int.
+ The bug in PGM transport caused a runtime error because of this.
+ The problem is fixed now.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ NEWS | 2 ++
+ src/pgm_receiver.cpp | 4 ++--
+ src/pgm_sender.cpp | 8 ++++----
+ src/pgm_socket.cpp | 8 ++++----
+ src/pgm_socket.hpp | 7 ++++---
+ 5 files changed, 16 insertions(+), 13 deletions(-)
+
+commit 024c4c91098913c7488abde75e9ef0d3fee7e195
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Aug 17 16:40:09 2011 +0200
+
+ Fixed compile error on win32
+
+ src/zmq.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 323138b81ca71e036200d666b95b96c9b6e58696
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Aug 16 17:45:39 2011 +0200
+
+ Updated NEWS for Android build
+
+ NEWS | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 7b22dccf2fed4cd057876912991fdd61954d6dbc
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Mon Aug 15 19:09:04 2011 +0200
+
+ Added Android support
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ configure.in | 6 ++++++
+ src/ip.cpp | 2 +-
+ src/swap.cpp | 2 +-
+ src/thread.cpp | 2 +-
+ 4 files changed, 9 insertions(+), 3 deletions(-)
+
+commit 591e5887e6e32675a7520eac67621416f13bec35
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sun Aug 14 14:23:16 2011 +0200
+
+ Fixed issue 238
+
+ NEWS | 5 ++++-
+ 1 files changed, 4 insertions(+), 1 deletions(-)
+
+commit ebfdfdf298525c993b8827fe6c7b6f753c56ca52
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sun Aug 14 14:23:16 2011 +0200
+
+ select version zmq_poll reports invalid FDs
+
+ Till now, passing invalid file descriptor to zmq_poll()
+ caused asseration. Now it returns error.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/zmq.cpp | 18 +++++++++++++-----
+ 1 files changed, 13 insertions(+), 5 deletions(-)
+
+commit d6fbb80a19056cad02ee32e465b12cb0ba29c419
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Aug 13 00:27:13 2011 +0200
+
+ Fixed issue 239
+
+ NEWS | 3 +++
+ src/swap.cpp | 2 --
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+commit 317435e2835b41d98a885883631d024422f5c9ff
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Aug 11 16:54:50 2011 +0200
+
+ usleep is void on Android
+
+ src/zmq.cpp | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+commit 7239640d0282902af047d391b4a41fb5cc914bd1
+Author: wroberts <wroberts@wroberts-P480.(none)>
+Date: Wed Aug 10 13:23:37 2011 -0400
+
+ Added an ndk-build clean command to clean script and fixed usleep error.
+
+ - Fixed incorrect directory removal in clean script
+
+ builds/android/clean.sh | 2 +-
+ src/zmq.cpp | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+commit eeca373616e347e947ff73f1cf8c11f7b53fc1a8
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Aug 10 18:18:15 2011 +0200
+
+ Updated NEWS for Android
+
+ NEWS | 11 ++++++++---
+ 1 files changed, 8 insertions(+), 3 deletions(-)
+
+commit 880e5c324031bc390bc88d07f5137ce31d1c8c69
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Aug 10 17:58:16 2011 +0200
+
+ Fixed use of ANDROID macro
+
+ src/thread.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 98b96e7d8fd60605ad1498cd540b07dd7040f168
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Aug 10 17:51:34 2011 +0200
+
+ Whitespace and comment changes
+
+ builds/android/build.sh | 35 ++++++++++++++++++++++-------------
+ builds/android/clean.sh | 15 ++++++++++-----
+ 2 files changed, 32 insertions(+), 18 deletions(-)
+
+commit f2b76414f70d462e7863e4d79f61227d7315cf9d
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Aug 10 17:13:40 2011 +0200
+
+ Added William Roberts to AUTHORS
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 7f2a522a85a2379120ad6d809be56b9f34e3b89b
+Author: wroberts <wroberts@wroberts-P480.(none)>
+Date: Tue Aug 9 19:24:11 2011 -0400
+
+ Finished with clean android build
+
+ builds/android/Android.mk | 6 ++----
+ builds/android/build.sh | 5 +++++
+ builds/android/clean.sh | 14 +++++++++++---
+ 3 files changed, 18 insertions(+), 7 deletions(-)
+
+commit 62a8d76aa32cc9579811f32d06cbc6ae0a00dbb2
+Author: wroberts <wroberts@wroberts-P480.(none)>
+Date: Tue Aug 9 18:47:59 2011 -0400
+
+ Android wip
+
+ builds/android/Android.mk | 42 ++
+ builds/android/Application.mk | 1 +
+ builds/android/build.sh | 38 ++
+ builds/android/clean.sh | 13 +
+ builds/android/include/platform.hpp | 1 +
+ builds/android/include/platform_android.hpp | 229 +++++++++
+ builds/android/uuid/clear.c | 43 ++
+ builds/android/uuid/compare.c | 55 +++
+ builds/android/uuid/copy.c | 45 ++
+ builds/android/uuid/gen_uuid.c | 680 +++++++++++++++++++++++++++
+ builds/android/uuid/gen_uuid_nt.c | 92 ++++
+ builds/android/uuid/isnull.c | 48 ++
+ builds/android/uuid/pack.c | 69 +++
+ builds/android/uuid/parse.c | 79 +++
+ builds/android/uuid/unpack.c | 63 +++
+ builds/android/uuid/unparse.c | 76 +++
+ builds/android/uuid/uuid.h | 103 ++++
+ builds/android/uuid/uuidP.h | 59 +++
+ builds/android/uuid/uuid_time.c | 171 +++++++
+ builds/android/uuid/uuidd.h | 54 +++
+ 20 files changed, 1961 insertions(+), 0 deletions(-)
+
+commit ad6bf4aa3e77d8aec72951ac88e0e916c6e63a0d
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Aug 9 20:48:04 2011 +0200
+
+ Provisional Android support, from Ghislain Putois
+
+ AUTHORS | 1 +
+ builds/android/Makefile | 10 ++++++++++
+ src/ip.cpp | 20 ++++++++++----------
+ src/swap.cpp | 6 +++---
+ src/thread.cpp | 10 ++++++----
+ 5 files changed, 30 insertions(+), 17 deletions(-)
+
+commit 9b2c16cb42fd559cfac1c86f420392a2e4cb7b2e
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Jul 30 17:26:42 2011 +0200
+
+ Fixed issue 236
+
+ NEWS | 11 +++++++++++
+ src/socket_base.cpp | 4 ++++
+ 2 files changed, 15 insertions(+), 0 deletions(-)
+
+commit b7d1b669ce9c3f27202b8daf46425766a877de3e
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 28 14:07:25 2011 +0200
+
+ Debian packaging wasn't distributed
+
+ NEWS | 6 ------
+ 1 files changed, 0 insertions(+), 6 deletions(-)
+
+commit 764c4f5a8fa2f21d0f755811ba8b4c38c24e7ae5
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 28 13:52:55 2011 +0200
+
+ Updated version number for next release
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 3c913026c72dd83e2d6ffbb6d9866a748502ffcf
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 28 13:44:40 2011 +0200
+
+ Updated NEWS for 2.1.8 release
+
+ NEWS | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 9d9fb596ab0eaa00da36f79b442d40fd42dfe4eb
+Merge: 3cb929e 59a84ab
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Jul 22 11:38:32 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 3cb929e46affd5ebf8c456acba594bae5c106cc8
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Thu Jul 21 23:35:26 2011 +0200
+
+ mailbox::recv correctly passes EINTR to the caller
+
+ This bug caused signal during blocking call to assert.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ NEWS | 3 +++
+ src/mailbox.cpp | 2 +-
+ 2 files changed, 4 insertions(+), 1 deletions(-)
+
+commit 59a84abbfbb3be79d8f765da95de23ebdac16630
+Merge: 5227717 1b9bc37
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Jul 20 16:40:12 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 1b9bc37ff76826069de846fe0c3220b78b357e72
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Jul 20 13:12:18 2011 +0200
+
+ Fixed build for MSVC
+
+ builds/msvc/libzmq/libzmq.vcproj | 4 ++++
+ src/signaler.cpp | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletions(-)
+
+commit d897a2b45b422ff87da6007b06c6147e535491dd
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Jul 19 23:08:02 2011 +0200
+
+ Fixed build for Windows (signaler.cpp)
+
+ src/signaler.cpp | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 8dd8c71dab33bfd903e05d238b2e8ec507c23c7e
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Jul 18 14:29:20 2011 +0200
+
+ Fixed email addresses in the MAITAINERS file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ MAINTAINERS | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+commit b69aee1b5e5aee9bdcab75aa1b5af88bfc7b0339
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Jul 18 13:39:51 2011 +0200
+
+ Avoid SIGPIPE errors on FreeBSD
+
+ MAINTAINERS | 8 ++++----
+ src/tcp_socket.cpp | 2 +-
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+commit 846769d809dea727bb6aeb58155aeb9afb357bce
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Jul 18 09:41:26 2011 +0200
+
+ Signaler timeout bug on Windows fixed
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/signaler.cpp | 12 ++++++++----
+ 1 files changed, 8 insertions(+), 4 deletions(-)
+
+commit b613c297897cfca15024d493e181f4f1973b1abe
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Jul 18 11:53:58 2011 +0200
+
+ Avoid SIGPIPE errors on FreeBSD
+
+ src/tcp_socket.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 5227717f9b8ccb8cf89967f470e017884edbd10f
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Jul 15 13:43:20 2011 +0200
+
+ ROUTER can talk to ZMQ_REP, DEALER to ZMQ_REQ
+
+ doc/zmq_socket.txt | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+commit e496d49f57d6b3a377c11b6d5a58f175200ddbde
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Jul 15 07:08:00 2011 +0200
+
+ Updated NEWS for issue 230
+
+ NEWS | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 5fd65d8f62e4c6e70b23a3e8f0195526b03a2e4f
+Merge: a8c9eed 61233d0
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri Jul 15 07:06:42 2011 +0200
+
+ Merge branch 'issue230'
+
+commit a8c9eedc031ef68d01b5515ff1108bb7f5ada3ac
+Merge: d17cae2 2c89920
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 14 23:29:15 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit d17cae20c5365fe2695b5e9027d8b91916eb9174
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 14 22:32:45 2011 +0200
+
+ Backported fix for issue 231
+
+ NEWS | 4 +
+ src/Makefile.am | 2 +
+ src/config.hpp | 7 +
+ src/ctx.cpp | 2 +-
+ src/io_thread.cpp | 2 +-
+ src/mailbox.cpp | 366 ++++------------------------------------
+ src/mailbox.hpp | 26 ++-
+ src/reaper.cpp | 2 +-
+ src/signaler.cpp | 340 +++++++++++++++++++++++++++++++++++++
+ src/signaler.hpp | 63 +++++++
+ src/socket_base.cpp | 75 ++++++---
+ src/socket_base.hpp | 6 +-
+ tests/test_shutdown_stress.cpp | 2 +-
+ 13 files changed, 529 insertions(+), 368 deletions(-)
+
+commit 2c899206691f528aa21ed52a4eb52ea7d59436cd
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 14 22:32:45 2011 +0200
+
+ Backported fix for issue 231
+
+ src/Makefile.am | 2 +
+ src/config.hpp | 7 +
+ src/ctx.cpp | 2 +-
+ src/io_thread.cpp | 2 +-
+ src/mailbox.cpp | 366 ++++------------------------------------
+ src/mailbox.hpp | 26 ++-
+ src/reaper.cpp | 2 +-
+ src/signaler.cpp | 340 +++++++++++++++++++++++++++++++++++++
+ src/signaler.hpp | 63 +++++++
+ src/socket_base.cpp | 75 ++++++---
+ src/socket_base.hpp | 6 +-
+ tests/test_shutdown_stress.cpp | 2 +-
+ 12 files changed, 525 insertions(+), 368 deletions(-)
+
+commit 61233d00877dfb0322bb1a1fd3d7916a1e779d9b
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jul 14 22:09:45 2011 +0200
+
+ Fixed issue 230
+
+ src/tcp_socket.cpp | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+commit a5972520e9961eaf6f6948036c99dbfd03812c1e
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Jul 13 18:10:54 2011 +0200
+
+ Fixed issue 228, backported from 3.0
+
+ NEWS | 2 ++
+ src/rep.cpp | 2 +-
+ src/xrep.cpp | 4 ----
+ 3 files changed, 3 insertions(+), 5 deletions(-)
+
+commit 647dca9650d54637a0e763216825875d1ac915d1
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Jul 11 16:05:04 2011 +0200
+
+ zmq_bind(3) and zmq_connect(3) describe EINVAL error
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ doc/zmq_bind.txt | 2 ++
+ doc/zmq_connect.txt | 2 ++
+ 2 files changed, 4 insertions(+), 0 deletions(-)
+
+commit 89fc94cc7e3bb7f23c27dcc57877ec582f4af790
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Jul 12 15:47:01 2011 +0200
+
+ Updated NEWS
+
+ NEWS | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 994dbe48e74ddfa30a66c46430e878e60dfdd61e
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Jul 12 15:45:38 2011 +0200
+
+ Removed debian packaging, it's now at http://packages.debian.org/source/sid/zeromq
+
+ debian/README.Debian | 4 --
+ debian/changelog | 24 ----------
+ debian/compat | 1 -
+ debian/control | 76 --------------------------------
+ debian/copyright | 105 --------------------------------------------
+ debian/libzmq-dev.install | 5 --
+ debian/libzmq-dev.manpages | 2 -
+ debian/libzmq0.install | 1 -
+ debian/libzmq0.manpages | 5 --
+ debian/rules | 92 --------------------------------------
+ debian/source/format | 1 -
+ debian/source/options | 1 -
+ debian/zeromq-bin.install | 3 -
+ debian/zeromq-bin.manpages | 3 -
+ 14 files changed, 0 insertions(+), 323 deletions(-)
+
+commit d27374c8346cdde9b0e77fb625249df6d185c6e0
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Jul 4 09:27:50 2011 +0200
+
+ License text in autogen.sh fixed
+
+ autogen.sh incorrectly referred to the license as GPL.
+ Changed to LGPL.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ autogen.sh | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+commit c35a14beaba8d60e473f15d9978b075d33423a55
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Thu Jun 30 00:05:03 2011 +0200
+
+ Testing for errors from pthread_* functions fixed
+
+ pthread_* functions return the error number rather than
+ setting errno. This was not accounter for till now.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/thread.cpp | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+commit 257859d1175d361eb9064dc94d8ad80bed6eec58
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Tue Jun 28 10:22:27 2011 +0200
+
+ Packaging for MSVC build fixed
+
+ MSVC project files for inproc_lat and inproc_thr were not
+ packaged during make dist phase.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ builds/msvc/Makefile.am | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+commit a26c5bfe99dcc574e4899cc7472bffbc092511f5
+Author: Carl Clemens <carlclemens1@yahoo.com>
+Date: Sun Jun 26 16:19:45 2011 +0200
+
+ Typo in zmq_msg_size(3) fixed
+
+ Signed-off-by: Carl Clemens <carlclemens1@yahoo.com>
+
+ AUTHORS | 1 +
+ doc/zmq_msg_size.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletions(-)
+
+commit fa6b54fccc281ed5f7d2d7b4f60c8f5f3f019167
+Merge: 21ea666 2008917
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Jun 19 10:31:58 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 21ea66635f5bc202ca64299d9f70687d224d55fc
+Author: Steven McCoy <steven.mccoy@miru.hk>
+Date: Fri Jun 17 15:02:48 2011 -0400
+
+ Refactor Windows versioning and WinSock usage.
+
+ Signed-off-by: Steven McCoy <steven.mccoy@miru.hk>
+
+ include/zmq.h | 2 +-
+ src/ctx.cpp | 12 +++--
+ src/select.cpp | 9 ++--
+ src/windows.hpp | 152 +++++++++++++++++++++++++++++++++++++++++++++----------
+ 4 files changed, 138 insertions(+), 37 deletions(-)
+
+commit 20089170eabc1614d4b3e946ae9a363cfa8d3e47
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Tue Jun 14 09:58:18 2011 +0200
+
+ Fixed issue 223 - ENETUNREACH is a valid error from connect
+
+ This patch fixed the JIRA issue 223
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ NEWS | 4 ++++
+ src/tcp_connecter.cpp | 3 ++-
+ 2 files changed, 6 insertions(+), 1 deletions(-)
+
+commit 0a533915b4cb2d3910ee3f128e882376e340f87b
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Jun 13 11:45:06 2011 +0200
+
+ Revert "Fix scope on Windows includes."
+
+ This reverts commit c55e8b47b63ba69b7e240edd8270629f99a00b0d.
+
+ src/ctx.cpp | 8 ++------
+ src/select.cpp | 2 +-
+ src/select.hpp | 2 +-
+ src/windows.hpp | 5 +++--
+ 4 files changed, 7 insertions(+), 10 deletions(-)
+
+commit c55e8b47b63ba69b7e240edd8270629f99a00b0d
+Author: Steven McCoy <steven.mccoy@miru.hk>
+Date: Sun Jun 12 19:37:11 2011 +0200
+
+ Fix scope on Windows includes.
+
+ Fix windows.h included before winsock2.h.
+ Remove definition of _WINSOCKAPI_.
+
+ Signed-off-by: Steven McCoy <steven.mccoy@miru.hk>
+
+ src/ctx.cpp | 8 ++++++--
+ src/select.cpp | 2 +-
+ src/select.hpp | 2 +-
+ src/windows.hpp | 5 ++---
+ 4 files changed, 10 insertions(+), 7 deletions(-)
+
+commit 69bce48516554cb1f2ac5e52ebb59632ae967c48
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Jun 9 19:55:21 2011 +0200
+
+ Fixed NEWS for broken 2.1.6 release
+
+ NEWS | 42 ++++++++++++++++++++----------------------
+ 1 files changed, 20 insertions(+), 22 deletions(-)
+
+commit 71012227f8615b398f755a82f73a70c61ba4fc55
+Merge: 143b64b 47245e1
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu May 26 11:07:51 2011 -0700
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 2f6bc9ce9260a3234a1f1de5c63956b081695f40
+Merge: 6a8b691 47245e1
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon May 23 12:53:30 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 47245e189c81aa083824d732c238d64d5ea32fce
+Merge: dae5a6c f94a700
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon May 23 03:47:04 2011 -0700
+
+ Merge pull request #19 from grk/patch-1
+
+ Fix overflow of megabits on 32bit machines.
+
+commit 6a8b691a3117e8d925ee29392c6463568f37108c
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Fri May 20 17:22:42 2011 +0200
+
+ Prepared for 2.1.8
+
+ NEWS | 10 ++++++++++
+ include/zmq.h | 2 +-
+ 2 files changed, 11 insertions(+), 1 deletions(-)
+
+commit f94a700626d2d7fc48fce2f0400c764416483e88
+Author: Grzesiek Kolodziejczyk <gkolodziejczyk@gmail.com>
+Date: Thu May 12 03:46:08 2011 -0700
+
+ Fix overflow of megabits on 32bit machines.
+
+ perf/local_thr.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
commit c35f65a82f1dace3a0b9afc5185dc3efc35595b5
Author: Pieter Hintjens <ph@imatix.com>
Date: Thu May 12 12:07:51 2011 +0200
@@ -9,6 +653,13 @@ Date: Thu May 12 12:07:51 2011 +0200
NEWS | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
+commit 143b64bf5ccd59227135cf151a4dc3ed60384360
+Merge: 6bb9e7b dae5a6c
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue May 10 08:05:23 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
commit dae5a6cb9e589e2471558dc86c55202558e918c2
Author: Martin Sustrik <sustrik@250bpm.com>
Date: Sun May 8 09:03:49 2011 +0200
@@ -34,6 +685,18 @@ Date: Sat Apr 9 09:46:59 2011 +0200
include/zmq.h | 3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
+commit 6bb9e7b55db32090763c7f4a43bda8be24f29fd3
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat May 7 09:03:38 2011 +0200
+
+ Fixed spelling errors in man pages
+
+ doc/zmq_getsockopt.txt | 2 +-
+ doc/zmq_pgm.txt | 4 ++--
+ doc/zmq_setsockopt.txt | 2 +-
+ doc/zmq_tcp.txt | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
commit 52318cf705f9b0a73e88b8296d10291f7ba22a86
Merge: c42d156 141a001
Author: Pieter Hintjens <ph@imatix.com>