summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog472
1 files changed, 472 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 779b799..5a9a3e7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,477 @@
# Generated by Makefile. Do not edit.
+commit ee185e241ec2a3091b9200cd5615cfa4f66e7a07
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 26 19:45:25 2011 +0200
+
+ Set version number for 2.1.6
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit d23534614452c954e7f64052ef232fd176e8897c
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 26 19:44:36 2011 +0200
+
+ Fixed NEWS for 2.1.6
+
+ NEWS | 11 ++++++++++-
+ 1 files changed, 10 insertions(+), 1 deletions(-)
+
+commit ca24a1baa512751c54a89ab7eb5f815522d77b13
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 26 19:22:24 2011 +0200
+
+ Moved tests off 5555 (conflict with Eclipse)
+
+ Signed-off-by: Pieter Hintjens <ph@imatix.com>
+
+ tests/test_pair_tcp.cpp | 2 +-
+ tests/test_reqrep_tcp.cpp | 2 +-
+ tests/test_shutdown_stress.cpp | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+commit 6f653e39d7a0ade569bc7e78679930a11640de4e
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Fri Apr 22 07:51:24 2011 +0200
+
+ Assert during SUB socket termination fixed.
+
+ Fair queueing algorithm was checking whether the current pipe
+ is not closed in the middle of reading a multipart message.
+ However, this is OK when the socket is closing down.
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/fq.cpp | 7 +++----
+ 1 files changed, 3 insertions(+), 4 deletions(-)
+
+commit fa6541c34e9c9496ad3fe83758773965862e272d
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Tue Apr 26 10:01:56 2011 +0200
+
+ Ignore generated RHAT spec file
+
+ .gitignore | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit 32915f8cadc30a62524ff6fe1c70158934704117
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Wed Apr 20 21:55:48 2011 +0100
+
+ Backport spec file changes from upstream
+
+ Makefile.am | 1 -
+ builds/redhat/zeromq.spec | 139 ------------------------------------------
+ builds/redhat/zeromq.spec.in | 139 ++++++++++++++++++++++++++++++++++++++++++
+ configure.in | 3 +-
+ 4 files changed, 141 insertions(+), 141 deletions(-)
+
+commit 43307455e352769189d427f260c4b48a3a19f7ce
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 19:39:57 2011 +0200
+
+ Fixed bad commit of message validity checking
+
+ include/zmq.h | 2 +-
+ include/zmq.hpp | 2 +-
+ src/socket_base.cpp | 12 ++++++------
+ src/zmq.cpp | 40 +++++++++++++++++++++++++++++++---------
+ 4 files changed, 39 insertions(+), 17 deletions(-)
+
+commit 205533ac79e6634650c9b77c41ef934084a84619
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 16:17:56 2011 +0200
+
+ Updated for 2.1.6
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit a347a957ecf3dcbf300fd4513d8aad967a492395
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 16:12:15 2011 +0200
+
+ Fixed error in zmq_msg_t checking, reverted to 2.1.5
+
+ include/zmq.h | 2 +-
+ src/socket_base.cpp | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+commit bee9cd8aa40cf82bdb45b88e6d9fc9ef123c118e
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 12:39:21 2011 +0200
+
+ Updated for 2.1.6
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit fd089736bcaa196106f516b87b8e8b906ffa8f63
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 12:31:17 2011 +0200
+
+ Updated news for 2.1.5
+
+ NEWS | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+commit f5043dff3ec0c1ea4619c89de8186a6d54938d5d
+Merge: c27e9d1 8b13301
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Apr 20 12:29:28 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit c27e9d16ad964f3b4252df890a3ec56c1c8ff6d7
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Tue Apr 19 08:08:15 2011 +0200
+
+ Message validity is checked in the runtime
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ doc/zmq_msg_close.txt | 3 ++-
+ doc/zmq_msg_copy.txt | 3 ++-
+ doc/zmq_msg_move.txt | 3 ++-
+ doc/zmq_recv.txt | 2 ++
+ doc/zmq_send.txt | 2 ++
+ include/zmq.h | 1 +
+ src/req.cpp | 2 +-
+ src/socket_base.cpp | 14 ++++++++++++++
+ src/xrep.cpp | 2 +-
+ 9 files changed, 27 insertions(+), 5 deletions(-)
+
+commit 8b13301225b0ee34397af53a4c824a5bf05388ba
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Apr 18 09:11:45 2011 +0200
+
+ zmq_socket(3) describes the EMFILE error code
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ doc/zmq_socket.txt | 4 +++-
+ 1 files changed, 3 insertions(+), 1 deletions(-)
+
+commit 2b07aaad62cfa218fcbc2f586fce94c1f9fc7284
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Fri Apr 15 08:03:26 2011 +0200
+
+ zmq_send(3) manpage improved
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ doc/zmq_send.txt | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+commit 91bfeaf9b9ef1e0370fae31b14b4be3d8b02eff5
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Fri Apr 15 07:59:28 2011 +0200
+
+ Error handling for accept on Cygwin fixed
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/tcp_listener.cpp | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+commit 6ee55af86870e102cf9dab77e7ed217068c8c4d4
+Merge: 5a87743 1b55cf2
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Apr 7 22:56:19 2011 +0200
+
+ Merge branch 'master' of github.com:zeromq/zeromq2-1
+
+commit 5a8774373279ec9517b89ac21a945ca65fda20d2
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Thu Apr 7 22:56:09 2011 +0200
+
+ Reduced stress of shutdown tests
+
+ tests/test_shutdown_stress.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 1b55cf2705b04caa0fc8152e1684389d91e557f0
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Tue Apr 5 12:00:30 2011 +0100
+
+ Fix Win32 builds
+
+ src/tcp_socket.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 5fe4e9cea8af2c9d5f22d53b92ae202c03ce9c33
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Mon Apr 4 22:52:02 2011 +0200
+
+ Make pkg-config dependency conditional
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ autogen.sh | 6 ------
+ configure.in | 13 ++++++++-----
+ 2 files changed, 8 insertions(+), 11 deletions(-)
+
+commit 28cdcaa8f323e05f7ebb3873c62ed1fd7839136f
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Apr 4 13:12:46 2011 +0200
+
+ Another error handling issue on Win32 solved
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ perf/inproc_lat.cpp | 2 +-
+ perf/inproc_thr.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+commit 08066dcf6511faddf54ede3dd28bf14bf5f89201
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Apr 4 12:49:39 2011 +0200
+
+ Issue with error checking on Win32 platform fixed
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/thread.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 6f9cb01eab130589d9c97062847a293b7605d429
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Mon Apr 4 12:12:06 2011 +0200
+
+ Unreferenced variable removed
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ src/tcp_socket.cpp | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+commit 5436832fdfe12c51c869e2cd59722b2be21a5a2a
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Apr 4 10:50:51 2011 +0200
+
+ Fixed RPM source spec
+
+ builds/redhat/zeromq.spec | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit c493a44a2c1f2eb4e9e2aa37929b16170d849975
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Mon Apr 4 10:36:24 2011 +0200
+
+ Fixed bad packaging for zmq_device
+
+ builds/redhat/zeromq.spec | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 122b9a48247d12258710bde53d4298da03661a01
+Author: Robert G. Jakabosky <bobby@sharedrealm.com>
+Date: Sun Apr 3 20:44:02 2011 +0200
+
+ Add note about thread-safety to zmq_msg_init_data() manpage.
+
+ Signed-off-by: Robert G. Jakabosky <bobby@sharedrealm.com>
+
+ doc/zmq_msg_init_data.txt | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 2ec3fdeff4c9b0d825cc5f1192abf3362b0bf771
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Apr 3 14:28:07 2011 +0200
+
+ Backported inproc perf tests to 2.x api
+
+ perf/inproc_lat.cpp | 16 ++++++++--------
+ perf/inproc_thr.cpp | 12 ++++++------
+ 2 files changed, 14 insertions(+), 14 deletions(-)
+
+commit 4929636cea946892870921162388ecdf39f5267a
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Sun Apr 3 12:51:12 2011 +0100
+
+ Fix merge conflicts
+
+ acinclude.m4 | 6 +++---
+ configure.in | 3 ---
+ 2 files changed, 3 insertions(+), 6 deletions(-)
+
+commit 6641ed81d2d2215f6b0d2aafa30c455eafe00c29
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sun Apr 3 10:37:12 2011 +0200
+
+ Updated NEWS
+
+ NEWS | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+commit 7a5f33ed180303c45b83e224bebaa4d734687fbf
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sun Apr 3 07:36:02 2011 +0200
+
+ Git ignores .gcno files
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ .gitignore | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 1e3ccf94c3b964ebb5b85c76775489ed73d881d1
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Sun Apr 3 07:34:14 2011 +0200
+
+ Additional gcov changes
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ acinclude.m4 | 32 +++++++++++++++++++++-----------
+ 1 files changed, 21 insertions(+), 11 deletions(-)
+
+commit 9014b40901bf87c322f69e656ff77c99e34cf1d1
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Sat Apr 2 22:49:41 2011 +0200
+
+ Added code coverage checking
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ acinclude.m4 | 8 ++++----
+ configure.in | 3 +++
+ 2 files changed, 7 insertions(+), 4 deletions(-)
+
+commit cd299055643ef160e87b7a339cb30aa0bb2eab98
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Sat Apr 2 22:50:46 2011 +0200
+
+ Large rename: AC_ZMQ_ to LIBZMQ_ and ac_zmq_ to libzmq_. Fixes "warning suspicious cache-id"
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ acinclude.m4 | 366 +++++++++++++++++++++++++++++++--------------------------
+ configure.in | 86 +++++++-------
+ 2 files changed, 243 insertions(+), 209 deletions(-)
+
+commit 45f95648b825257f5426263643547a7df9c304b7
+Author: Mikko Koppanen <mkoppanen@php.net>
+Date: Sat Apr 2 22:48:52 2011 +0200
+
+ Add option to build with system opepgm
+
+ Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
+
+ autogen.sh | 6 ++++++
+ configure.in | 17 +++++++++++++++++
+ 2 files changed, 23 insertions(+), 0 deletions(-)
+
+commit c54e54b1c32c602d9a188d4f2318f72d4f3b21f9
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Apr 2 20:17:38 2011 +0200
+
+ Updated NEWS for patches
+
+ NEWS | 28 +++++++++++++++++++++++-----
+ 1 files changed, 23 insertions(+), 5 deletions(-)
+
+commit b4c4648fef62b6aceaad1ab3d47764b9f3c06e47
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sat Apr 2 19:32:44 2011 +0200
+
+ Project location on github changed in README file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ README | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+commit 006b72e73d34edda48a477d62042b3b73dfe5166
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Sat Apr 2 09:22:41 2011 +0200
+
+ Fixed memory leak with threads on win32
+
+ Signed-off-by: Pieter Hintjens <ph@imatix.com>
+
+ src/thread.cpp | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit b65071324288ff5b5c1bfa2439d547a11c40b687
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Sat Apr 2 09:50:35 2011 +0200
+
+ inproc perf tests now work on Windows
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ builds/msvc/inproc_lat/inproc_lat.vcproj | 174 ++++++++++++++++++++++++++++++
+ builds/msvc/inproc_thr/inproc_thr.vcproj | 174 ++++++++++++++++++++++++++++++
+ builds/msvc/msvc.sln | 40 ++++---
+ perf/inproc_lat.cpp | 46 ++++++++-
+ perf/inproc_thr.cpp | 46 ++++++++-
+ 5 files changed, 458 insertions(+), 22 deletions(-)
+
+commit 6da2436ea8944dc8625ccaa005eddc69c5a8942b
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Fri Apr 1 11:55:10 2011 +0200
+
+ inproc_lat and inproc_thr added to .gitignore
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ .gitignore | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+commit e1926d84698cdc2a331123c7d3f6c0d2aa8d8cfd
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Fri Apr 1 11:53:51 2011 +0200
+
+ PGM wire format specification improved in zmq_pgm(7)
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ doc/zmq_pgm.txt | 5 +++++
+ 1 files changed, 5 insertions(+), 0 deletions(-)
+
+commit 1fb5a3ee6e07cdbdef31a5dd1abaf8799a88b1a7
+Author: Martin Sustrik <sustrik@250bpm.com>
+Date: Thu Mar 31 23:16:14 2011 +0200
+
+ Robert G. Jakabosky added to the AUTHORS file
+
+ Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
+
+ AUTHORS | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+commit 0e528fb7029234f490d77ab7d382d47413f85c4e
+Author: Robert G. Jakabosky <bobby@sharedrealm.com>
+Date: Thu Mar 31 23:14:38 2011 +0200
+
+ Adding thread latency/throughput perf. examples.
+
+ Signed-off-by: Robert G. Jakabosky <bobby@sharedrealm.com>
+
+ perf/Makefile.am | 8 ++-
+ perf/inproc_lat.cpp | 190 +++++++++++++++++++++++++++++++++++++++++++++++
+ perf/inproc_thr.cpp | 204 +++++++++++++++++++++++++++++++++++++++++++++++++++
+ 3 files changed, 401 insertions(+), 1 deletions(-)
+
+commit 51d6e1d47d3a2cf13358b83d312236317a53f435
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Mar 30 14:45:29 2011 +0200
+
+ Udated version for next release
+
+ include/zmq.h | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+commit 5684d43eb3a03cb863f920015c5fa52f73977ec8
+Author: Pieter Hintjens <ph@imatix.com>
+Date: Wed Mar 30 14:21:58 2011 +0200
+
+ Fixed whitespace error
+
+ doc/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
commit 3420eb7304ec05e2d7f36ac6f811abf2d0ba8bff
Author: Pieter Hintjens <ph@imatix.com>
Date: Wed Mar 30 14:09:19 2011 +0200