summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index bdff0cf..d3f506d 100644
--- a/configure.in
+++ b/configure.in
@@ -27,9 +27,10 @@ AC_SUBST(PACKAGE_VERSION)
#
# ZeroMQ versions prior to 2.1.0 use 0.0.0 ("unstable")
# ZeroMQ version 2.1.0: 1:0:0
+# ZeroMQ version 2.2.0: 1:1:0
#
# libzmq -version-info current:revision:age
-LTVER="1:0:0"
+LTVER="1:1:0"
AC_SUBST(LTVER)
# Take a copy of original flags
@@ -187,6 +188,8 @@ case "${host_os}" in
AS_IF([test "x$with_dce" != xno],
[AC_CHECK_LIB(dcekt, uuid_create)],
[AC_CHECK_LIB(crypto, RAND_bytes)])
+ LIBZMQ_CHECK_LANG_FLAG_PREPEND([-Ae])
+ AC_CHECK_FUNCS(gethrtime)
;;
*mingw32*)
AC_DEFINE(ZMQ_HAVE_WINDOWS, 1, [Have Windows OS])
@@ -251,6 +254,10 @@ esac
# Check whether to build docs / install man pages
LIBZMQ_CHECK_DOC_BUILD
+# Check polling system
+LIBZMQ_CHECK_POLLER([CPPFLAGS="${CPPFLAGS} -D${libzmq_cv_poller_flag}"],
+ [AC_MSG_ERROR([Unable to continue without polling system])])
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(errno.h arpa/inet.h netinet/tcp.h netinet/in.h stddef.h \
@@ -395,4 +402,3 @@ AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile
foreign/openpgm/Makefile \
builds/redhat/zeromq.spec])
AC_OUTPUT
-