summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 6 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 8cb7712..46c9ce0 100644
--- a/configure.in
+++ b/configure.in
@@ -2,31 +2,22 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
#
-# Change the version number below after doing a public release.
+# The 0MQ version number is extracted from include/zmq.h using
+# the version.sh script. Hence, it should be updated there.
# The version in git should reflect the *next* version planned.
-# Version must be MAJOR.MINOR.PATCH otherwise things will break.
#
-AC_INIT([zeromq],[2.0.9],[zeromq-dev@lists.zeromq.org])
+AC_INIT([zeromq],
+ m4_esyscmd([./version.sh | tr -d '\n']),
+ [zeromq-dev@lists.zeromq.org])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
AM_CONFIG_HEADER(src/platform.hpp)
AM_INIT_AUTOMAKE(tar-ustar dist-zip foreign)
-# This defines PACKAGE_VERSION_... in src/platform.hpp
-PV_MAJOR=`echo $PACKAGE_VERSION | cut -d . -f 1`
-PV_MINOR=`echo $PACKAGE_VERSION | cut -d . -f 2`
-PV_PATCH=`echo $PACKAGE_VERSION | cut -d . -f 3`
-AC_DEFINE_UNQUOTED([PACKAGE_VERSION_MAJOR],[$PV_MAJOR],
- [0MQ major version])
-AC_DEFINE_UNQUOTED([PACKAGE_VERSION_MINOR],[$PV_MINOR],
- [0MQ minor version])
-AC_DEFINE_UNQUOTED([PACKAGE_VERSION_PATCH],[$PV_PATCH],
- [0MQ patchlevel])
# This lets us use PACKAGE_VERSION in Makefiles
AC_SUBST(PACKAGE_VERSION)
-#
# Libtool -version-info (ABI version)
#
# Currently 0.0.0 ("unstable"). Don't change this unless you
@@ -269,7 +260,7 @@ fi
# PGM extension
pgm_ext="no"
-pgm_basename="libpgm-2.1.26"
+pgm_basename="libpgm-2-1-28~dfsg"
AC_SUBST(pgm_basename)
@@ -376,14 +367,3 @@ AC_OUTPUT(Makefile src/Makefile doc/Makefile
devices/zmq_streamer/Makefile devices/zmq_queue/Makefile \
builds/msvc/Makefile)
-# On Linux patch libtool to delete hardcoded paths (rpath).
-case "${host_os}" in
- *linux*)
- sed < libtool > libtool-2 \
- 's/^hardcode_libdir_flag_spec.*$'/'hardcode_libdir_flag_spec=" "/'
- mv libtool-2 libtool
- chmod 755 libtool
- ;;
-esac
-
-