summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in384
1 files changed, 207 insertions, 177 deletions
diff --git a/configure.in b/configure.in
index 46c9ce0..1d85fa9 100644
--- a/configure.in
+++ b/configure.in
@@ -6,104 +6,99 @@ AC_PREREQ(2.61)
# the version.sh script. Hence, it should be updated there.
# The version in git should reflect the *next* version planned.
#
-AC_INIT([zeromq],
- m4_esyscmd([./version.sh | tr -d '\n']),
- [zeromq-dev@lists.zeromq.org])
+AC_INIT([zeromq],[m4_esyscmd([./version.sh])],[zeromq-dev@lists.zeromq.org])
AC_CONFIG_AUX_DIR(config)
AC_CONFIG_MACRO_DIR(config)
AM_CONFIG_HEADER(src/platform.hpp)
AM_INIT_AUTOMAKE(tar-ustar dist-zip foreign)
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
# This lets us use PACKAGE_VERSION in Makefiles
AC_SUBST(PACKAGE_VERSION)
# Libtool -version-info (ABI version)
#
-# Currently 0.0.0 ("unstable"). Don't change this unless you
-# know exactly what you're doing and have read and understand
+# Don't change this unless you know exactly what you're doing and have read and
+# understand:
# http://www.gnu.org/software/libtool/manual/html_node/Updating-version-info.html
#
-# libzmq -version-info
-LTVER="0:0:0"
+# Changes:
+#
+# ZeroMQ versions prior to 2.1.0 use 0.0.0 ("unstable")
+# ZeroMQ version 2.1.0: 1:0:0
+#
+# libzmq -version-info current:revision:age
+LTVER="1:0:0"
AC_SUBST(LTVER)
+# Take a copy of original flags
+ZMQ_ORIG_CFLAGS="${CFLAGS:-none}"
+ZMQ_ORIG_CPPFLAGS="${CPPFLAGS:-none}"
+ZMQ_ORIG_CXXFLAGS="${CXXFLAGS:-none}"
+
# Checks for programs.
AC_PROG_CC
+AC_PROG_CC_C99
AC_PROG_CXX
AM_PROG_CC_C_O
-AC_LIBTOOL_WIN32_DLL
-AC_PROG_LIBTOOL
AC_PROG_SED
AC_PROG_AWK
-# Set a helper variable to indicate GNU C and C++ are in use
-if test "x$GCC" = "xyes" -a "x$GXX" = "xyes"; then
- gnu_compilers="yes"
-else
- gnu_compilers="no"
-fi
-
-# Checks for libraries.
-AC_CHECK_LIB([pthread], [pthread_create])
+AC_ARG_VAR([XMLTO], [Path to xmlto command])
+AC_PATH_PROG([XMLTO], [xmlto])
+AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
+AC_PATH_PROG([ASCIIDOC], [asciidoc])
-# Extra CXXFLAGS are appended at the end of CXXFLAGS for libzmq.
-LIBZMQ_EXTRA_CXXFLAGS=""
+# Libtool configuration for different targets. See acinclude.m4
+AC_ZMQ_CONFIG_LIBTOOL
+AC_LIBTOOL_WIN32_DLL
+AC_PROG_LIBTOOL
-# Extra LDFLAGS are appended at the end of LDFLAGS for libzmq.
-LIBZMQ_EXTRA_LDFLAGS=""
+# Check whether to build a with debug symbols
+AC_ZMQ_CHECK_ENABLE_DEBUG
-# By default compiling with -pedantic except QNX and OSX.
-pedantic="yes"
+# Checks for libraries.
+AC_CHECK_LIB([pthread], [pthread_create])
-#By default compiling with -Werror except OSX.
-werror="yes"
+# Set pedantic
+ac_zmq_pedantic="yes"
-#Whether we are on mingw or not.
-on_mingw32="no"
+# By default compiling with -Werror except OSX.
+ac_zmq_werror="yes"
-# Host speciffic checks
-AC_CANONICAL_HOST
+# By default use DSO visibility
+ac_zmq_dso_visibility="yes"
-# Determine whether or not documentation should be built and installed.
-build_doc="yes"
-install_man="yes"
-# Check for asciidoc and xmlto and don't build the docs if these are not installed.
-AC_CHECK_PROG(have_asciidoc, asciidoc, yes, no)
-AC_CHECK_PROG(have_xmlto, xmlto, yes, no)
-if test "x$have_asciidoc" = "xno" -o "x$have_xmlto" = "xno"; then
- build_doc="no"
- # Tarballs built with 'make dist' ship with prebuilt documentation.
- if ! test -f doc/zmq.7; then
- install_man="no"
- AC_MSG_WARN([You are building an unreleased version of 0MQ and asciidoc or xmlto are not installed. Documentation will not be built and manual pages will not be installed.])
- fi
-fi
-AC_MSG_CHECKING([whether to build documentation])
-AC_MSG_RESULT([$build_doc])
-AC_MSG_CHECKING([whether to install manpages])
-AC_MSG_RESULT([$install_man])
+# Whether we are on mingw or not.
+ac_zmq_on_mingw32="no"
# Set some default features required by 0MQ code.
CPPFLAGS="-D_REENTRANT -D_THREAD_SAFE $CPPFLAGS"
+# For host type checks
+AC_CANONICAL_HOST
+
# OS-specific tests
case "${host_os}" in
*linux*)
- # Define on Linux to enable all library features
- CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
+ # Define on Linux to enable all library features. Define if using a gnu compiler
+ if test "x$GXX" = "xyes"; then
+ CPPFLAGS="-D_GNU_SOURCE $CPPFLAGS"
+ fi
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
- AC_CHECK_LIB(uuid, main, ,
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install uuid-dev.])])
;;
*solaris*)
# Define on Solaris to enable all library features
CPPFLAGS="-D_PTHREADS $CPPFLAGS"
AC_DEFINE(ZMQ_HAVE_SOLARIS, 1, [Have Solaris OS])
- AC_CHECK_LIB(socket, main)
- AC_CHECK_LIB(nsl, main)
- AC_CHECK_LIB(rt, main)
- AC_CHECK_LIB(uuid, main, ,
+ AC_CHECK_LIB(socket, socket)
+ AC_CHECK_LIB(nsl, gethostbyname)
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install uuid-dev.])])
AC_MSG_CHECKING([whether atomic operations can be used])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
@@ -127,10 +122,12 @@ case "${host_os}" in
*darwin*)
# Define on Darwin to enable all library features
CPPFLAGS="-D_DARWIN_C_SOURCE $CPPFLAGS"
- pedantic="no"
- werror="no"
+ ac_zmq_pedantic="no"
+ ac_zmq_werror="no"
AC_DEFINE(ZMQ_HAVE_OSX, 1, [Have DarwinOSX OS])
- LIBZMQ_EXTRA_CXXFLAGS+="-Wno-uninitialized"
+ AC_LANG_PUSH([C++])
+ AC_ZMQ_CHECK_LANG_FLAG_PREPEND([-Wno-uninitialized])
+ AC_LANG_POP([C++])
;;
*netbsd*)
# Define on NetBSD to enable all library features
@@ -139,7 +136,7 @@ case "${host_os}" in
# NetBSD 5.0 and newer provides atomic operations but we can
# only use these on systems where PR #42842 has been fixed so
# we must try and link a test program using C++.
- netbsd_has_atomic=no
+ ac_zmq_netbsd_has_atomic=no
AC_MSG_CHECKING([whether atomic operations can be used])
AC_LANG_PUSH([C++])
AC_LINK_IFELSE([AC_LANG_PROGRAM(
@@ -147,11 +144,11 @@ case "${host_os}" in
[[uint32_t value;
atomic_cas_32 (&value, 0, 0);
return 0;]])],
- [netbsd_has_atomic=yes],
- [netbsd_has_atomic=no])
+ [ac_zmq_netbsd_has_atomic=yes],
+ [ac_zmq_netbsd_has_atomic=no])
AC_LANG_POP([C++])
- AC_MSG_RESULT([$netbsd_has_atomic])
- if test "x$netbsd_has_atomic" = "xno"; then
+ AC_MSG_RESULT([$ac_zmq_netbsd_has_atomic])
+ if test "x$ac_zmq_netbsd_has_atomic" = "xno"; then
AC_DEFINE(ZMQ_FORCE_MUTEXES, 1, [Force to use mutexes])
fi
;;
@@ -161,19 +158,21 @@ case "${host_os}" in
AC_DEFINE(ZMQ_HAVE_OPENBSD, 1, [Have OpenBSD OS])
;;
*nto-qnx*)
- pedantic="no"
+ ac_zmq_pedantic="no"
AC_DEFINE(ZMQ_HAVE_QNXNTO, 1, [Have QNX Neutrino OS])
- AC_CHECK_LIB(socket,main)
- AC_CHECK_LIB(crypto,RAND_bytes)
+ AC_CHECK_LIB(socket, socket)
+ AC_CHECK_LIB(crypto, RAND_bytes)
;;
*aix*)
AC_DEFINE(ZMQ_HAVE_AIX, 1, [Have AIX OS])
+ AC_CHECK_LIB(crypto,RAND_bytes)
;;
*hpux*)
# Define on HP-UX to enable all library features
- CPPFLAGS="-D_POSIX_C_SOURCE=200112L"
+ CPPFLAGS="-D_POSIX_C_SOURCE=200112L $CPPFLAGS"
AC_DEFINE(ZMQ_HAVE_HPUX, 1, [Have HPUX OS])
- AC_CHECK_LIB(rt, main)
+ AC_CHECK_LIB(rt, sem_init)
+ AC_CHECK_LIB(crypto, RAND_bytes)
;;
*mingw32*)
AC_DEFINE(ZMQ_HAVE_WINDOWS, 1, [Have Windows OS])
@@ -185,9 +184,16 @@ case "${host_os}" in
[AC_MSG_ERROR([cannot link with rpcrt4.dll.])])
AC_CHECK_LIB(iphlpapi, main, ,
[AC_MSG_ERROR([cannot link with iphlpapi.dll.])])
- CFLAGS="${CFLAGS} -std=c99"
- on_mingw32="yes"
- install_man="no"
+ # mingw32 defines __int64_t as long long
+ AC_LANG_PUSH([C++])
+ AC_ZMQ_CHECK_LANG_FLAG_PREPEND([-Wno-long-long])
+ AC_LANG_POP([C++])
+ ac_zmq_on_mingw32="yes"
+ ac_zmq_dso_visibility="no"
+
+ if test "x$enable_static" = "xyes"; then
+ AC_MSG_ERROR([Building static libraries is not supported under MinGW32])
+ fi
;;
*cygwin*)
# Define on Cygwin to enable all library features
@@ -195,26 +201,46 @@ case "${host_os}" in
AC_DEFINE(ZMQ_HAVE_CYGWIN, 1, [Have Cygwin])
# Cygwin provides libuuid as part of the e2fsprogs package, and somewhat
# uselessly installs the library in /usr/lib/e2fsprogs
- LDFLAGS="${LDFLAGS} -L/usr/lib/e2fsprogs"
+ LDFLAGS="-L/usr/lib/e2fsprogs ${LDFLAGS}"
AC_CHECK_LIB(uuid, uuid_generate, ,
[AC_MSG_ERROR([cannot link with -luuid, install the e2fsprogs package.])])
+
+ if test "x$enable_static" = "xyes"; then
+ AC_MSG_ERROR([Building static libraries is not supported under Cygwin])
+ fi
;;
*)
AC_MSG_ERROR([unsupported system: ${host_os}.])
;;
esac
+#
+# Check if the compiler supports -fvisibility=hidden flag. MinGW32 uses __declspec
+#
+if test "x$ac_zmq_dso_visibility" = "xyes"; then
+ AC_LANG_PUSH([C])
+ AC_ZMQ_CHECK_LANG_VISIBILITY([LIBZMQ_EXTRA_CFLAGS="$ac_zmq_cv_[]_AC_LANG_ABBREV[]_visibility_flag ${LIBZMQ_EXTRA_CFLAGS}"])
+ AC_LANG_POP([C])
+
+ AC_LANG_PUSH([C++])
+ AC_ZMQ_CHECK_LANG_VISIBILITY([LIBZMQ_EXTRA_CXXFLAGS="$ac_zmq_cv_[]_AC_LANG_ABBREV[]_visibility_flag ${LIBZMQ_EXTRA_CXXFLAGS}"])
+ AC_LANG_POP([C++])
+fi
+
# CPU-specific optimizations
case "${host_cpu}" in
*sparc*)
- if test "x$gnu_compilers" = "xyes"; then
- CPPFLAGS="$CPPFLAGS -mcpu=v9"
- fi
+ AC_LANG_PUSH([C++])
+ AC_ZMQ_CHECK_LANG_FLAG_PREPEND([-mcpu=v9])
+ AC_LANG_POP([C++])
;;
*)
;;
esac
+# Check whether to build docs / install man pages
+AC_ZMQ_CHECK_DOC_BUILD
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS(errno.h arpa/inet.h netinet/tcp.h netinet/in.h stddef.h \
@@ -224,146 +250,150 @@ stdlib.h string.h sys/socket.h sys/time.h unistd.h limits.h)
AC_CHECK_HEADERS(ifaddrs.h, [AC_DEFINE(ZMQ_HAVE_IFADDRS, 1, [Have ifaddrs.h header.])])
# Use c++ in subsequent tests
-AC_LANG(C++)
-
-# pkg-config is used if found, and is required for builds with OpenPGM.
-# However, we need to provide a way to disable it entirely when the user
-# knows what she's doing and it's use is undesirable, such as when
-# cross-compiling.
-AC_ARG_WITH([pkg-config], [AS_HELP_STRING([--without-pkg-config],
- [do not use pkg-config [default=no]])])
-if test "x$with_pkg_config" != "xno"; then
- AC_CHECK_PROG(have_pkg_config, pkg-config, yes, no)
-fi
+AC_LANG_PUSH(C++)
-# Checks for typedefs, structures, and compiler characteristics.
AC_HEADER_STDBOOL
AC_C_CONST
AC_C_INLINE
-AC_TYPE_SIZE_T
-AC_TYPE_SSIZE_T
+# Checks for typedefs, structures, and compiler characteristics.
+if test "x$ac_zmq_cv_[]_AC_LANG_ABBREV[]_intel_compiler" = "xyes"; then
+ dnl 279: controlling expression is constant
+ dnl Fixes build with ICC 12.x
+ AC_ZMQ_CHECK_WITH_FLAG([-wd279], [AC_TYPE_SIZE_T])
+ AC_ZMQ_CHECK_WITH_FLAG([-wd279], [AC_TYPE_SSIZE_T])
+else
+ AC_TYPE_SIZE_T
+ AC_TYPE_SSIZE_T
+fi
AC_HEADER_TIME
AC_TYPE_UINT32_T
AC_C_VOLATILE
-# Substs
-stdint="0"
-if test "x$HAVE_STDINT_H" = "xyes"; then
- stdint="1"
-fi
-
-inttypes="0"
-if test "x$HAVE_INTTYPES_H" = "xyes"; then
- inttypes="1"
-fi
-
# PGM extension
-pgm_ext="no"
+ac_zmq_pgm_ext="no"
-pgm_basename="libpgm-2-1-28~dfsg"
+pgm_basename="libpgm-5.1.114~dfsg"
AC_SUBST(pgm_basename)
AC_ARG_WITH([pgm], [AS_HELP_STRING([--with-pgm],
[build libzmq with PGM extension [default=no]])],
- [with_pgm_ext=yes], [with_pgm_ext=no])
+ [with_pgm_ext=$withval], [with_pgm_ext=no])
if test "x$with_pgm_ext" != "xno"; then
- AC_MSG_CHECKING([if the PGM extension is supported on this platform])
- # OpenPGM is only supported by the vendor on x86 and AMD64 platforms...
- case "${host_cpu}" in
- i*86|x86_64)
- # Supported
- ;;
- *)
- AC_MSG_ERROR([the PGM extension is not supported on the ${host_cpu} platform.])
- ;;
- esac
-
- # ... and on Linux/Windows/Solaris systems.
- case "${host_os}" in
- *linux*|*mingw32*|*solaris*)
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Wno-variadic-macros -Wno-long-long "
- ;;
- *)
- AC_MSG_ERROR([the PGM extension is not supported on system ${host_os}.])
- ;;
- esac
- AC_MSG_RESULT([yes])
+ # This allows placing the tar.gz to foreign/openpgm
+ # and using ./configure --with-pgm=libpgm-x.y.z
+ if test "x$with_pgm_ext" != "xyes"; then
+ pgm_basename="$with_pgm_ext"
+ fi
- # Test if we have pkg-config
- if test "x$with_pkg_config" != "xno"; then
- if test "x$have_pkg_config" != "xyes"; then
- AC_MSG_ERROR([the --with-pgm option requires that pkg-config be installed.]);
- fi
+ # Unpack libpgm
+ AC_MSG_NOTICE([Unpacking ${pgm_basename}.tar.gz])
+ ac_zmq_pwd=`pwd`
+ cd foreign/openpgm
- # Check for OpenPGM dependencies
- PKG_CHECK_MODULES([GLIB], [glib-2.0 gthread-2.0])
- LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} ${GLIB_CFLAGS} "
- LIBZMQ_EXTRA_LDFLAGS="${LIBZMQ_EXTRA_LDFLAGS} ${GLIB_LIBS} "
+ if ! (gzip -dc "${pgm_basename}.tar.gz" || echo "failed") | ${am__untar}; then
+ AC_MSG_ERROR([cannot unpack the foreign/openpgm/${pgm_basename}.tar.gz file])
fi
-
- # Gzip, Perl and Python are required duing PGM build
- AC_CHECK_PROG(have_gzip, gzip, yes, no)
- if test "x$have_gzip" != "xyes"; then
- AC_MSG_ERROR([gzip is required for building the PGM extension.])
- fi
- AC_CHECK_PROG(have_perl, perl, yes, no)
- if test "x$have_perl" != "xyes"; then
- AC_MSG_ERROR([perl is required for building the PGM extension.])
- fi
- AC_CHECK_PROG(have_python, python, yes, no)
- if test "x$have_python" != "xyes"; then
- AC_MSG_ERROR([python is required for building the PGM extension.])
+
+ cd "${ac_zmq_pwd}"
+
+ if test -d foreign/openpgm/build-staging; then
+ rm -rf foreign/openpgm/build-staging
fi
- # Unpack libpgm
- AC_MSG_NOTICE([Unpacking ${pgm_basename}.tar.gz])
- if ! gzip -dc foreign/openpgm/${pgm_basename}.tar.gz | tar -xf - -C foreign/openpgm/; then
- AC_MSG_ERROR([cannot unpack the foreign/openpgm/${pgm_basename}.tar.gz file.])
+ mv foreign/openpgm/${pgm_basename} foreign/openpgm/build-staging
+ pgm_srcdir=foreign/openpgm/build-staging/openpgm/pgm
+
+ if ! test -d foreign/openpgm/build-staging/openpgm/pgm/config; then
+ mkdir foreign/openpgm/build-staging/openpgm/pgm/config
fi
+ AC_SUBST(pgm_srcdir)
+ AC_CONFIG_SUBDIRS([foreign/openpgm/build-staging/openpgm/pgm/])
+
# Success!
AC_DEFINE(ZMQ_HAVE_OPENPGM, 1, [Have OpenPGM extension])
- pgm_ext="yes"
+ ac_zmq_pgm_ext="yes"
fi
-# -Wall, -Werror and -pedantic are GNU compiler specific.
-# Also, these break OpenPGM so don't specify them if we are building with it.
-if test "x$gnu_compilers" = "xyes" -a "x$pgm_ext" = "xno"; then
- CPPFLAGS="-Wall $CPPFLAGS"
+# Set -Wall, -Werror and -pedantic
+AC_LANG_PUSH([C++])
- if test "x$pedantic" = "xyes"; then
- CPPFLAGS="-pedantic $CPPFLAGS"
- fi
+# Check how to enable -Wall
+AC_ZMQ_LANG_WALL([CPPFLAGS="$ac_zmq_cv_[]_AC_LANG_ABBREV[]_wall_flag $CPPFLAGS"])
- if test "x$werror" = "xyes"; then
- CPPFLAGS="-Werror $CPPFLAGS"
- fi
+if test "x$ac_zmq_werror" = "xyes" -a "x$ac_zmq_cv_[]_AC_LANG_ABBREV[]_sun_studio_compiler" != "xyes"; then
+ AC_ZMQ_LANG_WERROR([CPPFLAGS="$ac_zmq_cv_[]_AC_LANG_ABBREV[]_werror_flag $CPPFLAGS"])
fi
-AM_CONDITIONAL(BUILD_PGM, test "x$pgm_ext" = "xyes")
-AM_CONDITIONAL(BUILD_NO_PGM, test "x$pgm_ext" = "xno")
-AM_CONDITIONAL(ON_MINGW, test "x$on_mingw32" = "xyes")
-AM_CONDITIONAL(INSTALL_MAN, test "x$install_man" = "xyes")
-AM_CONDITIONAL(BUILD_DOC, test "x$build_doc" = "xyes")
-
-AC_SUBST(stdint)
-AC_SUBST(inttypes)
-
-# Subst LIBZMQ_EXTRA_CXXFLAGS & LDFLAGS
-AC_SUBST(LIBZMQ_EXTRA_CXXFLAGS)
-AC_SUBST(LIBZMQ_EXTRA_LDFLAGS)
+if test "x$ac_zmq_pedantic" = "xyes"; then
+ AC_ZMQ_LANG_STRICT([CPPFLAGS="$ac_zmq_cv_[]_AC_LANG_ABBREV[]_strict_flag $CPPFLAGS"])
+fi
+AC_LANG_POP([C++])
+AM_CONDITIONAL(BUILD_PGM, test "x$ac_zmq_pgm_ext" = "xyes")
+AM_CONDITIONAL(ON_MINGW, test "x$ac_zmq_on_mingw32" = "xyes")
# Checks for library functions.
AC_TYPE_SIGNAL
AC_CHECK_FUNCS(perror gettimeofday memset socket getifaddrs freeifaddrs)
+AC_CHECK_HEADERS([alloca.h])
+
+if test "x$with_pgm_ext" != "xno"; then
+
+ # Check additional functions for PGM build
+ AC_CHECK_FUNCS(poll epoll_create pselect getopt vasprintf getprotobyname_r2 getprotobyname_r)
+
+ if test "x$ac_cv_func_gettimeofday" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_GETTIMEOFDAY $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_getprotobyname_r2" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_GETPROTOBYNAME_R2 $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_poll" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_POLL $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_epoll_create" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_EPOLL $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_getifaddrs" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_GETIFADDRS $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_getopt" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_GETOPT $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_pselect" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_PSELECT $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_header_alloca_h" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_ALLOCA_H $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_c_compiler_gnu" = "xno"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_ISO_VARARGS $LIBZMQ_EXTRA_CFLAGS"
+ else
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_GNU_VARARGS $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ if test "x$ac_cv_func_vasprintf" = "xyes"; then
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_VASPRINTF $LIBZMQ_EXTRA_CFLAGS"
+ fi
+ case "${host_cpu}" in
+ i*86|x86_64|amd64|*sparc*)
+ LIBZMQ_EXTRA_CFLAGS="-DCONFIG_HAVE_TSC -DCONFIG_HAVE_RTC -DCONFIG_HAVE_HPET $LIBZMQ_EXTRA_CFLAGS"
+ ;;
+ *sparc*|s390*)
+ ;;
+ esac
+fi
+
+# Subst LIBZMQ_EXTRA_CFLAGS & CXXFLAGS & LDFLAGS
+AC_SUBST(LIBZMQ_EXTRA_CFLAGS)
+AC_SUBST(LIBZMQ_EXTRA_CXXFLAGS)
+AC_SUBST(LIBZMQ_EXTRA_LDFLAGS)
-AC_OUTPUT(Makefile src/Makefile doc/Makefile
+AC_CONFIG_FILES([Makefile src/Makefile doc/Makefile
perf/Makefile src/libzmq.pc \
- devices/Makefile devices/zmq_forwarder/Makefile \
- devices/zmq_streamer/Makefile devices/zmq_queue/Makefile \
- builds/msvc/Makefile)
+ builds/msvc/Makefile tests/Makefile])
+AC_OUTPUT