summaryrefslogtreecommitdiff
path: root/src/platform.hpp.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/platform.hpp.in')
-rw-r--r--src/platform.hpp.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/platform.hpp.in b/src/platform.hpp.in
index 1f47133..09943ee 100644
--- a/src/platform.hpp.in
+++ b/src/platform.hpp.in
@@ -1,11 +1,17 @@
/* src/platform.hpp.in. Generated from configure.in by autoheader. */
+/* Define to 1 if you have the <alloca.h> header file. */
+#undef HAVE_ALLOCA_H
+
/* Define to 1 if you have the <arpa/inet.h> header file. */
#undef HAVE_ARPA_INET_H
/* Define to 1 if you have the <dlfcn.h> header file. */
#undef HAVE_DLFCN_H
+/* Define to 1 if you have the `epoll_create' function. */
+#undef HAVE_EPOLL_CREATE
+
/* Define to 1 if you have the <errno.h> header file. */
#undef HAVE_ERRNO_H
@@ -15,6 +21,15 @@
/* Define to 1 if you have the `getifaddrs' function. */
#undef HAVE_GETIFADDRS
+/* Define to 1 if you have the `getopt' function. */
+#undef HAVE_GETOPT
+
+/* Define to 1 if you have the `getprotobyname_r' function. */
+#undef HAVE_GETPROTOBYNAME_R
+
+/* Define to 1 if you have the `getprotobyname_r2' function. */
+#undef HAVE_GETPROTOBYNAME_R2
+
/* Define to 1 if you have the `gettimeofday' function. */
#undef HAVE_GETTIMEOFDAY
@@ -69,6 +84,12 @@
/* Define to 1 if you have the `perror' function. */
#undef HAVE_PERROR
+/* Define to 1 if you have the `poll' function. */
+#undef HAVE_POLL
+
+/* Define to 1 if you have the `pselect' function. */
+#undef HAVE_PSELECT
+
/* Define to 1 if you have the `socket' function. */
#undef HAVE_SOCKET
@@ -105,6 +126,9 @@
/* Define to 1 if you have the <unistd.h> header file. */
#undef HAVE_UNISTD_H
+/* Define to 1 if you have the `vasprintf' function. */
+#undef HAVE_VASPRINTF
+
/* Define to 1 if you have the <windows.h> header file. */
#undef HAVE_WINDOWS_H