summaryrefslogtreecommitdiff
path: root/tests/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.in')
-rw-r--r--tests/Makefile.in21
1 files changed, 17 insertions, 4 deletions
diff --git a/tests/Makefile.in b/tests/Makefile.in
index 2bf15e0..c5a95a7 100644
--- a/tests/Makefile.in
+++ b/tests/Makefile.in
@@ -39,7 +39,8 @@ noinst_PROGRAMS = test_pair_inproc$(EXEEXT) test_pair_tcp$(EXEEXT) \
test_hwm$(EXEEXT) $(am__EXEEXT_1)
@ON_MINGW_FALSE@am__append_1 = test_shutdown_stress \
@ON_MINGW_FALSE@ test_pair_ipc \
-@ON_MINGW_FALSE@ test_reqrep_ipc
+@ON_MINGW_FALSE@ test_reqrep_ipc \
+@ON_MINGW_FALSE@ test_timeo
subdir = tests
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
@@ -58,7 +59,7 @@ CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
@ON_MINGW_FALSE@am__EXEEXT_1 = test_shutdown_stress$(EXEEXT) \
@ON_MINGW_FALSE@ test_pair_ipc$(EXEEXT) \
-@ON_MINGW_FALSE@ test_reqrep_ipc$(EXEEXT)
+@ON_MINGW_FALSE@ test_reqrep_ipc$(EXEEXT) test_timeo$(EXEEXT)
PROGRAMS = $(noinst_PROGRAMS)
am_test_hwm_OBJECTS = test_hwm.$(OBJEXT)
test_hwm_OBJECTS = $(am_test_hwm_OBJECTS)
@@ -100,6 +101,11 @@ am__test_shutdown_stress_SOURCES_DIST = test_shutdown_stress.cpp
test_shutdown_stress_OBJECTS = $(am_test_shutdown_stress_OBJECTS)
test_shutdown_stress_LDADD = $(LDADD)
test_shutdown_stress_DEPENDENCIES = $(top_builddir)/src/libzmq.la
+am__test_timeo_SOURCES_DIST = test_timeo.cpp
+@ON_MINGW_FALSE@am_test_timeo_OBJECTS = test_timeo.$(OBJEXT)
+test_timeo_OBJECTS = $(am_test_timeo_OBJECTS)
+test_timeo_LDADD = $(LDADD)
+test_timeo_DEPENDENCIES = $(top_builddir)/src/libzmq.la
DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/src
depcomp = $(SHELL) $(top_srcdir)/config/depcomp
am__depfiles_maybe = depfiles
@@ -145,12 +151,14 @@ am__v_GEN_0 = @echo " GEN " $@;
SOURCES = $(test_hwm_SOURCES) $(test_pair_inproc_SOURCES) \
$(test_pair_ipc_SOURCES) $(test_pair_tcp_SOURCES) \
$(test_reqrep_inproc_SOURCES) $(test_reqrep_ipc_SOURCES) \
- $(test_reqrep_tcp_SOURCES) $(test_shutdown_stress_SOURCES)
+ $(test_reqrep_tcp_SOURCES) $(test_shutdown_stress_SOURCES) \
+ $(test_timeo_SOURCES)
DIST_SOURCES = $(test_hwm_SOURCES) $(test_pair_inproc_SOURCES) \
$(am__test_pair_ipc_SOURCES_DIST) $(test_pair_tcp_SOURCES) \
$(test_reqrep_inproc_SOURCES) \
$(am__test_reqrep_ipc_SOURCES_DIST) $(test_reqrep_tcp_SOURCES) \
- $(am__test_shutdown_stress_SOURCES_DIST)
+ $(am__test_shutdown_stress_SOURCES_DIST) \
+ $(am__test_timeo_SOURCES_DIST)
ETAGS = etags
CTAGS = ctags
am__tty_colors = \
@@ -303,6 +311,7 @@ test_hwm_SOURCES = test_hwm.cpp
@ON_MINGW_FALSE@test_shutdown_stress_SOURCES = test_shutdown_stress.cpp
@ON_MINGW_FALSE@test_pair_ipc_SOURCES = test_pair_ipc.cpp testutil.hpp
@ON_MINGW_FALSE@test_reqrep_ipc_SOURCES = test_reqrep_ipc.cpp testutil.hpp
+@ON_MINGW_FALSE@test_timeo_SOURCES = test_timeo.cpp
TESTS = $(noinst_PROGRAMS)
all: all-am
@@ -371,6 +380,9 @@ test_reqrep_tcp$(EXEEXT): $(test_reqrep_tcp_OBJECTS) $(test_reqrep_tcp_DEPENDENC
test_shutdown_stress$(EXEEXT): $(test_shutdown_stress_OBJECTS) $(test_shutdown_stress_DEPENDENCIES)
@rm -f test_shutdown_stress$(EXEEXT)
$(AM_V_CXXLD)$(CXXLINK) $(test_shutdown_stress_OBJECTS) $(test_shutdown_stress_LDADD) $(LIBS)
+test_timeo$(EXEEXT): $(test_timeo_OBJECTS) $(test_timeo_DEPENDENCIES)
+ @rm -f test_timeo$(EXEEXT)
+ $(AM_V_CXXLD)$(CXXLINK) $(test_timeo_OBJECTS) $(test_timeo_LDADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
@@ -386,6 +398,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_reqrep_ipc.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_reqrep_tcp.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_shutdown_stress.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/test_timeo.Po@am__quote@
.cpp.o:
@am__fastdepCXX_TRUE@ $(AM_V_CXX)$(CXXCOMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<