summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGabriele Svelto <gabriele.svelto@gmail.com>2012-04-15 14:11:08 +0200
committerMartin Sustrik <sustrik@250bpm.com>2012-04-16 06:11:24 +0200
commit35d748dfa5f846916c32142fc641eae0b5d9b88d (patch)
treec383c6abeb65d440a991b0336de2e471117520a0 /Makefile.am
parentcb89ca70646591a6cb29e81be43c442d6b5d653b (diff)
Improve POSIX threads detection and configuration
POSIX threads support is checked using the AX_PTHREAD macro, this provides improved support and coverage of different platforms. The M4 macros are also moved into the M4 directory. Signed-off-by: Gabriele Svelto <gabriele.svelto@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index be6f649..b249d29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-ACLOCAL_AMFLAGS = -I config
+ACLOCAL_AMFLAGS = -I m4
if BUILD_PGM
SUBDIRS = foreign/openpgm src doc perf tests
@@ -9,12 +9,17 @@ endif
DIST_SUBDIRS = foreign/openpgm src doc perf tests builds/msvc
EXTRA_DIST = \
- autogen.sh \
- version.sh \
+ autogen.sh \
+ m4/ax_pthread.m4 \
+ version.sh \
foreign/openpgm/@pgm_basename@.tar.gz
MAINTAINERCLEANFILES = \
$(srcdir)/aclocal.m4 \
- $(srcdir)/autom4te.cache \
+ $(srcdir)/m4/ltversion.m4 \
+ $(srcdir)/m4/ltoptions.m4 \
+ $(srcdir)/m4/lt~obsolete.m4 \
+ $(srcdir)/m4/libtool.m4 \
+ $(srcdir)/m4/ltsugar.m4 \
$(srcdir)/configure \
`find "$(srcdir)" -type f -name Makefile.in -print`