summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGabriele Svelto <gabriele.svelto@gmail.com>2012-04-30 21:14:04 +0200
committerMartin Sustrik <sustrik@250bpm.com>2012-05-02 09:44:04 +0200
commit357a20ef6feae94c033eed392b025e57fe8eaa81 (patch)
treecf3c151ea004d762d5f1f967a1d49c4c2e6a3229 /configure.ac
parent971cbeda3de6691b212ad18bed9e9f08b278cfe1 (diff)
Conditionally include header files required by select() and poll()
Feature checks are introduced to check for all the headers required by the select() and poll() calls. Include files are then included conditionally without the use of any OS-specific directive. The change also fixes a couple of problems: - Fixed compilation under FreeBSD, NetBSD and OpenBSD when forcing the use of select() in the poller - Quieted a warning mixed-sign comparison warning on FreeBSD caused by FD_SETSIZE being declared as an unsigned constant on that OS - Removed the obsolescent AC_HEADER_TIME macro from the configure script Signed-off-by: Gabriele Svelto <gabriele.svelto@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0d8b404..339cc37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -200,6 +200,7 @@ AC_CHECK_HEADERS([ \
string.h \
sys/socket.h \
sys/time.h \
+ sys/types.h \
time.h \
unistd.h \
limits.h
@@ -359,7 +360,6 @@ AS_IF([test "x$libxs_cv_[]_AC_LANG_ABBREV[]_intel_compiler" = "xyes"], [
AC_TYPE_SSIZE_T
])
-AC_HEADER_TIME
AC_TYPE_UINT32_T
AC_C_VOLATILE