summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGabriele Svelto <gabriele.svelto@gmail.com>2012-04-26 09:17:23 +0200
committerMartin Sustrik <sustrik@250bpm.com>2012-04-27 10:41:10 +0200
commit5b468252036fdbadfab00df743c35a415fbb2adb (patch)
tree835ad625e5ff23dd6bbcd20d2bba4fb66e9a18fe /configure.ac
parent2602a776e520ff12769cac152559b0bf33d5f70f (diff)
Replaced obsolete autoconf and automake macros
This patch cleans up a number of obsolete constructs in the build system, these include: - Replacing AC_TRY_RUN with AC_RUN_IFELSE for the SOCK_CLOEXEC test - Using AC_CONFIG_HEADERS instead of AM_CONFIG_HEADER - Using LT_INIT with the win32-dll parameter instead of the obsolete AC_PROG_LIBTOOL and AC_LIBTOOL_WIN32_DLL macros - Removing the unused and obsolete AC_TYPE_SIGNAL check - Removing the unused alloca.h header check - Replacing the deprecated INCLUDES macro with AM_CPPFLAGS Signed-off-by: Gabriele Svelto <gabriele.svelto@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index b602df5..decbd6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,7 +11,7 @@ AC_INIT([libxs], [m4_esyscmd([./version.sh])],
AC_CONFIG_AUX_DIR([config])
AC_CONFIG_MACRO_DIR([m4])
-AM_CONFIG_HEADER([src/platform.hpp])
+AC_CONFIG_HEADERS([src/platform.hpp])
AM_INIT_AUTOMAKE([tar-ustar dist-zip foreign])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -56,8 +56,7 @@ AC_PATH_PROG([XMLTO], [xmlto])
AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
AC_PATH_PROG([ASCIIDOC], [asciidoc])
LIBXS_CONFIG_LIBTOOL
-AC_LIBTOOL_WIN32_DLL
-AC_PROG_LIBTOOL
+LT_INIT([win32-dll])
# Check whether to build a with debug symbols
LIBXS_CHECK_ENABLE_DEBUG
@@ -459,7 +458,6 @@ AM_CONDITIONAL([BUILD_PGM], [test "x$libxs_pgm_ext" = "xyes"])
AM_CONDITIONAL([ON_MINGW], [test "x$libxs_on_mingw32" = "xyes"])
# Checks for library functions.
-AC_TYPE_SIGNAL
AC_CHECK_FUNCS([ \
perror \
gettimeofday \
@@ -469,7 +467,7 @@ AC_CHECK_FUNCS([ \
getifaddrs \
freeifaddrs
])
-AC_CHECK_HEADERS([alloca.h])
+
LIBXS_CHECK_SOCK_CLOEXEC([
AC_DEFINE([XS_HAVE_SOCK_CLOEXEC], [1],
[Whether SOCK_CLOEXEC is defined and functioning.])