summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGabriele Svelto <gabriele.svelto@gmail.com>2012-02-25 18:06:42 +0100
committerMartin Sustrik <sustrik@250bpm.com>2012-02-26 13:15:50 +0100
commita94f940ade9c9bad030aa1b9d586755f94509901 (patch)
tree7dea988114e8d68d5a8b7dac42be16f6e3112f95 /configure.ac
parent60d709bea971bd99d3b6727465aa0ead0d00beba (diff)
Added a configuration summary print-out to the configure script
Signed-off-by: Gabriele Svelto <gabriele.svelto@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8061d6a..04e2dfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -409,6 +409,36 @@ if test "x$libxs_libzmq_compat" == "xyes"; then
fi
AC_OUTPUT
+# Print configuration
+cat <<EOF | tee -a config.log
+
+## -------------- ##
+## Configuration. ##
+## -------------- ##
+
+Configuration for $PACKAGE_STRING
+ Host OS: $host_os
+ Debugging information: ${enable_debug-no}
+ GCC code coverage reporting: ${XS_GCOV-no}
+ Polling system: $libxs_cv_poller
+ Disable eventfd: $xs_disable_eventfd
+ Build libzmq compatibility library and headers: $libxs_libzmq_compat
+ PGM extension: $with_pgm_ext
+ Use system-provided PGM library: $with_system_pgm_ext
+ Build documentation: $libxs_build_doc
+
+Environment variables:
+ CPPFLAGS: $CPPFLAGS
+ CFLAGS: $CFLAGS
+ CXXFLAGS: $CXXFLAGS
+ LDFLAGS: $LDFLAGS
+
+Installation:
+ Prefix: $prefix
+ Install man pages: $libxs_install_man
+
+EOF
+
if test "x$libxs_libzmq_compat" == "xyes"; then
AC_MSG_WARN([The --enable-libzmq-compat option was specified:])
AC_MSG_WARN([libzmq compatibility library and headers are enabled.])