summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-03-11 20:33:27 +0100
committerMartin Lucina <mato@kotelna.sk>2010-03-11 20:33:27 +0100
commit27e2d08449ea52649e2e42b263f76fbd5d8382c5 (patch)
tree470feaca5d3b14366b1246f6cec8b336f2f71453 /configure.in
parent90944759b66771bbe399922eecedc5095fa2a509 (diff)
Restructure language bindings
C and C++ headers moved from bindings/ to include/, bindings/ removed --with-c and --with-cpp options to configure removed, C and C++ now built and installed by default
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 2 insertions, 30 deletions
diff --git a/configure.in b/configure.in
index afee13d..f630398 100644
--- a/configure.in
+++ b/configure.in
@@ -286,24 +286,6 @@ if test "x$HAVE_INTTYPES_H" = "xyes"; then
inttypes="1"
fi
-# c
-czmq="no"
-AC_ARG_WITH([c], [AS_HELP_STRING([--with-c],
- [build c language binding [default=no]])], [c=yes], [c=no])
-
-if test "x$c" != "xno"; then
- czmq="yes"
-fi
-
-# c++
-cppzmq="no"
-AC_ARG_WITH([cpp], [AS_HELP_STRING([--with-cpp],
- [build c++ language binding [default=no]])], [cpp=yes], [cpp=no])
-
-if test "x$cpp" != "xno"; then
- cppzmq="yes"
-fi
-
# PGM extension
pgm_ext="no"
@@ -323,10 +305,6 @@ if test "x$with_pgm_ext" = "xno" -a "x$with_pgm_examples" = "xyes"; then
AC_MSG_ERROR([cannot configure --with-pgm-examples without --with-pgm.]);
fi
-if test "x$c" = "xno" -a "x$with_pgm_examples" = "xyes"; then
- AC_MSG_ERROR([cannot configure --with-pgm-examples without --with-c.]);
-fi
-
if test "x$with_pgm_ext" != "xno"; then
AC_MSG_CHECKING([if the PGM extension is supported on this platform])
@@ -430,18 +408,12 @@ AC_ARG_WITH([perf], [AS_HELP_STRING([--with-perf],
if test "x$with_perf" != "xno"; then
perf="yes"
-
- if test "x$czmq" = "xno" -a "x$cppzmq" = "xno"; then
- AC_MSG_ERROR([the --with-perf option requires at least one language binding.]);
- fi
fi
if test "x$with_perf" = "xno" -a "x$with_pgm_examples" = "xyes"; then
AC_MSG_ERROR([cannot configure --with-pgm-examples without --with-perf.]);
fi
-AM_CONDITIONAL(BUILD_C, test "x$czmq" = "xyes")
-AM_CONDITIONAL(BUILD_CPP, test "x$cppzmq" = "xyes")
AM_CONDITIONAL(BUILD_PGM, test "x$pgm_ext" = "xyes")
AM_CONDITIONAL(BUILD_NO_PGM, test "x$pgm_ext" = "xno")
AM_CONDITIONAL(BUILD_FORWARDER, test "x$forwarder" = "xyes")
@@ -493,8 +465,8 @@ AC_MSG_RESULT([ ******************************************************** ])
AC_MSG_RESULT([])
AC_MSG_RESULT([ 0MQ install dir: $prefix])
AC_MSG_RESULT([ Language bindings:])
-AC_MSG_RESULT([ C: $czmq])
-AC_MSG_RESULT([ C++: $cppzmq])
+AC_MSG_RESULT([ C: yes])
+AC_MSG_RESULT([ C++: yes])
AC_MSG_RESULT([ Transports:])
AC_MSG_RESULT([ tcp: yes])
AC_MSG_RESULT([ pgm (epgm): $pgm_ext])