summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-02-18 19:38:15 +0100
committerMartin Lucina <mato@kotelna.sk>2010-02-18 19:38:15 +0100
commit2a79a943de417679c562cd4a917e1d1bc19b0d25 (patch)
tree43ce287a60b07a4c4c9ba879606594e2bf6b7b9a /configure.in
parent776b12633981fd95050e138daeeba00a65d9532b (diff)
Add NetBSD support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 314372a..20cd8c5 100644
--- a/configure.in
+++ b/configure.in
@@ -154,6 +154,19 @@ case "${host_os}" in
AC_DEFINE(ZMQ_HAVE_OSX, 1, [Have DarwinOSX OS])
LIBZMQ_EXTRA_CXXFLAGS+="-Wno-uninitialized"
;;
+ *netbsd*)
+ # Define on NetBSD to enable all library features
+ CPPFLAGS="-D_NETBSD_SOURCE $CPPFLAGS"
+ AC_DEFINE(ZMQ_HAVE_NETBSD, 1, [Have NetBSD OS])
+ # NetBSD 5.0 and newer provides atomic operations
+ netbsd_has_atomic=no
+ # XXX As of 5.0.1 the functions declared in atomic.h are
+ # missing "extern C", disable this until upstream fixes it.
+ # AC_CHECK_HEADERS(atomic.h, [netbsd_has_atomic=yes])
+ if test "x$netbsd_has_atomic" = "xno"; then
+ AC_DEFINE(ZMQ_FORCE_MUTEXES, 1, [Force to use mutexes])
+ fi
+ ;;
*openbsd*)
# Define on OpenBSD to enable all library features
CPPFLAGS="-D_BSD_SOURCE $CPPFLAGS"