summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-02-18 17:25:49 +0100
committerMartin Lucina <mato@kotelna.sk>2010-02-18 17:25:49 +0100
commit46824abeb2b016c51f406401d965816f71189aed (patch)
treed75cb7b5f0a69f91ea56e7cc3dfe20739c2cb41b /configure.in
parent8be491b7bdb8525eb37cebf355697c566a482e2d (diff)
Never build docs from tarball releases
This fixes the build_doc logic to work as advertised and never try to (re)build documentation when working with a tarball release.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d43f941..45def38 100644
--- a/configure.in
+++ b/configure.in
@@ -77,9 +77,9 @@ on_mingw32="no"
AC_CANONICAL_HOST
# Determine whether or not documentation should be built.
-build_doc="yes"
+build_doc="no"
install_man="yes"
-if test ! -f "doc/zmq.html"; then
+if test -d ".git"; then
# We are building from git.
# Check for asciidoc and xmlto and don't build the docs if these are not installed.
AC_CHECK_PROG(have_asciidoc, asciidoc, yes, no)
@@ -88,8 +88,17 @@ if test ! -f "doc/zmq.html"; then
build_doc="no"
install_man="no"
AC_MSG_WARN([You are building from git and asciidoc is not installed. Documentation will not be built or installed.])
+ else
+ build_doc="yes"
fi
fi
+AC_MSG_CHECKING([whether to build documentation])
+AC_MSG_RESULT([$build_doc])
+AC_MSG_CHECKING([whether to install manpages])
+if test ! -f "./doc/zmq.7"; then
+ AC_MSG_ERROR([configure thinks we want to install manpages but they're not present. Help!])
+fi
+AC_MSG_RESULT([$install_man])
# Set some default features required by 0MQ code.
CPPFLAGS="-D_REENTRANT -D_THREAD_SAFE $CPPFLAGS"
@@ -639,7 +648,6 @@ AC_MSG_RESULT([ Queue: $queue])
AC_MSG_RESULT([ Performance tests: $perf])
AC_MSG_RESULT([ Examples:])
AC_MSG_RESULT([ Chat: $chat])
-AC_MSG_RESULT([ Documentation: $build_doc])
AC_MSG_RESULT([])
AC_MSG_RESULT([ ******************************************************** ])
AC_MSG_RESULT([])