summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2010-01-28 19:19:25 +0100
committermalosek <malosek@fastmq.com>2010-01-28 19:19:25 +0100
commit4d5e643299e22b53120173319490957b98c0199e (patch)
treedeb6c62470963ab972ae5b03fb799730c7739086 /configure.in
parent849095a042b8326f5789baa04d1dbb7ca36d4632 (diff)
patching libtool script moved at the end of configure
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index a54df77..56fed66 100644
--- a/configure.in
+++ b/configure.in
@@ -58,10 +58,6 @@ case "${host_os}" in
*linux*)
AC_DEFINE(ZMQ_HAVE_LINUX, 1, [Have Linux OS])
CPPFLAGS="-D_REENTRANT $CPPFLAGS"
- sed < libtool > libtool-2 \
- 's/^hardcode_libdir_flag_spec.*$'/'hardcode_libdir_flag_spec=" "/'
- mv libtool-2 libtool
- chmod 755 libtool
AC_CHECK_LIB(uuid, main, ,
[AC_MSG_ERROR([Could not link with libuuid, install develop version.])])
;;
@@ -122,10 +118,6 @@ case "${host_os}" in
CPPFLAGS="-D_THREAD_SAFE $CPPFLAGS"
fi
AC_CHECK_LIB(rt, main)
- sed < libtool > libtool-2 \
- 's/^hardcode_libdir_flag_spec.*$'/'hardcode_libdir_flag_spec=" "/'
- mv libtool-2 libtool
- chmod 755 libtool
;;
*mingw32*)
AC_DEFINE(ZMQ_HAVE_WINDOWS, 1, [Have Windows OS])
@@ -581,6 +573,16 @@ AC_OUTPUT(Makefile src/Makefile man/Makefile bindings/python/Makefile \
devices/zmq_streamer/Makefile devices/zmq_queue/Makefile bindings/Makefile \
examples/Makefile examples/chat/Makefile)
+# On Linux patch libtool to delete hardcoded paths (rpath).
+case "${host_os}" in
+ *linux*)
+ sed < libtool > libtool-2 \
+ 's/^hardcode_libdir_flag_spec.*$'/'hardcode_libdir_flag_spec=" "/'
+ mv libtool-2 libtool
+ chmod 755 libtool
+ ;;
+esac
+
AC_MSG_RESULT([])
AC_MSG_RESULT([ ******************************************************** ])
AC_MSG_RESULT([ 0MQ ])