summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2010-03-12 18:58:29 +0100
committerMartin Sustrik <sustrik@250bpm.com>2010-03-12 18:58:29 +0100
commit66b67fbdf2b047ef7adb8ec018a6fe89dd9cbfca (patch)
tree109d8d7577e77dee0e3c013c32a05ec899dfb4a5 /configure.in
parent430aa533347dcbca57857d318a6898f480967cba (diff)
devices are built unconditionally
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in34
1 files changed, 0 insertions, 34 deletions
diff --git a/configure.in b/configure.in
index e8302c6..2b02382 100644
--- a/configure.in
+++ b/configure.in
@@ -374,33 +374,6 @@ if test "x$werror" = "xyes" -a "x$pgm_ext" = "xno"; then
LIBZMQ_EXTRA_CXXFLAGS="${LIBZMQ_EXTRA_CXXFLAGS} -Werror"
fi
-# Forwarder device
-forwarder="no"
-AC_ARG_WITH([forwarder], [AS_HELP_STRING([--with-forwarder],
- [build forwarder device [default=no]])], [with_forwarder=yes], [with_forwarder=no])
-
-if test "x$with_forwarder" != "xno"; then
- forwarder="yes"
-fi
-
-# Streamer device
-streamer="no"
-AC_ARG_WITH([streamer], [AS_HELP_STRING([--with-streamer],
- [build streamer device [default=no]])], [with_streamer=yes], [with_streamer=no])
-
-if test "x$with_streamer" != "xno"; then
- streamer="yes"
-fi
-
-# Queue device
-queue="no"
-AC_ARG_WITH([queue], [AS_HELP_STRING([--with-queue],
- [build queue device [default=no]])], [with_queue=yes], [with_queue=no])
-
-if test "x$with_queue" != "xno"; then
- queue="yes"
-fi
-
# Perf
perf="no"
AC_ARG_WITH([perf], [AS_HELP_STRING([--with-perf],
@@ -416,9 +389,6 @@ fi
AM_CONDITIONAL(BUILD_PGM, test "x$pgm_ext" = "xyes")
AM_CONDITIONAL(BUILD_NO_PGM, test "x$pgm_ext" = "xno")
-AM_CONDITIONAL(BUILD_FORWARDER, test "x$forwarder" = "xyes")
-AM_CONDITIONAL(BUILD_STREAMER, test "x$streamer" = "xyes")
-AM_CONDITIONAL(BUILD_QUEUE, test "x$queue" = "xyes")
AM_CONDITIONAL(BUILD_PERF, test "x$perf" = "xyes")
AM_CONDITIONAL(ON_MINGW, test "x$on_mingw32" = "xyes")
AM_CONDITIONAL(BUILD_PGM_EXAMPLES, test "x$with_pgm_examples" = "xyes")
@@ -469,10 +439,6 @@ AC_MSG_RESULT([ tcp: yes])
AC_MSG_RESULT([ pgm (epgm): $pgm_ext])
AC_MSG_RESULT([ ipc: yes])
AC_MSG_RESULT([ inproc: yes])
-AC_MSG_RESULT([ Devices:])
-AC_MSG_RESULT([ Forwarder: $forwarder])
-AC_MSG_RESULT([ Streamer: $streamer])
-AC_MSG_RESULT([ Queue: $queue])
AC_MSG_RESULT([ Performance tests: $perf])
AC_MSG_RESULT([])
AC_MSG_RESULT([ ******************************************************** ])