summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2009-10-19 19:00:04 +0200
committermalosek <malosek@fastmq.com>2009-10-19 19:00:04 +0200
commit8b08047cb08dd6ba7ae142007f82607183574ef6 (patch)
treeed083bd0044b1e73d37e980b987d8f761153ee06 /configure.in
parent71e455bfe5dd1df1220e9280e536be56238d2178 (diff)
added --with-pgm2-examples configure option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index be28221..1b1db35 100644
--- a/configure.in
+++ b/configure.in
@@ -406,10 +406,22 @@ AC_ARG_WITH([pgm2], [AS_HELP_STRING([--with-pgm2],
[build libzmq with PGM v2 extension [default=no]])],
[with_pgm2_ext=yes], [with_pgm2_ext=no])
+AC_ARG_WITH([pgm2-examples], [AS_HELP_STRING([--with-pgm2-examples],
+ [build PGM v2 examples [default=no]])],
+ [with_pgm2_examples=yes], [with_pgm2_examples=no])
+
if test "x$with_pgm1_ext" != "xno" -a "x$with_pgm2_ext" != "xno"; then
AC_MSG_ERROR([Can not configure --with-pgm and --with-pgm2.]);
fi
+if test "x$with_pgm2_ext" = "xno" -a "x$with_pgm2_examples" = "xyes"; then
+ AC_MSG_ERROR([Can not configure --with-pgm2-examples without --with-pgm2.]);
+fi
+
+if test "x$c" = "xno" -a "x$with_pgm2_examples" = "xyes"; then
+ AC_MSG_ERROR([Can not configure --with-pgm2-examples without --with-c.]);
+fi
+
if test "x$with_pgm1_ext" != "xno"; then
pgm_basename=${pgm1_basename}
@@ -588,6 +600,10 @@ if test "x$with_perf" != "xno"; then
fi
fi
+if test "x$with_perf" = "xno" -a "x$with_pgm2_examples" = "xyes"; then
+ AC_MSG_ERROR([Can not configure --with-pgm2-examples without --with-perf.]);
+fi
+
AM_CONDITIONAL(BUILD_PYTHON, test "x$pyzmq" = "xyes")
AM_CONDITIONAL(BUILD_JAVA, test "x$jzmq" = "xyes")
AM_CONDITIONAL(BUILD_PYTHON, test "x$pyzmq" = "xyes")
@@ -600,6 +616,7 @@ AM_CONDITIONAL(BUILD_NO_PGM, test "x$pgm2_ext" = "xno" -a "x$pgm1_ext" = "xno")
AM_CONDITIONAL(BUILD_FORWARDER, test "x$forwarder" = "xyes")
AM_CONDITIONAL(BUILD_PERF, test "x$perf" = "xyes")
AM_CONDITIONAL(ON_MINGW, test "x$on_mingw32" = "xyes")
+AM_CONDITIONAL(BUILD_PGM2_EXAMPLES, test "x$with_pgm2_ext" = "xyes")
AC_SUBST(stdint)
AC_SUBST(inttypes)