summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormalosek <malosek@fastmq.com>2009-10-05 10:18:24 +0200
committermalosek <malosek@fastmq.com>2009-10-05 10:18:24 +0200
commite1b9fcd4b185cdcfd460a5d2ecb29d085856bb20 (patch)
treed4443a9756a5739a069307f49d4b5b72cc22d3d9 /configure.in
parent64e68e748607473befbcf2d96590d45dc7bc98db (diff)
moved pgm_create_custom_gsi into PGM1 and drop ssl dependency
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 8 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index d82db7b..78029a3 100644
--- a/configure.in
+++ b/configure.in
@@ -390,11 +390,6 @@ if test "x$with_pgm1_ext" != "xno"; then
;;
esac
- AC_CHECK_HEADERS(openssl/md5.h, [] ,
- [AC_MSG_ERROR([To run configure with --with-pgm option, openssl/md5.h has to be usable.])])
-
- AC_CHECK_LIB(ssl, MD5_Init, , [AC_MSG_ERROR([Could not link with libssl, install develop version.])])
-
AC_CHECK_PROG(have_tar, tar, yes, no)
if test "x$have_tar" != "xyes"; then
AC_MSG_ERROR([Could not find tar.])
@@ -439,6 +434,14 @@ if test "x$with_pgm1_ext" != "xno"; then
AC_MSG_ERROR([Could not apply foreign/openpgm/lost_data_tsi.patch file.])
fi
+ AC_MSG_CHECKING([Patching ${pgm_basename}])
+
+ if patch --silent -p0 < foreign/openpgm/create_custom_gsi.patch; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_ERROR([Could not apply foreign/openpgm/create_custom_gsi.patch file.])
+ fi
+
# Generate galois_tables.c
AC_CONFIG_COMMANDS([galois_tables.c],
[perl foreign/openpgm/libpgm-1.2.14/openpgm/pgm/galois_generator.pl > \
@@ -481,11 +484,6 @@ if test "x$with_pgm2_ext" != "xno"; then
;;
esac
- AC_CHECK_HEADERS(openssl/md5.h, [] ,
- [AC_MSG_ERROR([To run configure with --with-pgm2 option, openssl/md5.h has to be usable.])])
-
- AC_CHECK_LIB(ssl, MD5_Init, , [AC_MSG_ERROR([Could not link with libssl, install develop version.])])
-
if test "x$pyzmq" != "xyes"; then
AC_CHECK_PROG(have_python, python, yes, no)
if test "x$have_python" != "xyes"; then