summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMikko Koppanen <mkoppanen@php.net>2010-11-19 09:10:26 +0100
committerMartin Sustrik <sustrik@250bpm.com>2010-11-19 09:10:26 +0100
commitedf7c18d79b195001d7ed7d05ac30a4d7a64bce1 (patch)
treefd30945917c8cc1a7f7cdc8a30d92d1f1bf4b660 /configure.in
parent945c931daf0c053a9cdbfdbb3ec7d0e90c29fc10 (diff)
Add a check that the compiler actually works.
The patch tests that the C and C++ compilers actually exist and work. autoconf seems to default to 'g++' when C++ compiler is not found, which causes the following error (when the compiler isn't there): checking for uuid_generate in -luuid... no configure: error: cannot link with -luuid, install uuid-dev. The config.log contains the real error message "g++ command not found" but the error message shown to the user is misleading. Signed-off-by: Mikko Koppanen <mkoppanen@php.net>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index fdc682d..27f8bab 100644
--- a/configure.in
+++ b/configure.in
@@ -42,12 +42,16 @@ AC_CONFIG_LIBTOOL
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
-# Check for ICC and Sun Studio compilers
+# For that the compiler works and try to come up with the type
AC_LANG(C)
+AC_CHECK_LANG_COMPILER
+
AC_CHECK_LANG_ICC
AC_CHECK_LANG_SUN_STUDIO
AC_LANG(C++)
+AC_CHECK_LANG_COMPILER
+
AC_CHECK_LANG_ICC
AC_CHECK_LANG_SUN_STUDIO