summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-04-10 16:51:22 +0200
committerMartin Lucina <mato@kotelna.sk>2010-04-10 16:51:22 +0200
commitf6fa41dd7b3677d0f7441db83cbd6c8a0283a499 (patch)
tree1bf42255947c804d757f563c7eb694f3dfe9477a /configure.in
parentc214a24f06bb41885dfbd73e42acb6e043df05ef (diff)
Compile perf tests with the C++ compiler
This lets us build the binaries in a portable fashion w/o having to worry about how to link with the C++ runtime.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index e936cc7..ae944b4 100644
--- a/configure.in
+++ b/configure.in
@@ -55,13 +55,6 @@ fi
# Checks for libraries.
AC_CHECK_LIB([pthread], [pthread_create])
-# If using GNU C/C++ and static linking, libstdc++ must be available.
-if test "x$gnu_compilers" = "xyes" -a "x$enable_shared" = "xno"; then
- # libstdc++ depends on libm on some platforms
- AC_CHECK_LIB([m], [main])
- AC_CHECK_LIB([stdc++], [main], ,
- [AC_MSG_ERROR([cannot link with -lstdc++])])
-fi
# Extra CXXFLAGS are appended at the end of CXXFLAGS for libzmq.
LIBZMQ_EXTRA_CXXFLAGS=""