summaryrefslogtreecommitdiff
path: root/python/Makefile.am
diff options
context:
space:
mode:
authortamara <tamara@jozsi.(none)>2009-08-24 11:17:16 +0200
committertamara <tamara@jozsi.(none)>2009-08-24 11:17:16 +0200
commit77bc3790fa9e781ad26ec881175d22d807e16acf (patch)
treee6c3ba8cea92ecb021c523e125b5c658ed876263 /python/Makefile.am
parent6be4b0143793ab5ceebc5d9d6bbe5c2f1333a0d2 (diff)
python extension added
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
new file mode 100644
index 0000000..effe8b9
--- /dev/null
+++ b/python/Makefile.am
@@ -0,0 +1,7 @@
+INCLUDES = -I$(top_builddir) -I$(top_srcdir) -I$(top_srcdir)/libzmq \
+-I$(top_builddir)/libzmq $(PYTHON_INCLUDES)
+
+pyexec_LTLIBRARIES = libpyzmq.la
+libpyzmq_la_SOURCES = pyzmq.cpp
+libpyzmq_la_LIBADD = $(top_builddir)/src/libzmq.la
+libpyzmq_la_LDFLAGS = -avoid-version