summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPieter Hintjens <ph@imatix.com>2010-08-04 14:38:56 +0200
committerPieter Hintjens <ph@imatix.com>2010-08-04 14:38:56 +0200
commit11a410b65827a3958fb5f417c29e95c1953a0b42 (patch)
tree61b56b2fe34f2318c4fb3a1c56682aedee295bad /src/Makefile.am
parent544b36da68729daffefa8f40d2efed5945851a01 (diff)
Renamed ZMQ_UPSTREAM to ZMQ_PULL, and ZMQ_DOWNSTREAM to ZMQ_PUSH. Left the old
definitions as aliases, to be removed in release 3.0. Also renamed the source files implementing these two socket types. This change does not break existing applications nor bindings, but allows us to fix the documentation and user guide now, rather than keeping the old (confusing) names.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 977b655..19a80d0 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -58,7 +58,7 @@ libzmq_la_SOURCES = app_thread.hpp \
ctx.hpp \
decoder.hpp \
devpoll.hpp \
- downstream.hpp \
+ push.hpp \
encoder.hpp \
epoll.hpp \
err.hpp \
@@ -105,7 +105,7 @@ libzmq_la_SOURCES = app_thread.hpp \
tcp_listener.hpp \
tcp_socket.hpp \
thread.hpp \
- upstream.hpp \
+ pull.hpp \
uuid.hpp \
windows.hpp \
wire.hpp \
@@ -125,7 +125,7 @@ libzmq_la_SOURCES = app_thread.hpp \
command.cpp \
ctx.cpp \
devpoll.cpp \
- downstream.cpp \
+ push.cpp \
epoll.cpp \
err.cpp \
forwarder.cpp \
@@ -160,7 +160,7 @@ libzmq_la_SOURCES = app_thread.hpp \
tcp_listener.cpp \
tcp_socket.cpp \
thread.cpp \
- upstream.cpp \
+ pull.cpp \
uuid.cpp \
xrep.cpp \
xreq.cpp \