summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Lucina <mato@kotelna.sk>2010-03-11 20:33:27 +0100
committerMartin Lucina <mato@kotelna.sk>2010-03-11 20:33:27 +0100
commit27e2d08449ea52649e2e42b263f76fbd5d8382c5 (patch)
tree470feaca5d3b14366b1246f6cec8b336f2f71453 /src/Makefile.am
parent90944759b66771bbe399922eecedc5095fa2a509 (diff)
Restructure language bindings
C and C++ headers moved from bindings/ to include/, bindings/ removed --with-c and --with-cpp options to configure removed, C and C++ now built and installed by default
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 1 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eeb33d6..26106d8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,17 +3,7 @@ lib_LTLIBRARIES = libzmq.la
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libzmq.pc
-if BUILD_CPP
-include_HEADERS = ../bindings/cpp/zmq.hpp ../bindings/c/zmq.h
-endif
-
-if BUILD_C
-if BUILD_CPP
-
-else
-include_HEADERS = ../bindings/c/zmq.h
-endif
-endif
+include_HEADERS = ../include/zmq.h ../include/zmq.hpp
if BUILD_PGM
pgm_sources = ../foreign/openpgm/@pgm_basename@/openpgm/pgm/packet.c \