summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@fastmq.commkdir>2009-07-29 12:07:54 +0200
committerMartin Sustrik <sustrik@fastmq.commkdir>2009-07-29 12:07:54 +0200
commit4ed70a930202b103e7e80b8dc925e0aaa4622595 (patch)
treeaeed881ce17629f81b7c90f7d675aac8ecf69d4f /src/Makefile.am
initial commit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am120
1 files changed, 120 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..bb648ec
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,120 @@
+lib_LTLIBRARIES = libzs.la
+
+libzs_la_SOURCES = \
+ app_thread.hpp \
+ atomic_bitmap.hpp \
+ atomic_counter.hpp \
+ atomic_ptr.hpp \
+ command.hpp \
+ config.hpp \
+ connecter.hpp \
+ data_distributor.hpp \
+ decoder.hpp \
+ devpoll.hpp \
+ dispatcher.hpp \
+ dummy_aggregator.hpp \
+ dummy_distributor.hpp \
+ encoder.hpp \
+ epoll.hpp \
+ err.hpp \
+ fair_aggregator.hpp \
+ fd.hpp \
+ fd_signaler.hpp \
+ io_object.hpp \
+ io_thread.hpp \
+ ip.hpp \
+ i_api.hpp \
+ i_demux.hpp \
+ i_mux.hpp \
+ i_poller.hpp \
+ i_poll_events.hpp \
+ i_session.hpp \
+ i_signaler.hpp \
+ i_engine.hpp \
+ i_thread.hpp \
+ listener.hpp \
+ kqueue.hpp \
+ load_balancer.hpp \
+ msg.hpp \
+ mutex.hpp \
+ object.hpp \
+ p2p.hpp \
+ pipe.hpp \
+ pipe_reader.hpp \
+ pipe_writer.hpp \
+ platform.hpp \
+ poll.hpp \
+ pub.hpp \
+ rep.hpp \
+ req.hpp \
+ safe_object.hpp \
+ select.hpp \
+ session.hpp \
+ session_stub.hpp \
+ simple_semaphore.hpp \
+ socket_base.hpp \
+ sub.hpp \
+ stdint.hpp \
+ tcp_connecter.hpp \
+ tcp_listener.hpp \
+ tcp_socket.hpp \
+ thread.hpp \
+ uuid.hpp \
+ windows.hpp \
+ wire.hpp \
+ ypipe.hpp \
+ ypollset.hpp \
+ yqueue.hpp \
+ zmq_decoder.hpp \
+ zmq_encoder.hpp \
+ zmq_tcp_engine.hpp \
+ app_thread.cpp \
+ connecter.cpp \
+ data_distributor.cpp \
+ devpoll.hpp \
+ dispatcher.cpp \
+ dummy_aggregator.cpp \
+ dummy_distributor.cpp \
+ epoll.cpp \
+ err.cpp \
+ fair_aggregator.cpp \
+ fd_signaler.cpp \
+ io_object.cpp \
+ io_thread.cpp \
+ ip.cpp \
+ kqueue.cpp \
+ listener.cpp \
+ load_balancer.cpp \
+ object.cpp \
+ p2p.cpp \
+ pipe.cpp \
+ pipe_reader.cpp \
+ pipe_writer.cpp \
+ poll.cpp \
+ pub.cpp \
+ rep.cpp \
+ req.cpp \
+ safe_object.cpp \
+ select.cpp \
+ session.cpp \
+ session_stub.cpp \
+ socket_base.cpp \
+ sub.cpp \
+ tcp_connecter.cpp \
+ tcp_listener.cpp \
+ tcp_socket.cpp \
+ thread.cpp \
+ uuid.cpp \
+ ypollset.cpp \
+ zmq_decoder.cpp \
+ zmq_encoder.cpp \
+ zmq_tcp_engine.cpp \
+ zs.cpp
+
+libzs_la_LDFLAGS = -version-info 0:0:0
+libzs_la_CXXFLAGS = -Wall -pedantic -Werror @ZS_EXTRA_CXXFLAGS@
+
+dist-hook:
+ -rm $(distdir)/src/platform.hpp
+
+