summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorMartin Sustrik <sustrik@250bpm.com>2011-07-03 13:33:45 +0200
committerMartin Sustrik <sustrik@250bpm.com>2011-07-03 13:33:45 +0200
commit7c0c79812075459765440ca26bad56f4f7ddbe52 (patch)
tree2d1aa3dd7dbb1dcff8664708bc535d3dae4f2585 /src/Makefile.am
parentde3838403b9a35e7131aae23519ced1f11a3e03c (diff)
Command are now stored in ypipes instead of in socketpairs
Storing commands in OS socket buffers caused whole lot of problems when free space in the buffer ran out. This patch stores commands in ypipes instead and uses socketpair just to signal the other thread, ie. at most one byte is stored in the socketpair at any single instant. Signed-off-by: Martin Sustrik <sustrik@250bpm.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 45e8ac0..9c2fbf1 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -60,6 +60,7 @@ libzmq_la_SOURCES = \
select.hpp \
semaphore.hpp \
session.hpp \
+ signaler.hpp \
socket_base.hpp \
stdint.hpp \
sub.hpp \
@@ -123,6 +124,7 @@ libzmq_la_SOURCES = \
router.cpp \
select.cpp \
session.cpp \
+ signaler.cpp \
socket_base.cpp \
sub.cpp \
tcp_connecter.cpp \